aboutsummaryrefslogtreecommitdiffstats
path: root/devel/atlas-devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-27 20:55:07 +0800
committerbapt <bapt@FreeBSD.org>2014-01-27 20:55:07 +0800
commita65cbd993e214dde0d6c5235bf28c59980b65e06 (patch)
treea0221886e886b949c243dbff4adb3ecdced0def1 /devel/atlas-devel
parent1fe73cb656604719d70e1bba3126651b9828baaa (diff)
downloadfreebsd-ports-gnome-a65cbd993e214dde0d6c5235bf28c59980b65e06.tar.gz
freebsd-ports-gnome-a65cbd993e214dde0d6c5235bf28c59980b65e06.tar.zst
freebsd-ports-gnome-a65cbd993e214dde0d6c5235bf28c59980b65e06.zip
Support stage
Add doc option Simplify the ports to let the ustream build process install the docs, stage will take care of only packaging what we want. add GNU_CONFIGURE to properly let the configure process happen with the ports framework variables set Convert USE_GCC=4.7+ to USES=compiler:c++11-lang which allows to build with clang
Diffstat (limited to 'devel/atlas-devel')
-rw-r--r--devel/atlas-devel/Makefile20
-rw-r--r--devel/atlas-devel/pkg-plist7
2 files changed, 14 insertions, 13 deletions
diff --git a/devel/atlas-devel/Makefile b/devel/atlas-devel/Makefile
index 1eb203a24f8d..c14da924acd7 100644
--- a/devel/atlas-devel/Makefile
+++ b/devel/atlas-devel/Makefile
@@ -3,29 +3,23 @@
PORTNAME= Atlas
PORTVERSION= 0.6.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/worldforge/${PORTNAME}-C%2B%2B%20%28protocol%20lib%29/${PORTVERSION}
DISTNAME= ${PORTNAME}-C++-${PORTVERSION:S/.r/rc/}
MAINTAINER= oliver@FreeBSD.org
-COMMENT= A C++ reference implementation of the Atlas protocol
+COMMENT= C++ reference implementation of the Atlas protocol
+
+OPTIONS_DEFINE= DOCS
PKGNAMESUFFIX= -devel
GNU_CONFIGURE= yes
+USES= pathfix compiler:c++11-lang
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
USE_BZIP2= YES
-USES= pathfix
-USE_GCC= 4.7+
-
+MAKE_ARGS= docdir=${DOCSDIR}
CONFIGURE_ARGS+=--program-transform-name=
-NO_STAGE= yes
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for docfile in README COPYING AUTHORS THANKS NEWS ChangeLog TODO HACKING ROADMAP
- @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
-.endfor
-.endif
-
.include <bsd.port.mk>
diff --git a/devel/atlas-devel/pkg-plist b/devel/atlas-devel/pkg-plist
index 1240c99b533d..9f826e0a664a 100644
--- a/devel/atlas-devel/pkg-plist
+++ b/devel/atlas-devel/pkg-plist
@@ -36,24 +36,31 @@ include/Atlas-C++-0.6/Atlas/Objects/loadDefaults.h
include/Atlas-C++-0.6/Atlas/Objects/objectFactory.h
include/Atlas-C++-0.6/Atlas/Task.h
include/Atlas-C++-0.6/Atlas/Version.h
+lib/libAtlas-0.6.a
lib/libAtlas-0.6.la
lib/libAtlas-0.6.so
lib/libAtlas-0.6.so.2
+lib/libAtlasCodecs-0.6.a
lib/libAtlasCodecs-0.6.la
lib/libAtlasCodecs-0.6.so
lib/libAtlasCodecs-0.6.so.2
+lib/libAtlasFilters-0.6.a
lib/libAtlasFilters-0.6.la
lib/libAtlasFilters-0.6.so
lib/libAtlasFilters-0.6.so.2
+lib/libAtlasFunky-0.6.a
lib/libAtlasFunky-0.6.la
lib/libAtlasFunky-0.6.so
lib/libAtlasFunky-0.6.so.2
+lib/libAtlasMessage-0.6.a
lib/libAtlasMessage-0.6.la
lib/libAtlasMessage-0.6.so
lib/libAtlasMessage-0.6.so.2
+lib/libAtlasNet-0.6.a
lib/libAtlasNet-0.6.la
lib/libAtlasNet-0.6.so
lib/libAtlasNet-0.6.so.2
+lib/libAtlasObjects-0.6.a
lib/libAtlasObjects-0.6.la
lib/libAtlasObjects-0.6.so
lib/libAtlasObjects-0.6.so.2