aboutsummaryrefslogtreecommitdiffstats
path: root/devel/autoconf259/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2003-06-29 09:45:09 +0800
committerade <ade@FreeBSD.org>2003-06-29 09:45:09 +0800
commit4634b60ccc0322844952406dac781ab1c47cb997 (patch)
treeea4e251b5aac054e149903c5b543bc40db7b63fa /devel/autoconf259/Makefile
parenta0e01b7177eac7f42c2f537d44241a9d59bdcf0f (diff)
downloadfreebsd-ports-gnome-4634b60ccc0322844952406dac781ab1c47cb997.tar.gz
freebsd-ports-gnome-4634b60ccc0322844952406dac781ab1c47cb997.tar.zst
freebsd-ports-gnome-4634b60ccc0322844952406dac781ab1c47cb997.zip
Use the cosmetic BUILD_VERSION variable (a la libtool), switch portnames
away from using the version number twice. Unbreak autoconf257, based on work from Rui Lopes <rui@ruilopes.com>
Diffstat (limited to 'devel/autoconf259/Makefile')
-rw-r--r--devel/autoconf259/Makefile51
1 files changed, 28 insertions, 23 deletions
diff --git a/devel/autoconf259/Makefile b/devel/autoconf259/Makefile
index d2b41efd550b..888fa6bc9901 100644
--- a/devel/autoconf259/Makefile
+++ b/devel/autoconf259/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTNAME= autoconf257
+PORTNAME= autoconf
PORTVERSION= 2.57
PORTREVISION= 0
CATEGORIES= devel
@@ -20,32 +20,26 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
help2man:${PORTSDIR}/misc/help2man
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
+BUILD_VERSION= 257
+PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
+LATEST_LINK= autoconf${BUILD_VERSION}
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CONFIG_SHELL=${SH}
CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
-CONFIGURE_ARGS= --program-suffix=257
+CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION} --without-lispdir
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-.if ${PORTNAME} == "autoconf"
-.if exists(${LOCALBASE}/bin/emacs)
-PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
-.elif exists(${LOCALBASE}/bin/xemacs)
-PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
-.else
-PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif # no emacs found
-.endif # ${PORTNAME} == "autoconf"
+GENERIC_TOOLS= config.guess config.sub elisp-comp install-sh mdate-sh \
+ missing mkinstalldirs
-GENERIC_TOOLS= config.guess \
- config.sub \
- elisp-comp \
- install-sh \
- mdate-sh \
- missing \
- mkinstalldirs
+MAN1_PAGES= autoconf autoheader autom4te autoreconf autoscan \
+ autoupdate config.guess config.sub ifnames
+MAN1= ${MAN1_PAGES:S/$/${BUILD_VERSION}.1/g}
.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
pre-everything::
@@ -57,12 +51,23 @@ pre-everything::
@${FALSE}
.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
+post-patch:
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} -E 's,(PACKAGE=autoconf),\1${BUILD_VERSION},' configure)
+ @(cd ${WRKSRC}/man && \
+ for file in *.[1x]; do \
+ ${REINPLACE_CMD} -E 's,([^-]auto)(conf|make|reconf|update|header|scan),\1\2${BUILD_VERSION},g ; \
+ s,(config\.guess|config\.sub|ifnames),\1${BUILD_VERSION},g' $$file ; \
+ done)
+ @(cd ${WRKSRC}/doc && \
+ ${RM} -f *.info && \
+ ${MV} autoconf.texi autoconf${BUILD_VERSION}.texi && \
+ ${MV} standards.texi standards${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(autoconf)\),\1${BUILD_VERSION}\),g' autoconf${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(autoconf|standards)\.(info|texi),\1${BUILD_VERSION}\.\2,g' Makefile.in)
+
post-install:
- ${MKDIR} ${PREFIX}/share/autoconf257
.for FILE in ${GENERIC_TOOLS}
- ${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf257
+ ${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf${BUILD_VERSION}
.endfor
-.include <bsd.port.pre.mk>
-.include "${FILESDIR}/manpages.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>