aboutsummaryrefslogtreecommitdiffstats
path: root/devel/autodia/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-10-06 20:13:53 +0800
committerijliao <ijliao@FreeBSD.org>2001-10-06 20:13:53 +0800
commit0ee46ffcb57551a3c5ab9dd47dbaa957949e06a9 (patch)
treeea47d7361a7d9daec219f5890d1cffe03808a267 /devel/autodia/Makefile
parent5edbbe8a60ea379cc5e34ed21e02663db0dbfcfa (diff)
downloadfreebsd-ports-gnome-0ee46ffcb57551a3c5ab9dd47dbaa957949e06a9.tar.gz
freebsd-ports-gnome-0ee46ffcb57551a3c5ab9dd47dbaa957949e06a9.tar.zst
freebsd-ports-gnome-0ee46ffcb57551a3c5ab9dd47dbaa957949e06a9.zip
add autodia
Automatic Dia XML - from Source Code and Data
Diffstat (limited to 'devel/autodia/Makefile')
-rw-r--r--devel/autodia/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/autodia/Makefile b/devel/autodia/Makefile
new file mode 100644
index 000000000000..3ef677eb6326
--- /dev/null
+++ b/devel/autodia/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# New ports collection makefile for: autodia
+# Date created: Oct 6, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= autodia
+PORTVERSION= 1.0
+CATEGORIES= devel perl5
+MASTER_SITES= http://droogs.org/autodia/download/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+
+USE_BZIP2= yes
+USE_PERL5= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
+ s,%%PERL_VER%%,${PERL_VER},g" ${WRKSRC}/SRC/autodia.pl
+
+do-install:
+ @${MKDIR} ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/autodia
+ ${INSTALL_SCRIPT} ${WRKSRC}/SRC/autodia.pl ${PREFIX}/bin/autodia
+ ${CP} ${WRKSRC}/SRC/*.pm ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/autodia
+ ${CP} ${WRKSRC}/TEMPLATES/* ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/autodia
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/DOC/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>