aboutsummaryrefslogtreecommitdiffstats
path: root/devel/autogen/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-03-13 13:52:31 +0800
committerijliao <ijliao@FreeBSD.org>2001-03-13 13:52:31 +0800
commitaadd1549752f46a8fc3e3b0f5b1e66a9b84b3b3d (patch)
treeb853380dd1c1da91ff530a32f5c05bf35990d8a9 /devel/autogen/Makefile
parentc96062184e968a523a636388dc5c1e5bac6b20db (diff)
downloadfreebsd-ports-gnome-aadd1549752f46a8fc3e3b0f5b1e66a9b84b3b3d.tar.gz
freebsd-ports-gnome-aadd1549752f46a8fc3e3b0f5b1e66a9b84b3b3d.tar.zst
freebsd-ports-gnome-aadd1549752f46a8fc3e3b0f5b1e66a9b84b3b3d.zip
add autogen
AutoGen is a tool designed for generating program files that contain repetitive text with varied substitutions. Its goal is to simplify the maintenance of programs that contain large amounts of repetitious text. This is especially valuable if there are several blocks of such text that must be kept synchronized.
Diffstat (limited to 'devel/autogen/Makefile')
-rw-r--r--devel/autogen/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/autogen/Makefile b/devel/autogen/Makefile
new file mode 100644
index 000000000000..26b388e891e9
--- /dev/null
+++ b/devel/autogen/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection makefile for: autogen
+# Date created: Mar 11, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autogen
+PORTVERSION= 5.1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+
+MAN1= autogen.1 columns.1 getdefs.1
+
+post-install:
+ @${RM} ${PREFIX}/lib/libsnprintfv.la
+
+.include <bsd.port.mk>