aboutsummaryrefslogtreecommitdiffstats
path: root/devel/automake110
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-07-30 03:24:26 +0800
committerade <ade@FreeBSD.org>2004-07-30 03:24:26 +0800
commit596b07969b74806f485a032bced33ebf9c2b776c (patch)
tree8b020ce4f377543ffe04258149bfb03de12082ab /devel/automake110
parentc0e1255de2c93bbfa65f0b06c7ad5eb6a0a877bb (diff)
downloadfreebsd-ports-gnome-596b07969b74806f485a032bced33ebf9c2b776c.tar.gz
freebsd-ports-gnome-596b07969b74806f485a032bced33ebf9c2b776c.tar.zst
freebsd-ports-gnome-596b07969b74806f485a032bced33ebf9c2b776c.zip
Actually put in relevant symlinks to the versioned files in
${PREFIX}/bin to non-versioned files in ${PREFIX}/libexec/<autotool><ver> so that the PATH magic in bsd.autotools.mk works correctly.
Diffstat (limited to 'devel/automake110')
-rw-r--r--devel/automake110/Makefile14
-rw-r--r--devel/automake110/pkg-plist3
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/automake110/Makefile b/devel/automake110/Makefile
index 83d3bda39144..5cd9d41e31cc 100644
--- a/devel/automake110/Makefile
+++ b/devel/automake110/Makefile
@@ -7,7 +7,7 @@
PORTNAME= automake
PORTVERSION= 1.8.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= automake
@@ -48,4 +48,16 @@ post-patch:
)
@${REINPLACE_CMD} -e 's,%%X11BASE%%,${X11BASE},g' ${WRKSRC}/aclocal.in
+pre-install:
+ ${RM} -fr ${PREFIX}/share/automake${BUILD_VERSION}
+ ${MKDIR} ${PREFIX}/share/automake${BUILD_VERSION}
+ ${MKDIR} ${PREFIX}/share/aclocal${BUILD_VERSION}
+ ${MKDIR} ${PREFIX}/libexec/automake${BUILD_VERSION}
+
+post-install:
+.for i in aclocal automake
+ ${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} \
+ ${PREFIX}/libexec/automake${BUILD_VERSION}/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/devel/automake110/pkg-plist b/devel/automake110/pkg-plist
index 3865ef48b0ab..2e307b872175 100644
--- a/devel/automake110/pkg-plist
+++ b/devel/automake110/pkg-plist
@@ -3,6 +3,8 @@ bin/automake%%BUILD_VERSION%%
@unexec install-info --delete %D/info/automake%%BUILD_VERSION%%.info %D/info/dir
info/automake%%BUILD_VERSION%%.info
@exec install-info %D/info/automake%%BUILD_VERSION%%.info %D/info/dir
+libexec/automake%%BUILD_VERSION%%/aclocal
+libexec/automake%%BUILD_VERSION%%/automake
share/aclocal%%BUILD_VERSION%%/amversion.m4
share/aclocal%%BUILD_VERSION%%/as.m4
share/aclocal%%BUILD_VERSION%%/auxdir.m4
@@ -115,3 +117,4 @@ share/automake%%BUILD_VERSION%%/ylwrap
@dirrm share/automake%%BUILD_VERSION%%/Automake
@dirrm share/automake%%BUILD_VERSION%%/am
@dirrm share/automake%%BUILD_VERSION%%
+@dirrm libexec/automake%%BUILD_VERSION%%