aboutsummaryrefslogtreecommitdiffstats
path: root/devel/avr-gcc-3
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2002-09-01 20:13:57 +0800
committerjoerg <joerg@FreeBSD.org>2002-09-01 20:13:57 +0800
commit49c4dcf6b248586f09c63d291882116f8e5bf0e4 (patch)
tree3a94654e8f0b533d721ccb93fd411ea9baa0bd64 /devel/avr-gcc-3
parent572c3a8c7b489e303e5d0a2c2ce6ea2348bb76e8 (diff)
downloadfreebsd-ports-gnome-49c4dcf6b248586f09c63d291882116f8e5bf0e4.tar.gz
freebsd-ports-gnome-49c4dcf6b248586f09c63d291882116f8e5bf0e4.tar.zst
freebsd-ports-gnome-49c4dcf6b248586f09c63d291882116f8e5bf0e4.zip
Update to version 2002.09.01. Included are a couple of private
patches that were floating through the avr-gcc and avr-libc mailinglists, just for the time being until they might have been integrated into gcc's CVS. Portname changed from dashes in the snap date to dots so portupgrade doesn't get confused about it. Thanks to Brian Dean for the hint.
Diffstat (limited to 'devel/avr-gcc-3')
-rw-r--r--devel/avr-gcc-3/Makefile7
-rw-r--r--devel/avr-gcc-3/distinfo2
-rw-r--r--devel/avr-gcc-3/files/patch-16bitassign13
-rw-r--r--devel/avr-gcc-3/files/patch-no-c++-excepts20
-rw-r--r--devel/avr-gcc-3/pkg-plist64
5 files changed, 101 insertions, 5 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 4751a29b34f5..121e41108afc 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcc
-PORTVERSION= 3.3-2002-08-12
+PORTVERSION= 3.3.2002.09.01
CATEGORIES= devel
#MASTER_SITES= ${MASTER_SITE_GNU}
#MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -36,8 +36,7 @@ CONFIGURE_ARGS= --target=avr
MAKE_FLAGS= LANGUAGES="c c++"
-# Only few man pages in this snapshot...
-#MAN1= cpp.1 avr-gcc.1 avr-g++.1 gcov.1
-MAN1= avr-g++.1
+MAN1= cpp.1 avr-gcc.1 avr-g++.1 gcov.1
+MAN7= fsf-funding.7 gfdl.7 gpl.7
.include <bsd.port.mk>
diff --git a/devel/avr-gcc-3/distinfo b/devel/avr-gcc-3/distinfo
index 474eafcbb98d..b657aec104bd 100644
--- a/devel/avr-gcc-3/distinfo
+++ b/devel/avr-gcc-3/distinfo
@@ -1 +1 @@
-MD5 (gcc-core+g++-3.3-2002-08-12.tar.bz2) = 6a55dabdd021433a49c84673d5f4df37
+MD5 (gcc-core+g++-3.3.2002.09.01.tar.bz2) = 6424c3b48736fc0c126374bc44cbbe57
diff --git a/devel/avr-gcc-3/files/patch-16bitassign b/devel/avr-gcc-3/files/patch-16bitassign
new file mode 100644
index 000000000000..6a5659c18290
--- /dev/null
+++ b/devel/avr-gcc-3/files/patch-16bitassign
@@ -0,0 +1,13 @@
+--- gcc/config/avr/avr.c.orig Mon Aug 12 15:13:56 2002
++++ gcc/config/avr/avr.c Thu Aug 29 12:53:14 2002
+@@ -2711,8 +2711,8 @@
+ }
+ }
+ else
+- return *l=2, (AS2 (st ,%0,%A1) CR_TAB
+- AS2 (std,%0+1,%B1));
++ return *l=2, (AS2 (std,%0+1,%B1) CR_TAB
++ AS2 (st ,%0,%A1));
+ }
+ else if (GET_CODE (base) == PLUS)
+ {
diff --git a/devel/avr-gcc-3/files/patch-no-c++-excepts b/devel/avr-gcc-3/files/patch-no-c++-excepts
new file mode 100644
index 000000000000..d738b8228f20
--- /dev/null
+++ b/devel/avr-gcc-3/files/patch-no-c++-excepts
@@ -0,0 +1,20 @@
+Index: gcc/config/avr/avr.h
+===================================================================
+RCS file: /cvsroot/gcc/gcc/gcc/config/avr/avr.h,v
+retrieving revision 1.66
+diff -u -r1.66 avr.h
+--- gcc/config/avr/avr.h 11 Aug 2002 18:48:50 -0000 1.66
++++ gcc/config/avr/avr.h 28 Aug 2002 21:12:06 -0000
+@@ -2523,6 +2523,12 @@
+
+ Do not define this macro if it does not need to do anything. */
+
++#define CC1PLUS_SPEC "%{!frtti:-fno-rtti} \
++ %{!fenforce-eh-specs:-fno-enforce-eh-specs} \
++ %{!fexceptions:-fno-exceptions}"
++/* A C string constant that tells the GNU CC drvier program options to
++ pass to `cc1plus'. */
++
+ #define ASM_SPEC "%{mmcu=*:-mmcu=%*}"
+ /* A C string constant that tells the GNU CC driver program options to
+ pass to the assembler. It can also specify how to translate
diff --git a/devel/avr-gcc-3/pkg-plist b/devel/avr-gcc-3/pkg-plist
index 10882b777365..9809a55d62dd 100644
--- a/devel/avr-gcc-3/pkg-plist
+++ b/devel/avr-gcc-3/pkg-plist
@@ -7,6 +7,70 @@ bin/avr-g++
bin/avr-gcc
bin/avr-gcc-3.3
bin/avr-gccbug
+@unexec install-info --delete %D/info/cpp.info %D/info/dir
+@unexec install-info --delete %D/info/gcc.info %D/info/dir
+@unexec install-info --delete %D/info/gccint.info %D/info/dir
+@unexec install-info --delete %D/info/cppinternals.info %D/info/dir
+info/cpp.info
+info/cpp.info-1
+info/cpp.info-2
+info/cpp.info-3
+info/cpp.info-4
+info/cpp.info-5
+info/cppinternals.info
+info/gcc.info
+info/gcc.info-1
+info/gcc.info-2
+info/gcc.info-3
+info/gcc.info-4
+info/gcc.info-5
+info/gcc.info-6
+info/gcc.info-7
+info/gcc.info-8
+info/gcc.info-9
+info/gcc.info-10
+info/gcc.info-11
+info/gcc.info-12
+info/gcc.info-13
+info/gcc.info-14
+info/gcc.info-15
+info/gcc.info-16
+info/gcc.info-17
+info/gcc.info-18
+info/gcc.info-19
+info/gcc.info-20
+info/gcc.info-21
+info/gcc.info-22
+info/gcc.info-23
+info/gccint.info
+info/gccint.info-1
+info/gccint.info-2
+info/gccint.info-3
+info/gccint.info-4
+info/gccint.info-5
+info/gccint.info-6
+info/gccint.info-7
+info/gccint.info-8
+info/gccint.info-9
+info/gccint.info-10
+info/gccint.info-11
+info/gccint.info-12
+info/gccint.info-13
+info/gccint.info-14
+info/gccint.info-15
+info/gccint.info-16
+info/gccint.info-17
+info/gccint.info-18
+info/gccint.info-19
+info/gccint.info-20
+info/gccint.info-21
+info/gccint.info-22
+info/gccint.info-23
+info/gccint.info-24
+@exec install-info %D/info/cpp.info %D/info/dir
+@exec install-info %D/info/gcc.info %D/info/dir
+@exec install-info %D/info/gccint.info %D/info/dir
+@exec install-info %D/info/cppinternals.info %D/info/dir
lib/charset.alias
lib/gcc-lib/avr/3.3/avr3/libgcc.a
lib/gcc-lib/avr/3.3/avr4/libgcc.a