aboutsummaryrefslogtreecommitdiffstats
path: root/devel/avr-libc
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2004-12-21 22:42:36 +0800
committerjoerg <joerg@FreeBSD.org>2004-12-21 22:42:36 +0800
commit90ba2e11668c4e14d20d752ae62182843858b345 (patch)
treee0bb206d8f6dd3329c22744ec3b96e6117802d47 /devel/avr-libc
parent92b93c98dd6b27db97d038f4aacb0d8f0007eed9 (diff)
downloadfreebsd-ports-gnome-90ba2e11668c4e14d20d752ae62182843858b345.tar.gz
freebsd-ports-gnome-90ba2e11668c4e14d20d752ae62182843858b345.tar.zst
freebsd-ports-gnome-90ba2e11668c4e14d20d752ae62182843858b345.zip
Fix 3 out of 5 portlint warnings. (The remaining 2 are bogus.)
Diffstat (limited to 'devel/avr-libc')
-rw-r--r--devel/avr-libc/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index 6ad57a8b8fab..897f944d0939 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -17,8 +17,7 @@ COMMENT= A C and math library for the Atmel AVR controller family
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils \
- avr-gcc:${PORTSDIR}/devel/avr-gcc \
- ${GMAKE}:${PORTSDIR}/devel/gmake
+ avr-gcc:${PORTSDIR}/devel/avr-gcc
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils \
avr-gcc:${PORTSDIR}/devel/avr-gcc
@@ -29,6 +28,7 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
.endif
USE_BZIP2= yes
+USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
CONFIGURE_SCRIPT= doconf
@@ -54,7 +54,7 @@ do-build:
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE})
do-install:
- rm -f ${TMPPLIST}; cat ${PLIST_DOC} ${PLIST} > ${TMPPLIST}
+ ${RM} -f ${TMPPLIST}; ${CAT} ${PLIST_DOC} ${PLIST} > ${TMPPLIST}
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE} install)
${MKDIR} ${PREFIX}/share/doc/avr-libc
${MKDIR} ${PREFIX}/share/doc/avr-libc/examples