aboutsummaryrefslogtreecommitdiffstats
path: root/devel/avr-libc
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2001-04-20 21:54:18 +0800
committerjoerg <joerg@FreeBSD.org>2001-04-20 21:54:18 +0800
commitdad200a60a7705678cf6775c629595a7d3a32927 (patch)
treec102a1cec7d87667c14def5ae257ed14ecc112ac /devel/avr-libc
parent23e053b7801731e1363ff7c6ec32224fbf3230e7 (diff)
downloadfreebsd-ports-gnome-dad200a60a7705678cf6775c629595a7d3a32927.tar.gz
freebsd-ports-gnome-dad200a60a7705678cf6775c629595a7d3a32927.tar.zst
freebsd-ports-gnome-dad200a60a7705678cf6775c629595a7d3a32927.zip
Upgrade to current version. The tree layout has changed a bit, constants
are now according to Atmel's documentation, etc. pp. Requires an up-to-date avr-gcc.
Diffstat (limited to 'devel/avr-libc')
-rw-r--r--devel/avr-libc/Makefile15
-rw-r--r--devel/avr-libc/distinfo2
-rw-r--r--devel/avr-libc/files/patch-aa29
-rw-r--r--devel/avr-libc/pkg-plist56
4 files changed, 67 insertions, 35 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index 87c1d0ad3814..41db632e6155 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -6,15 +6,9 @@
#
PORTNAME= avr-libc
-PORTVERSION= 20000514
+PORTVERSION= 20010331
CATEGORIES= devel
-# The canonical place for the distfile is:
-#MASTER_SITES= http://www.amelek.gda.pl/avr/libc/
-# ... but until we could convert our avr-gcc to a
-# current version (which is by now only obtainable
-# directly from the gcc CVS repo), resort to the old
-# file here:
-MASTER_SITES= ftp://ftp.ifbus.de/pub/outgoing/
+MASTER_SITES= http://www.amelek.gda.pl/avr/libc/
MAINTAINER= joerg@freebsd.org
@@ -35,8 +29,11 @@ post-install:
${MKDIR} ${PREFIX}/share/doc/avr-libc
${MKDIR} ${PREFIX}/share/doc/avr-libc/examples
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README \
+ ${WRKDIR}/${DISTNAME}/doc/LICENSE \
+ ${WRKDIR}/${DISTNAME}/doc/register-usage.txt \
${PREFIX}/share/doc/avr-libc
- @for f in avr-recv.c io.c prg progmem.c send_byte.s signal.c;\
+ @for f in avr-recv.c io.c prg printf.h progmem.c \
+ send_byte.s signal.c;\
do \
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/examples/$$f \
${PREFIX}/share/doc/avr-libc/examples; \
diff --git a/devel/avr-libc/distinfo b/devel/avr-libc/distinfo
index a5350d78028a..6c10536c9b0b 100644
--- a/devel/avr-libc/distinfo
+++ b/devel/avr-libc/distinfo
@@ -1 +1 @@
-MD5 (avr-libc-20000514.tar.gz) = 90d0a53ea4fa862fc0031633c60a2500
+MD5 (avr-libc-20010331.tar.gz) = 4b7b204cd3b1c1912ea4ed5f0c6dedab
diff --git a/devel/avr-libc/files/patch-aa b/devel/avr-libc/files/patch-aa
index 6d64ded1d5a9..2eeb7ad476d0 100644
--- a/devel/avr-libc/files/patch-aa
+++ b/devel/avr-libc/files/patch-aa
@@ -1,11 +1,20 @@
---- Makefile.orig Mon Feb 7 11:19:03 2000
-+++ Makefile Tue Dec 5 14:23:40 2000
-@@ -17,7 +17,7 @@
- AR = ${target}-ar
- RM = rm
- MD = mkdir -p $@
--INSTALL = install -m644 $^/
-+INSTALL = install -C -m644 $^/
+--- Makefile.orig Sat Mar 31 18:10:42 2001
++++ Makefile Thu Apr 19 23:09:11 2001
+@@ -33,7 +33,7 @@
+ else
+ RM = rm
+ MD = mkdir -p
+- INSTALL = install -m644 $^/
++ INSTALL = install -c -m644 $^/
+ endif
- CFLAGS = -Wall -Wstrict-prototypes -DNO_UNDERSCORES=1
- CFLAGS_DEBUG = -g
+ ASFLAGS = -Wa,-gstabs
+@@ -386,7 +386,7 @@
+ install_lib_dirs = $(libdir) $(libdir)/avr3 $(libdir)/avr4 $(libdir)/avr5
+
+ $(libc_dirs) $(libm_dirs) $(install_lib_dirs) $(includedir):
+- $(MD)
++ $(MD) $@
+
+ ifdef win32
+ win32_make_dirs:
diff --git a/devel/avr-libc/pkg-plist b/devel/avr-libc/pkg-plist
index 4f505eb5d920..b44c18a88e9b 100644
--- a/devel/avr-libc/pkg-plist
+++ b/devel/avr-libc/pkg-plist
@@ -1,19 +1,34 @@
-avr/lib/gcrt1-2313.o
-avr/lib/gcrt1-2323.o
-avr/lib/gcrt1-2333.o
-avr/lib/gcrt1-2343.o
-avr/lib/gcrt1-4414.o
-avr/lib/gcrt1-4433.o
-avr/lib/gcrt1-4434.o
-avr/lib/gcrt1-8515.o
-avr/lib/gcrt1-8535.o
-avr/lib/gcrt1-mega103.o
-avr/lib/gcrt1-mega603.o
-avr/lib/gcrt1-tiny22.o
+avr/lib/crts1200.o
+avr/lib/crttn11.o
+avr/lib/crttn12.o
+avr/lib/crttn15.o
+avr/lib/crttn28.o
+avr/lib/crts2313.o
+avr/lib/crts2323.o
+avr/lib/crts2333.o
+avr/lib/crts2343.o
+avr/lib/crts4414.o
+avr/lib/crts4433.o
+avr/lib/crts4434.o
+avr/lib/crts8515.o
+avr/lib/crts8535.o
+avr/lib/crtc8534.o
+avr/lib/crttn22.o
+avr/lib/avr3/crtm103.o
+avr/lib/avr3/crtm603.o
+avr/lib/avr3/libc.a
+avr/lib/avr3/libm.a
+avr/lib/avr4/crtm83.o
+avr/lib/avr4/libc.a
+avr/lib/avr4/libm.a
+avr/lib/avr5/crtm161.o
+avr/lib/avr5/crtm163.o
+avr/lib/avr5/crtm32.o
+avr/lib/avr5/crtat94k.o
+avr/lib/avr5/libc.a
+avr/lib/avr5/libm.a
avr/lib/libc.a
-avr/lib/libc-mega.a
avr/lib/libm.a
-avr/lib/libm-mega.a
avr/include/ctype.h
avr/include/eeprom.h
avr/include/errno.h
@@ -30,13 +45,17 @@ avr/include/io2343.h
avr/include/io4414.h
avr/include/io4433.h
avr/include/io4434.h
+avr/include/io76c711.h
avr/include/io8515.h
avr/include/io8534.h
avr/include/io8535.h
-avr/include/io94k.h
+avr/include/ioat94k.h
avr/include/iom103.h
avr/include/iom161.h
+avr/include/iom163.h
+avr/include/iom32.h
avr/include/iom603.h
+avr/include/iom83.h
avr/include/iomacros.h
avr/include/iotn11.h
avr/include/iotn12.h
@@ -53,14 +72,21 @@ avr/include/stdlib.h
avr/include/string-avr.h
avr/include/string.h
avr/include/timer.h
+avr/include/twi.h
avr/include/wdt.h
share/doc/avr-libc/README
+share/doc/avr-libc/LICENSE
+share/doc/avr-libc/register-usage.txt
share/doc/avr-libc/avr-lib.pdf
share/doc/avr-libc/examples/avr-recv.c
share/doc/avr-libc/examples/io.c
share/doc/avr-libc/examples/prg
+share/doc/avr-libc/examples/printf.h
share/doc/avr-libc/examples/progmem.c
share/doc/avr-libc/examples/send_byte.s
share/doc/avr-libc/examples/signal.c
+@dirrm avr/lib/avr3
+@dirrm avr/lib/avr4
+@dirrm avr/lib/avr5
@dirrm share/doc/avr-libc/examples
@dirrm share/doc/avr-libc