aboutsummaryrefslogtreecommitdiffstats
path: root/devel/avr-libc
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2002-07-04 03:23:15 +0800
committerjoerg <joerg@FreeBSD.org>2002-07-04 03:23:15 +0800
commitc3fd3adeb238239d3e7ef64faff78c68cf03f11c (patch)
treeda794e82030d9fd51158d7b224402cf2eafcacd0 /devel/avr-libc
parent6e018382ae329a4d8b0ea299d1c07e6f30e7536b (diff)
downloadfreebsd-ports-gnome-c3fd3adeb238239d3e7ef64faff78c68cf03f11c.tar.gz
freebsd-ports-gnome-c3fd3adeb238239d3e7ef64faff78c68cf03f11c.tar.zst
freebsd-ports-gnome-c3fd3adeb238239d3e7ef64faff78c68cf03f11c.zip
Mega-upgrade of the AVR GNU toolchain, part #3:
Upgrade avr-libc. Marek Michalkiewicz largely reorganized the directory structure and the API, in the process of moving all this out to savanna.gnu.org in future. Please note that the API changes are not yet reflected in the documentation. Yet, i chose to make this version available since it is sorely needed to support the new AVR controllers.
Diffstat (limited to 'devel/avr-libc')
-rw-r--r--devel/avr-libc/Makefile14
-rw-r--r--devel/avr-libc/distinfo3
-rw-r--r--devel/avr-libc/files/README.libdoc8
-rw-r--r--devel/avr-libc/files/avr-lib.pdfbin225433 -> 0 bytes
-rw-r--r--devel/avr-libc/pkg-comment2
-rw-r--r--devel/avr-libc/pkg-plist135
6 files changed, 84 insertions, 78 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index ab9dc86b4749..1d65473446b3 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -6,9 +6,13 @@
#
PORTNAME= avr-libc
-PORTVERSION= 20020203
+PORTVERSION= 20020630
CATEGORIES= devel
-MASTER_SITES= http://www.amelek.gda.pl/avr/libc/
+#MASTER_SITES= http://www.amelek.gda.pl/avr/libc/
+MASTER_SITES= http://www.amelek.gda.pl/avr/test/ \
+ http://www.enteract.com/~rneswold/avr/:libdoc
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PDFDOC}:libdoc
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= joerg@freebsd.org
@@ -21,9 +25,11 @@ RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-gcc:${PORTSDIR}/devel/avr-gcc
HAS_CONFIGURE= yes
-CONFIGURE_ENV= CC=avr-gcc
+CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
CONFIGURE_SCRIPT= doconf
+PDFDOC= avr-tools.pdf
+
do-build:
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE})
@@ -43,6 +49,6 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/examples/$$f \
${PREFIX}/share/doc/avr-libc/examples; \
done
- ${INSTALL_DATA} ${FILESDIR}/avr-lib.pdf ${PREFIX}/share/doc/avr-libc
+ ${INSTALL_DATA} ${DISTDIR}/${PDFDOC} ${PREFIX}/share/doc/avr-libc/avr-tools.pdf
.include <bsd.port.mk>
diff --git a/devel/avr-libc/distinfo b/devel/avr-libc/distinfo
index 8a83c9f23f21..3dc1f52d4524 100644
--- a/devel/avr-libc/distinfo
+++ b/devel/avr-libc/distinfo
@@ -1 +1,2 @@
-MD5 (avr-libc-20020203.tar.gz) = fb80cdba885f5ed0f62422393062255f
+MD5 (avr-libc-20020630.tar.gz) = 111ca5283f70a4bd27aa57d3ca7610fa
+MD5 (avr-tools.pdf) = 608234de73631c8dae02155f5770fdb0
diff --git a/devel/avr-libc/files/README.libdoc b/devel/avr-libc/files/README.libdoc
deleted file mode 100644
index 1f063f92d1ba..000000000000
--- a/devel/avr-libc/files/README.libdoc
+++ /dev/null
@@ -1,8 +0,0 @@
-The file avr-lib.pdf has been obtained from
-
-http://www.enteract.com/~rneswold/avr/avr-tools.pdf
-
-It has been renamed to avr-lib.pdf to remain consistent
-with previous versions of the port.
-
-Note that this file is not yet fully up-to-date.
diff --git a/devel/avr-libc/files/avr-lib.pdf b/devel/avr-libc/files/avr-lib.pdf
deleted file mode 100644
index 1d9946a0ca53..000000000000
--- a/devel/avr-libc/files/avr-lib.pdf
+++ /dev/null
Binary files differ
diff --git a/devel/avr-libc/pkg-comment b/devel/avr-libc/pkg-comment
index aec1e6db4396..065154a0d462 100644
--- a/devel/avr-libc/pkg-comment
+++ b/devel/avr-libc/pkg-comment
@@ -1 +1 @@
-a C and math library for the Atmel AVR controller family
+A C and math library for the Atmel AVR controller family
diff --git a/devel/avr-libc/pkg-plist b/devel/avr-libc/pkg-plist
index 5f0fb0f0bf62..ba985dc3a6ae 100644
--- a/devel/avr-libc/pkg-plist
+++ b/devel/avr-libc/pkg-plist
@@ -1,86 +1,91 @@
-avr/lib/crts1200.o
-avr/lib/crttn11.o
-avr/lib/crttn12.o
-avr/lib/crttn15.o
-avr/lib/crttn28.o
-avr/lib/crts2313.o
-avr/lib/crts2323.o
-avr/lib/crts2333.o
-avr/lib/crts2343.o
-avr/lib/crts4414.o
-avr/lib/crts4433.o
-avr/lib/crts4434.o
-avr/lib/crts8515.o
-avr/lib/crts8535.o
-avr/lib/crtc8534.o
-avr/lib/crttn22.o
-avr/lib/avr3/crtm103.o
-avr/lib/avr3/crtm603.o
-avr/lib/avr3/libc.a
-avr/lib/avr3/libm.a
-avr/lib/avr4/crtm83.o
-avr/lib/avr4/libc.a
-avr/lib/avr4/libm.a
-avr/lib/avr5/crtm161.o
-avr/lib/avr5/crtm163.o
-avr/lib/avr5/crtm32.o
-avr/lib/avr5/crtat94k.o
-avr/lib/avr5/libc.a
-avr/lib/avr5/libm.a
-avr/lib/libc.a
-avr/lib/libm.a
+avr/include/avr/crc16.h
+avr/include/avr/eeprom.h
+avr/include/avr/ina90.h
+avr/include/avr/interrupt.h
+avr/include/avr/io.h
+avr/include/avr/io1200.h
+avr/include/avr/io2313.h
+avr/include/avr/io2323.h
+avr/include/avr/io2333.h
+avr/include/avr/io2343.h
+avr/include/avr/io4414.h
+avr/include/avr/io4433.h
+avr/include/avr/io4434.h
+avr/include/avr/io76c711.h
+avr/include/avr/io8515.h
+avr/include/avr/io8534.h
+avr/include/avr/io8535.h
+avr/include/avr/ioat94k.h
+avr/include/avr/iom103.h
+avr/include/avr/iom128.h
+avr/include/avr/iom161.h
+avr/include/avr/iom163.h
+avr/include/avr/iom323.h
+avr/include/avr/iom8.h
+avr/include/avr/iotn11.h
+avr/include/avr/iotn12.h
+avr/include/avr/iotn15.h
+avr/include/avr/iotn22.h
+avr/include/avr/iotn28.h
+avr/include/avr/parity.h
+avr/include/avr/pgmspace.h
+avr/include/avr/sfr_defs.h
+avr/include/avr/signal.h
+avr/include/avr/timer.h
+avr/include/avr/twi.h
+avr/include/avr/wdt.h
avr/include/ctype.h
avr/include/eeprom.h
avr/include/errno.h
avr/include/ina90.h
avr/include/interrupt.h
avr/include/inttypes.h
-avr/include/io-avr.h
avr/include/io.h
-avr/include/io1200.h
-avr/include/io2313.h
-avr/include/io2323.h
-avr/include/io2333.h
-avr/include/io2343.h
-avr/include/io4414.h
-avr/include/io4433.h
-avr/include/io4434.h
-avr/include/io76c711.h
-avr/include/io8515.h
-avr/include/io8534.h
-avr/include/io8535.h
-avr/include/ioat94k.h
-avr/include/iom103.h
-avr/include/iom128.h
-avr/include/iom161.h
-avr/include/iom163.h
-avr/include/iom32.h
-avr/include/iom603.h
-avr/include/iom8.h
-avr/include/iom83.h
-avr/include/iomacros.h
-avr/include/iotn11.h
-avr/include/iotn12.h
-avr/include/iotn15.h
-avr/include/iotn22.h
-avr/include/iotn28.h
avr/include/math.h
avr/include/pgmspace.h
avr/include/progmem.h
avr/include/setjmp.h
avr/include/sig-avr.h
-avr/include/signal.h
avr/include/stdlib.h
-avr/include/string-avr.h
avr/include/string.h
avr/include/timer.h
avr/include/twi.h
avr/include/wdt.h
-share/doc/avr-libc/LICENSE
+avr/lib/avr3/crtm103.o
+avr/lib/avr3/libc.a
+avr/lib/avr3/libm.a
+avr/lib/avr4/crtm8.o
+avr/lib/avr4/libc.a
+avr/lib/avr4/libm.a
+avr/lib/avr5/crtat94k.o
+avr/lib/avr5/crtm128.o
+avr/lib/avr5/crtm161.o
+avr/lib/avr5/crtm163.o
+avr/lib/avr5/crtm323.o
+avr/lib/avr5/libc.a
+avr/lib/avr5/libm.a
+avr/lib/crtc8534.o
+avr/lib/crts1200.o
+avr/lib/crts2313.o
+avr/lib/crts2323.o
+avr/lib/crts2333.o
+avr/lib/crts2343.o
+avr/lib/crts4414.o
+avr/lib/crts4433.o
+avr/lib/crts4434.o
+avr/lib/crts8515.o
+avr/lib/crts8535.o
+avr/lib/crttn11.o
+avr/lib/crttn12.o
+avr/lib/crttn15.o
+avr/lib/crttn22.o
+avr/lib/crttn28.o
+avr/lib/libc.a
+avr/lib/libm.a
share/doc/avr-libc/AUTHORS
-share/doc/avr-libc/register-usage.txt
-share/doc/avr-libc/avr-lib.pdf
+share/doc/avr-libc/LICENSE
share/doc/avr-libc/avr-libc-reference.html
+share/doc/avr-libc/avr-tools.pdf
share/doc/avr-libc/examples/avr-recv.c
share/doc/avr-libc/examples/io.c
share/doc/avr-libc/examples/prg
@@ -88,6 +93,8 @@ share/doc/avr-libc/examples/printf.h
share/doc/avr-libc/examples/progmem.c
share/doc/avr-libc/examples/send_byte.s
share/doc/avr-libc/examples/signal.c
+share/doc/avr-libc/register-usage.txt
+@dirrm avr/include/avr
@dirrm avr/lib/avr3
@dirrm avr/lib/avr4
@dirrm avr/lib/avr5