aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bison175
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2001-12-10 12:41:18 +0800
committerobrien <obrien@FreeBSD.org>2001-12-10 12:41:18 +0800
commitd42fa21499073073fff0e2a243c37789fb8609de (patch)
treefcaf7dec846f895e4af62128aa3ddc8f59b4a4b5 /devel/bison175
parent945d9c93dd23350d970ae98c7612aeb666633211 (diff)
downloadfreebsd-ports-gnome-d42fa21499073073fff0e2a243c37789fb8609de.tar.gz
freebsd-ports-gnome-d42fa21499073073fff0e2a243c37789fb8609de.tar.zst
freebsd-ports-gnome-d42fa21499073073fff0e2a243c37789fb8609de.zip
Back this down to version 1.28 until the Bison developers can acutally
do some regression tests on their later releases. Versions 1.29 and 1.30 seg fault where 1.28 did not.
Diffstat (limited to 'devel/bison175')
-rw-r--r--devel/bison175/Makefile4
-rw-r--r--devel/bison175/distinfo2
-rw-r--r--devel/bison175/files/patch-getargs.c28
-rw-r--r--devel/bison175/files/patch-reader.c33
4 files changed, 33 insertions, 34 deletions
diff --git a/devel/bison175/Makefile b/devel/bison175/Makefile
index 233ff0571062..b490fdb86833 100644
--- a/devel/bison175/Makefile
+++ b/devel/bison175/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bison
-PORTVERSION= 1.30
+PORTVERSION= 1.28
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= bison
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl" \
MAKEINFO="makeinfo --no-split"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= bison.1
diff --git a/devel/bison175/distinfo b/devel/bison175/distinfo
index 39add6c3c6a8..bf42a21c5426 100644
--- a/devel/bison175/distinfo
+++ b/devel/bison175/distinfo
@@ -1 +1 @@
-MD5 (bison-1.30.tar.gz) = 9f86a4166cf9146d0db1ec9a663d7d81
+MD5 (bison-1.28.tar.gz) = 4afb3989f2270043c47c3daa1fa7ffab
diff --git a/devel/bison175/files/patch-getargs.c b/devel/bison175/files/patch-getargs.c
index 60c244d3ca77..a08818ef5ca3 100644
--- a/devel/bison175/files/patch-getargs.c
+++ b/devel/bison175/files/patch-getargs.c
@@ -1,18 +1,18 @@
---- src/getargs.c.orig Sun Sep 23 02:08:44 2001
-+++ src/getargs.c Sun Sep 23 02:09:27 2001
-@@ -35,6 +35,7 @@
- int statistics_flag = 0;
- int yacc_flag = 0; /* for -y */
- int graph_flag = 0;
+--- src/getargs.c.orig Mon Jun 14 15:19:05 1999
++++ src/getargs.c Mon Jan 17 03:38:56 2000
+@@ -31,6 +31,7 @@
+ int noparserflag = 0;
+ int toknumflag = 0;
+ int rawtoknumflag = 0;
+int broken_undeftoken_init;
+ char *spec_name_prefix; /* for -p. */
+ char *spec_file_prefix; /* for -b. */
+ extern int fixed_outfiles;/* for -y */
+@@ -44,6 +45,7 @@
- const char *skeleton = NULL;
-
-@@ -42,6 +43,7 @@
- const char *shortopts = "yvgdhrltknVo:b:p:S:";
- static struct option longopts[] =
+ struct option longopts[] =
{
+ {"broken-undeftoken-init", 0, &broken_undeftoken_init, 1},
- /* Operation modes. */
- {"help", no_argument, 0, 'h'},
- {"version", no_argument, 0, 'V'},
+ {"debug", 0, &debugflag, 1},
+ {"defines", 0, &definesflag, 1},
+ {"file-prefix", 1, 0, 'b'},
diff --git a/devel/bison175/files/patch-reader.c b/devel/bison175/files/patch-reader.c
index 4e0460a0ebe5..29e1146a7e1d 100644
--- a/devel/bison175/files/patch-reader.c
+++ b/devel/bison175/files/patch-reader.c
@@ -1,23 +1,22 @@
---- src/reader.c.orig Sun Sep 23 02:10:06 2001
-+++ src/reader.c Sun Sep 23 02:08:08 2001
-@@ -65,6 +65,8 @@
+--- src/reader.c.orig Mon Jun 14 15:19:05 1999
++++ src/reader.c Mon Jan 17 03:38:56 2000
+@@ -44,6 +44,7 @@
+ int rline_allocated;
- static bucket *errtoken;
- static bucket *undeftoken;
-+
+ extern char *program_name;
+extern int broken_undeftoken_init;
-
-
- /*===================\
-@@ -1959,7 +1961,10 @@
- It is always token number 2. */
- undeftoken = getsym ("$undefined.");
- undeftoken->class = token_sym;
+ extern int definesflag;
+ extern int nolinesflag;
+ extern int noparserflag;
+@@ -199,7 +200,10 @@
+ /* it is always token number 2. */
+ undeftoken = getsym("$undefined.");
+ undeftoken->class = STOKEN;
- undeftoken->user_token_number = 2;
-+ /* XXX ``broken_undeftoken_init'' makes Bison 1.29 bug-compatable
++ /* XXX ``broken_undeftoken_init'' makes Bison 1.28 bug-compatable
+ with Bison 1.25. FreeBSD depends on this behavior when compiling
+ EGCS-1.1.2's cc1plus. */
+ undeftoken->user_token_number = broken_undeftoken_init ? 0 : 2;
-
- /* Read the declaration section. Copy %{ ... %} groups to
- TABLE_OBSTACK and FDEFINES file. Also notice any %token, %left,
+ /* Read the declaration section. Copy %{ ... %} groups to ftable and fdefines file.
+ Also notice any %token, %left, etc. found there. */
+ if (noparserflag)