aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bison2/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-11-12 01:19:39 +0800
committerleeym <leeym@FreeBSD.org>2004-11-12 01:19:39 +0800
commit2faa87eccd5489a1ff13f5577115c113c74cc853 (patch)
treed18b999a4c3982bb1b00a74410f6bd40727e03b9 /devel/bison2/Makefile
parent2713798cdd18ee2cc22c46c4b3e76127762357d8 (diff)
downloadfreebsd-ports-gnome-2faa87eccd5489a1ff13f5577115c113c74cc853.tar.gz
freebsd-ports-gnome-2faa87eccd5489a1ff13f5577115c113c74cc853.tar.zst
freebsd-ports-gnome-2faa87eccd5489a1ff13f5577115c113c74cc853.zip
- relocate CONFLICTS
- add WITHOUT_NLS for USE_GETTEXT - utilize INFO - replace LOCALBASE with PREFIX PR: 72646 Submitted by: leeym Approved by: maintainer timeout
Diffstat (limited to 'devel/bison2/Makefile')
-rw-r--r--devel/bison2/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/devel/bison2/Makefile b/devel/bison2/Makefile
index bed51ea37372..9cbe502f92fa 100644
--- a/devel/bison2/Makefile
+++ b/devel/bison2/Makefile
@@ -15,14 +15,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= seanc@FreeBSD.org
COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
-CONFLICTS= bison-1.7[0-9]*
-
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
+CONFLICTS= bison-1.7[0-9]*
+
NO_LATEST_LINK= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -30,6 +29,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAKEINFO="makeinfo --no-split"
MAN1= bison.1
+INFO= bison
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
.ifdef USE_BISON
.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
@@ -39,6 +47,6 @@ post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
post-install:
- ${LN} -sf ${LOCALBASE}/bin/bison ${LOCALBASE}/bin/bison1875
+ ${LN} -sf ${PREFIX}/bin/bison ${PREFIX}/bin/bison1875
.include <bsd.port.mk>