aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bitkeeper
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-02-25 05:18:08 +0800
committersem <sem@FreeBSD.org>2005-02-25 05:18:08 +0800
commitac42f7701506aaf1c4350df18b134368fb5060ff (patch)
tree2894e5b07b06005669b948edf963c29f1a4b0492 /devel/bitkeeper
parent401f3cf9d7c8fadda4ed84c27804f35c7ba531c1 (diff)
downloadfreebsd-ports-gnome-ac42f7701506aaf1c4350df18b134368fb5060ff.tar.gz
freebsd-ports-gnome-ac42f7701506aaf1c4350df18b134368fb5060ff.tar.zst
freebsd-ports-gnome-ac42f7701506aaf1c4350df18b134368fb5060ff.zip
BitKeeper - Scalable Distributed Software Configuration Management System.
Free for OpenSource projects. PR: ports/77041 Submitted by: Matthias Andree <matthias.andree (at) gmx.de>
Diffstat (limited to 'devel/bitkeeper')
-rw-r--r--devel/bitkeeper/Makefile101
-rw-r--r--devel/bitkeeper/distinfo2
-rw-r--r--devel/bitkeeper/distinfo-52
-rw-r--r--devel/bitkeeper/pkg-descr12
-rw-r--r--devel/bitkeeper/pkg-message4
-rw-r--r--devel/bitkeeper/pkg-plist140
6 files changed, 261 insertions, 0 deletions
diff --git a/devel/bitkeeper/Makefile b/devel/bitkeeper/Makefile
new file mode 100644
index 000000000000..baa5ae3d3c16
--- /dev/null
+++ b/devel/bitkeeper/Makefile
@@ -0,0 +1,101 @@
+# Ports collection Makefile for: devel/bitkeeper
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+# Date created: 2005-01-13
+#
+# $FreeBSD$
+#
+
+# NOTE: unfortunately, bitkeeper hardcodes it path, so moving files around
+# does not work properly, not even for the documentation unfortunately.
+
+# NOTE: we list no MASTER_SITES because the user must fetch the software
+# manually after registering.
+
+PORTNAME= bitkeeper
+PORTVERSION= 3.2.3
+CATEGORIES= devel
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= Scalable Distributed Software Configuration Management System
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+RESTRICTED= "Redistribution is not permitted"
+
+USE_XLIB= yes
+
+MAN1= bk-Basics-Overview.1 bk-Howto-bkd.1 bk-Howto-developer.1 \
+ bk-Howto-setup.1 bk-Howto.1 bk-abort.1 bk-admin.1 \
+ bk-annotate.1 bk-backups.1 bk-base64.1 bk-bin.1 bk-bk.1 \
+ bk-bkcl.1 bk-bkd.1 bk-bkl.1 bk-bkscc.1 bk-c2r.1 bk-cat.1 \
+ bk-changes.1 bk-check.1 bk-checksum.1 bk-chmod.1 bk-ci.1 \
+ bk-citool.1 bk-clean.1 bk-clone.1 bk-cmdlog.1 bk-co.1 \
+ bk-comments.1 bk-commit.1 bk-compatibility.1 bk-config-etc.1 \
+ bk-config-gui.1 bk-config.1 bk-cp.1 bk-crypto.1 bk-cset.1 \
+ bk-csetprune.1 bk-csets.1 bk-csettool.1 bk-delta.1 bk-diffs.1 \
+ bk-difftool.1 bk-edit.1 bk-editor.1 bk-emacs.1 bk-export.1 \
+ bk-extras.1 bk-files.1 bk-findkey.1 bk-fix.1 bk-flags.1 \
+ bk-fmtool.1 bk-gca.1 bk-get.1 bk-gethost.1 bk-getuser.1 \
+ bk-gnupatch.1 bk-gone.1 bk-grep.1 bk-help.1 bk-helptool.1 \
+ bk-history.1 bk-id.1 bk-ignore.1 bk-import.1 bk-info.1 \
+ bk-initscripts.1 bk-isascii.1 bk-key2rev.1 bk-keywords.1 \
+ bk-lease.1 bk-level.1 bk-licensing.1 bk-links.1 bk-lock.1 \
+ bk-lod.1 bk-log.1 bk-makepatch.1 bk-merge-binaries.1 \
+ bk-merge.1 bk-merging.1 bk-more.1 bk-multiuser.1 bk-mv.1 \
+ bk-mvdir.1 bk-names.1 bk-new.1 bk-newroot.1 bk-obscure.1 \
+ bk-openlogging.1 bk-parent.1 bk-path.1 bk-pending.1 \
+ bk-prompt.1 bk-prs.1 bk-pull.1 bk-push.1 bk-r2c.1 bk-range.1 \
+ bk-rcs2sccs.1 bk-rcsparse.1 bk-receive.1 bk-relink.1 \
+ bk-renames.1 bk-renametool.1 bk-renumber.1 bk-repogca.1 \
+ bk-resolve.1 bk-revtool.1 bk-rm.1 bk-rmdel.1 bk-rmdir.1 \
+ bk-rmgone.1 bk-root.1 bk-rset.1 bk-sane.1 bk-sccslog.1 \
+ bk-send.1 bk-sendbug.1 bk-set.1 bk-setup.1 bk-setuptool.1 \
+ bk-sfiles.1 bk-sfio.1 bk-smerge.1 bk-status.1 bk-stripdel.1 \
+ bk-superset.1 bk-support.1 bk-tag.1 bk-takepatch.1 \
+ bk-templates.1 bk-terms.1 bk-treediff.1 bk-triggers.1 \
+ bk-undo.1 bk-undos.1 bk-unedit.1 bk-unlock.1 bk-unpull.1 \
+ bk-unrm.1 bk-unwrap.1 bk-url.1 bk-users.1 bk-version.1 \
+ bk-what.1 bk-wrap.1 bk-xflags.1 bk-zone.1
+MANCOMPRESSED= no
+
+do-install:
+ ${MKDIR} ${WRKSRC}
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DISTNAME} ${WRKSRC}/
+ ${MKDIR} ${PREFIX}/bitkeeper ${PREFIX}/bin
+ ${CHMOD} u+rx ${WRKSRC}/${DISTNAME}
+ BK_NOLINKS=1 ${WRKSRC}/${DISTNAME} ${PREFIX}/bitkeeper
+.for i in admin bk delta get prs rmdel unget
+ ${LN} -s ${PREFIX}/bitkeeper/$i ${PREFIX}/bin
+.endfor
+ for i in ${PREFIX}/bitkeeper/man/man1/bk-* ; do \
+ ${LN} $$i ${PREFIX}/man/man1/ ; \
+ done
+ ${RM} -rf ${PREFIX}/bitkeeper/man
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501000 || ${OSVERSION} > 600000
+DISTNAME= bk-${PORTVERSION}-x86-freebsd4.1.bin
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+.endif
+.else
+DISTNAME= bk-${PORTVERSION}-x86-freebsd5.1.bin
+MD5_FILE= ${MASTERDIR}/distinfo-5
+.endif
+
+.if !exists(${DISTDIR}/${DISTNAME})
+ECHO_MSG= ${PRINTF}
+IGNORE=:\n\
+Because of licensing restrictions, you must fetch the bitkeeper binary\n\
+manually. Please fill in one of the download forms at\n\
+http://www.bitkeeper.com/Products.BK_Pro.Downloads.html and download\n\
+the ${DISTFILES} file and place it in ${DISTDIR}.\n
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/bitkeeper/distinfo b/devel/bitkeeper/distinfo
new file mode 100644
index 000000000000..65e10857ecab
--- /dev/null
+++ b/devel/bitkeeper/distinfo
@@ -0,0 +1,2 @@
+MD5 (bk-3.2.3-x86-freebsd4.1.bin) = 94d116c4790b86e0608e5c76f6f0d258
+SIZE (bk-3.2.3-x86-freebsd4.1.bin) = 3103260
diff --git a/devel/bitkeeper/distinfo-5 b/devel/bitkeeper/distinfo-5
new file mode 100644
index 000000000000..e0b4ade1813f
--- /dev/null
+++ b/devel/bitkeeper/distinfo-5
@@ -0,0 +1,2 @@
+MD5 (bk-3.2.3-x86-freebsd5.1.bin) = 88aec7a9afdd0142f44a9d20238bcc4f
+SIZE (bk-3.2.3-x86-freebsd5.1.bin) = 3114740
diff --git a/devel/bitkeeper/pkg-descr b/devel/bitkeeper/pkg-descr
new file mode 100644
index 000000000000..880207757c14
--- /dev/null
+++ b/devel/bitkeeper/pkg-descr
@@ -0,0 +1,12 @@
+"BK/Pro is a scalable configuration management system, supporting globally
+distributed development, disconnected operation, compressed repositories,
+change sets, and repositories as branches.
+
+Distributed means that every developer gets their own personal repository,
+complete with revision history, and the tool handles moving changes between
+repositories. SSH, RSH, BKD, HTTP, and/or SMTP can all be used as communication
+transports between repositories; or, if both are local, the system just uses
+the file system."
+ -- Bitmover, Inc.
+
+WWW: http://www.bitkeeper.com/Products.BK_Pro.html
diff --git a/devel/bitkeeper/pkg-message b/devel/bitkeeper/pkg-message
new file mode 100644
index 000000000000..2805abd71c61
--- /dev/null
+++ b/devel/bitkeeper/pkg-message
@@ -0,0 +1,4 @@
+WARNING: If you are using the BitKeeper free license, there are some important
+license restrictions, the free license is valid for open source software only,
+not to competitors of BitMover and it terminates in the event that BitMover
+publish a new version of the BitKeeper software, to which you must upgrade.
diff --git a/devel/bitkeeper/pkg-plist b/devel/bitkeeper/pkg-plist
new file mode 100644
index 000000000000..22d2d73534f3
--- /dev/null
+++ b/devel/bitkeeper/pkg-plist
@@ -0,0 +1,140 @@
+bin/admin
+bin/bk
+bin/delta
+bin/get
+bin/prs
+bin/rmdel
+bin/unget
+bitkeeper/RELEASE-NOTES
+bitkeeper/admin
+bitkeeper/applypatch
+bitkeeper/b64wrap
+bitkeeper/bitkeeper.config
+bitkeeper/bk
+bitkeeper/bk.script
+bitkeeper/bk_refcard.pdf
+bitkeeper/bk_refcard.ps
+bitkeeper/bkhelp.txt
+bitkeeper/bkmsg.txt
+bitkeeper/cmp
+bitkeeper/delta
+bitkeeper/diff
+bitkeeper/diff3
+bitkeeper/get
+bitkeeper/gui/bin/bkgui
+bitkeeper/gui/bin/tclsh
+@dirrm bitkeeper/gui/bin
+bitkeeper/gui/images/bklogo.gif
+bitkeeper/gui/images/ci-cset.xbm
+bitkeeper/gui/images/ci-done.xbm
+bitkeeper/gui/images/ci-exclude.xbm
+bitkeeper/gui/images/ci-modified.xbm
+bitkeeper/gui/images/ci-new.xbm
+bitkeeper/gui/images/next.gif
+bitkeeper/gui/images/previous.gif
+@dirrm bitkeeper/gui/images
+bitkeeper/gui/lib/bugform
+bitkeeper/gui/lib/citool
+bitkeeper/gui/lib/csettool
+bitkeeper/gui/lib/difftool
+bitkeeper/gui/lib/fm3tool
+bitkeeper/gui/lib/fmtool
+bitkeeper/gui/lib/helptool
+bitkeeper/gui/lib/installtool
+bitkeeper/gui/lib/msgtool
+bitkeeper/gui/lib/renametool
+bitkeeper/gui/lib/revtool
+bitkeeper/gui/lib/setuptool
+bitkeeper/gui/lib/supportform
+bitkeeper/gui/lib/tcl8.4/auto.tcl
+bitkeeper/gui/lib/tcl8.4/encoding/ascii.enc
+bitkeeper/gui/lib/tcl8.4/encoding/cp1252.enc
+bitkeeper/gui/lib/tcl8.4/encoding/iso8859-1.enc
+bitkeeper/gui/lib/tcl8.4/encoding/iso8859-2.enc
+bitkeeper/gui/lib/tcl8.4/encoding/macRoman.enc
+@dirrm bitkeeper/gui/lib/tcl8.4/encoding
+bitkeeper/gui/lib/tcl8.4/history.tcl
+bitkeeper/gui/lib/tcl8.4/http1.0/http.tcl
+bitkeeper/gui/lib/tcl8.4/http1.0/pkgIndex.tcl
+@dirrm bitkeeper/gui/lib/tcl8.4/http1.0
+bitkeeper/gui/lib/tcl8.4/http2.4/http.tcl
+bitkeeper/gui/lib/tcl8.4/http2.4/pkgIndex.tcl
+@dirrm bitkeeper/gui/lib/tcl8.4/http2.4
+bitkeeper/gui/lib/tcl8.4/init.tcl
+bitkeeper/gui/lib/tcl8.4/ldAix
+bitkeeper/gui/lib/tcl8.4/ldAout.tcl
+bitkeeper/gui/lib/tcl8.4/msgcat1.3/msgcat.tcl
+bitkeeper/gui/lib/tcl8.4/msgcat1.3/pkgIndex.tcl
+@dirrm bitkeeper/gui/lib/tcl8.4/msgcat1.3
+bitkeeper/gui/lib/tcl8.4/opt0.4/optparse.tcl
+bitkeeper/gui/lib/tcl8.4/opt0.4/pkgIndex.tcl
+@dirrm bitkeeper/gui/lib/tcl8.4/opt0.4
+bitkeeper/gui/lib/tcl8.4/package.tcl
+bitkeeper/gui/lib/tcl8.4/parray.tcl
+bitkeeper/gui/lib/tcl8.4/safe.tcl
+bitkeeper/gui/lib/tcl8.4/tclAppInit.c
+bitkeeper/gui/lib/tcl8.4/tclIndex
+bitkeeper/gui/lib/tcl8.4/tcltest2.2/pkgIndex.tcl
+bitkeeper/gui/lib/tcl8.4/tcltest2.2/tcltest.tcl
+@dirrm bitkeeper/gui/lib/tcl8.4/tcltest2.2
+bitkeeper/gui/lib/tcl8.4/word.tcl
+@dirrm bitkeeper/gui/lib/tcl8.4
+bitkeeper/gui/lib/tk8.4/bgerror.tcl
+bitkeeper/gui/lib/tk8.4/button.tcl
+bitkeeper/gui/lib/tk8.4/choosedir.tcl
+bitkeeper/gui/lib/tk8.4/clrpick.tcl
+bitkeeper/gui/lib/tk8.4/comdlg.tcl
+bitkeeper/gui/lib/tk8.4/console.tcl
+bitkeeper/gui/lib/tk8.4/dialog.tcl
+bitkeeper/gui/lib/tk8.4/entry.tcl
+bitkeeper/gui/lib/tk8.4/focus.tcl
+bitkeeper/gui/lib/tk8.4/listbox.tcl
+bitkeeper/gui/lib/tk8.4/menu.tcl
+bitkeeper/gui/lib/tk8.4/mkpsenc.tcl
+bitkeeper/gui/lib/tk8.4/msgbox.tcl
+bitkeeper/gui/lib/tk8.4/msgs/cs.msg
+bitkeeper/gui/lib/tk8.4/msgs/de.msg
+bitkeeper/gui/lib/tk8.4/msgs/el.msg
+bitkeeper/gui/lib/tk8.4/msgs/en.msg
+bitkeeper/gui/lib/tk8.4/msgs/en_gb.msg
+bitkeeper/gui/lib/tk8.4/msgs/es.msg
+bitkeeper/gui/lib/tk8.4/msgs/fr.msg
+bitkeeper/gui/lib/tk8.4/msgs/it.msg
+bitkeeper/gui/lib/tk8.4/msgs/nl.msg
+bitkeeper/gui/lib/tk8.4/msgs/ru.msg
+@dirrm bitkeeper/gui/lib/tk8.4/msgs
+bitkeeper/gui/lib/tk8.4/obsolete.tcl
+bitkeeper/gui/lib/tk8.4/optMenu.tcl
+bitkeeper/gui/lib/tk8.4/palette.tcl
+bitkeeper/gui/lib/tk8.4/panedwindow.tcl
+bitkeeper/gui/lib/tk8.4/prolog.ps
+bitkeeper/gui/lib/tk8.4/safetk.tcl
+bitkeeper/gui/lib/tk8.4/scale.tcl
+bitkeeper/gui/lib/tk8.4/scrlbar.tcl
+bitkeeper/gui/lib/tk8.4/spinbox.tcl
+bitkeeper/gui/lib/tk8.4/tclIndex
+bitkeeper/gui/lib/tk8.4/tearoff.tcl
+bitkeeper/gui/lib/tk8.4/text.tcl
+bitkeeper/gui/lib/tk8.4/tk.tcl
+bitkeeper/gui/lib/tk8.4/tkAppInit.c
+bitkeeper/gui/lib/tk8.4/tkfbox.tcl
+bitkeeper/gui/lib/tk8.4/unsupported.tcl
+bitkeeper/gui/lib/tk8.4/xmfbox.tcl
+@dirrm bitkeeper/gui/lib/tk8.4
+@dirrm bitkeeper/gui/lib
+@dirrm bitkeeper/gui
+bitkeeper/gzip_b64wrap
+bitkeeper/gzip_uuwrap
+bitkeeper/import
+bitkeeper/patch
+bitkeeper/prs
+bitkeeper/resync
+bitkeeper/rmdel
+bitkeeper/sdiff
+bitkeeper/unb64wrap
+bitkeeper/unget
+bitkeeper/ungzip_b64wrap
+bitkeeper/ungzip_uuwrap
+bitkeeper/unuuwrap
+bitkeeper/uuwrap
+@dirrm bitkeeper