aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bnfc/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-27 15:37:57 +0800
committermiwi <miwi@FreeBSD.org>2007-03-27 15:37:57 +0800
commitaa8c041ebf278c731857f534253e59abefdddfa9 (patch)
treeec37c7e21d0ed20fca4d5479f4133a24c929f356 /devel/bnfc/Makefile
parentc69529b72d4efdeaaeee9334665205365e36924d (diff)
downloadfreebsd-ports-gnome-aa8c041ebf278c731857f534253e59abefdddfa9.tar.gz
freebsd-ports-gnome-aa8c041ebf278c731857f534253e59abefdddfa9.tar.zst
freebsd-ports-gnome-aa8c041ebf278c731857f534253e59abefdddfa9.zip
- Fix the permission of bin/bnfc, binary executable should use INSTALL_PROGRAM
- NOPORTDOCS shoule not apply to things in EXAMPLESDIR - We can use bsd.port.mk in this port PR: 110852 Submitted by: Li-Wen Hsu <lwhsu@lwhsu.org> Approved by: maintainer
Diffstat (limited to 'devel/bnfc/Makefile')
-rw-r--r--devel/bnfc/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/bnfc/Makefile b/devel/bnfc/Makefile
index 3bd6fe2a9cf8..bb4b478d0c2d 100644
--- a/devel/bnfc/Makefile
+++ b/devel/bnfc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bnfc
PORTVERSION= 2.3b
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.cs.chalmers.se/~markus/BNFC/ \
http://www.cs.chalmers.se/Cs/Grundutb/Kurser/komp/current/resources/
@@ -20,18 +21,17 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
do-install:
- ${INSTALL_DATA} ${WRKSRC}/bnfc ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bnfc ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
post-install:
+ ${RM} -f ${WRKSRC}/examples/.cvsignore
${RM} -f ${WRKSRC}/examples/haskell-core/.cvsignore
${MKDIR} ${EXAMPLESDIR}
- ${CP} -pR ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/LBNF-report.tex ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>