aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boehm-gc/files
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-12-15 13:53:43 +0800
committerstas <stas@FreeBSD.org>2009-12-15 13:53:43 +0800
commit0047a8715098e98721ac79f5523d4b3b52147448 (patch)
tree6789e87f9641e55765135829c9b5282c050385ab /devel/boehm-gc/files
parent3455b466b5a3dcb7774d5838ef4991cc5f3b8119 (diff)
downloadfreebsd-ports-gnome-0047a8715098e98721ac79f5523d4b3b52147448.tar.gz
freebsd-ports-gnome-0047a8715098e98721ac79f5523d4b3b52147448.tar.zst
freebsd-ports-gnome-0047a8715098e98721ac79f5523d4b3b52147448.zip
- Update to 7.1.
Diffstat (limited to 'devel/boehm-gc/files')
-rw-r--r--devel/boehm-gc/files/patch-Makefile.in (renamed from devel/boehm-gc/files/patch-doc:Makefile.in)8
-rw-r--r--devel/boehm-gc/files/patch-dbg_mlc.c39
-rw-r--r--devel/boehm-gc/files/patch-include-private-gcconfig.h63
-rw-r--r--devel/boehm-gc/files/patch-os_dep.c16
4 files changed, 48 insertions, 78 deletions
diff --git a/devel/boehm-gc/files/patch-doc:Makefile.in b/devel/boehm-gc/files/patch-Makefile.in
index 025b8857b7ca..5021e88488f3 100644
--- a/devel/boehm-gc/files/patch-doc:Makefile.in
+++ b/devel/boehm-gc/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- doc/Makefile.in.orig Mon May 16 20:28:05 2005
-+++ doc/Makefile.in Fri Jun 17 21:24:36 2005
-@@ -30,7 +30,7 @@
+--- Makefile.in.orig 2009-10-20 01:25:20.000000000 +0400
++++ Makefile.in 2009-10-20 01:25:30.000000000 +0400
+@@ -75,7 +75,7 @@
srcdir = @srcdir@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
@@ -8,4 +8,4 @@
+pkgdatadir = $(datadir)/doc/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
- top_builddir = ..
+ top_builddir = .
diff --git a/devel/boehm-gc/files/patch-dbg_mlc.c b/devel/boehm-gc/files/patch-dbg_mlc.c
index a3995703c004..52a801da9c3a 100644
--- a/devel/boehm-gc/files/patch-dbg_mlc.c
+++ b/devel/boehm-gc/files/patch-dbg_mlc.c
@@ -1,6 +1,6 @@
---- dbg_mlc.c.orig Tue May 13 16:59:49 2003
-+++ dbg_mlc.c Wed May 12 20:13:19 2004
-@@ -414,6 +414,23 @@
+--- dbg_mlc.c.orig 2009-10-20 00:34:39.000000000 +0400
++++ dbg_mlc.c 2009-10-20 00:41:22.000000000 +0400
+@@ -456,10 +456,34 @@
GC_register_displacement((word)sizeof(oh) + offset);
}
@@ -21,13 +21,11 @@
+#define GC_caller_func(ad, symp, offp)
+#endif
+
- # ifdef __STDC__
- GC_PTR GC_debug_malloc(size_t lb, GC_EXTRA_PARAMS)
- # else
-@@ -428,6 +445,13 @@
+ void * GC_debug_malloc(size_t lb, GC_EXTRA_PARAMS)
{
- GC_PTR result = GC_malloc(lb + DEBUG_BYTES);
-
+ void * result = GC_malloc(lb + DEBUG_BYTES);
+-
++
+#ifdef GC_ADD_CALLER
+ if (s == NULL) {
+ GC_caller_func_offset(ra, &s, &i);
@@ -36,11 +34,11 @@
+ }
+#endif
if (result == 0) {
- GC_err_printf1("GC_debug_malloc(%ld) returning NIL (",
- (unsigned long) lb);
-@@ -789,6 +813,13 @@
- register size_t old_sz;
- register hdr * hhdr;
+ GC_err_printf("GC_debug_malloc(%lu) returning NIL (",
+ (unsigned long) lb);
+@@ -764,6 +788,13 @@
+ size_t old_sz;
+ hdr * hhdr;
+#ifdef GC_ADD_CALLER
+ if (s == NULL) {
@@ -51,8 +49,8 @@
+#endif
if (p == 0) return(GC_debug_malloc(lb, OPT_RA s, i));
if (base == 0) {
- GC_err_printf1(
-@@ -1094,7 +1125,11 @@
+ GC_err_printf("Attempt to reallocate invalid pointer %p\n", p);
+@@ -1041,17 +1072,21 @@
}
#ifdef GC_ADD_CALLER
@@ -65,17 +63,14 @@
#else
# define RA
#endif
-@@ -1102,12 +1137,12 @@
- GC_PTR GC_debug_malloc_replacement(lb)
- size_t lb;
+
+ void * GC_debug_malloc_replacement(size_t lb)
{
- return GC_debug_malloc(lb, RA "unknown", 0);
+ return GC_debug_malloc(lb, RA NULL, 0);
}
- GC_PTR GC_debug_realloc_replacement(p, lb)
- GC_PTR p;
- size_t lb;
+ void * GC_debug_realloc_replacement(void *p, size_t lb)
{
- return GC_debug_realloc(p, lb, RA "unknown", 0);
+ return GC_debug_realloc(p, lb, RA NULL, 0);
diff --git a/devel/boehm-gc/files/patch-include-private-gcconfig.h b/devel/boehm-gc/files/patch-include-private-gcconfig.h
index 8be1a7ca5228..da83c49ebb91 100644
--- a/devel/boehm-gc/files/patch-include-private-gcconfig.h
+++ b/devel/boehm-gc/files/patch-include-private-gcconfig.h
@@ -1,6 +1,6 @@
---- include/private/gcconfig.h.rorig Sat Oct 15 16:40:25 2005
-+++ include/private/gcconfig.h Sat Oct 15 16:42:43 2005
-@@ -62,7 +62,7 @@
+--- include/private/gcconfig.h.orig 2008-02-20 22:23:00.000000000 +0300
++++ include/private/gcconfig.h 2009-10-20 01:08:38.000000000 +0400
+@@ -64,7 +64,7 @@
/* Determine the machine type: */
# if defined(__arm__) || defined(__thumb__)
# define ARM32
@@ -9,7 +9,7 @@
# define NOSYS
# define mach_type_known
# endif
-@@ -334,10 +334,22 @@
+@@ -334,10 +334,26 @@
# define X86_64
# define mach_type_known
# endif
@@ -17,11 +17,14 @@
+# define X86_64
+# define mach_type_known
+# endif
++# if defined(__FreeBSD__) && defined(__ia64__)
++# define IA64
++# define mach_type_known
++# endif
# if defined(FREEBSD) && defined(__sparc__)
# define SPARC
# define mach_type_known
--#endif
-+# endif
+ # endif
+# if defined(FREEBSD) && defined(__powerpc__)
+# define POWERPC
+# define mach_type_known
@@ -33,9 +36,9 @@
# if defined(bsdi) && (defined(i386) || defined(__i386__))
# define I386
# define BSDI
-@@ -845,6 +857,16 @@
- # define DATASTART GC_data_start
- # define DYNAMIC_LOADING
+@@ -1771,6 +1787,16 @@
+ # define OS_TYPE "MSWINCE"
+ # define DATAEND /* not needed */
# endif
+# ifdef FREEBSD
+# define ALIGNMENT 4
@@ -48,41 +51,13 @@
+# define SEARCH_FOR_DATA_START
+# endif
# ifdef NOSYS
- # define ALIGNMENT 4
- # define OS_TYPE "NOSYS"
-@@ -1807,6 +1829,17 @@
- # endif
- # define USE_GENERIC_PUSH_REGS
+ /* __data_start is usually defined in the target linker script. */
+ extern int __data_start[];
+@@ -1800,6 +1826,7 @@
+ # define OS_TYPE "MSWINCE"
+ # define DATAEND /* not needed */
# endif
-+# ifdef FREEBSD
-+# define ALIGNMENT 4
-+# define OS_TYPE "FREEBSD"
-+# ifdef __ELF__
-+# define DYNAMIC_LOADING
-+# endif
-+# define HEURISTIC2
-+ extern char etext[];
-+# define SEARCH_FOR_DATA_START
-+# endif
+
# ifdef LINUX
- # define OS_TYPE "LINUX"
- # define LINUX_STACKBOTTOM
-@@ -1957,6 +1990,17 @@
- # ifdef __ELF__
- # define DYNAMIC_LOADING
- # endif
-+# define HEURISTIC2
-+ extern char etext[];
-+# define SEARCH_FOR_DATA_START
-+# endif
-+# ifdef FREEBSD
-+# define OS_TYPE "FREEBSD"
-+# define SIG_SUSPEND SIGUSR1
-+# define SIG_THR_RESTART SIGUSR2
-+# ifdef __ELF__
-+# define DYNAMIC_LOADING
-+# endif
- # define HEURISTIC2
- extern char etext[];
- # define SEARCH_FOR_DATA_START
+ # define OS_TYPE "LINUX"
+ # define LINUX_STACKBOTTOM
diff --git a/devel/boehm-gc/files/patch-os_dep.c b/devel/boehm-gc/files/patch-os_dep.c
index b7f96acbc3fb..910777fe2b47 100644
--- a/devel/boehm-gc/files/patch-os_dep.c
+++ b/devel/boehm-gc/files/patch-os_dep.c
@@ -1,16 +1,16 @@
---- os_dep.c.orig Thu May 19 20:48:49 2005
-+++ os_dep.c Fri Jun 17 21:28:07 2005
-@@ -699,7 +699,7 @@
+--- os_dep.c.orig 2008-02-29 22:01:28.000000000 +0300
++++ os_dep.c 2009-10-20 00:48:39.000000000 +0400
+@@ -816,7 +816,7 @@
|| defined(HURD) || defined(NETBSD)
static struct sigaction old_segv_act;
- # if defined(IRIX5) || defined(HPUX) \
+ # if defined(_sigargs) /* !Irix6.x */ || defined(HPUX) \
- || defined(HURD) || defined(NETBSD)
+ || defined(HURD) || defined(NETBSD) || defined(FREEBSD)
static struct sigaction old_bus_act;
# endif
# else
-@@ -714,7 +714,7 @@
- # endif
+@@ -826,7 +826,7 @@
+ void GC_set_and_save_fault_handler(handler h)
{
# if defined(SUNOS5SIGS) || defined(IRIX5) \
- || defined(OSF1) || defined(HURD) || defined(NETBSD)
@@ -18,10 +18,10 @@
struct sigaction act;
act.sa_handler = h;
-@@ -736,7 +736,7 @@
+@@ -846,7 +846,7 @@
# else
(void) sigaction(SIGSEGV, &act, &old_segv_act);
- # if defined(IRIX5) \
+ # if defined(IRIX5) && defined(_sigargs) /* Irix 5.x, not 6.x */ \
- || defined(HPUX) || defined(HURD) || defined(NETBSD)
+ || defined(HPUX) || defined(HURD) || defined(NETBSD) || defined(FREEBSD)
/* Under Irix 5.x or HP/UX, we may get SIGBUS. */