aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boehm-gc
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2007-02-06 06:12:46 +0800
committerstas <stas@FreeBSD.org>2007-02-06 06:12:46 +0800
commit86e0235eff7962ff3cdc720590503a0f53059e33 (patch)
treeb8a7ba48914c1db486763fb2d94074124acbdb73 /devel/boehm-gc
parenta7316fa98c5bb40752964e291f4be40b84abd77f (diff)
downloadfreebsd-ports-gnome-86e0235eff7962ff3cdc720590503a0f53059e33.tar.gz
freebsd-ports-gnome-86e0235eff7962ff3cdc720590503a0f53059e33.tar.zst
freebsd-ports-gnome-86e0235eff7962ff3cdc720590503a0f53059e33.zip
- Use PTHREAD_LIBS.
Submitted by: nork
Diffstat (limited to 'devel/boehm-gc')
-rw-r--r--devel/boehm-gc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 40777725ab40..b613c02e6cb4 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -31,10 +31,10 @@ OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
CONFIGURE_ARGS+= --enable-threads=posix --enable-thread-local-alloc
.if ${OSVERSION} < 502102
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lc_r"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lc_r/}"
.else
CONFIGURE_ENV= CFLAGSS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lpthread"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/}"
.endif
.if defined(WITH_PARALLEL_MARK)
CONFIGURE_ARGS+= --enable-parallel-mark