aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boehm-gc
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2005-10-23 08:01:35 +0800
committernobutaka <nobutaka@FreeBSD.org>2005-10-23 08:01:35 +0800
commitd6ee61d24abb09a1916c80f28fa7475c10ddafc7 (patch)
treebfdec112e774377a8bf07c5db44dc86811a13ab5 /devel/boehm-gc
parent3dc895bf4f3c26f696f543c0e54d205f7dc3c81f (diff)
downloadfreebsd-ports-gnome-d6ee61d24abb09a1916c80f28fa7475c10ddafc7.tar.gz
freebsd-ports-gnome-d6ee61d24abb09a1916c80f28fa7475c10ddafc7.tar.zst
freebsd-ports-gnome-d6ee61d24abb09a1916c80f28fa7475c10ddafc7.zip
Fix build error on amd64 with THREADING option.
PR: ports/87484 Submitted by: Vasil Dimov <vd@datamax.bg>
Diffstat (limited to 'devel/boehm-gc')
-rw-r--r--devel/boehm-gc/Makefile4
-rw-r--r--devel/boehm-gc/files/patch-include-private-gcconfig.h16
2 files changed, 12 insertions, 8 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 4a2c0267858f..02969ca0a32f 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= boehm-gc
PORTVERSION= 6.6
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/
DISTNAME= gc${PORTVERSION:S/.a/alpha/}
@@ -17,7 +18,8 @@ COMMENT= Garbage collection and memory leak detection for C and C++
USE_INC_LIBTOOL_VER= 13
USE_GNOME= lthack
USE_REINPLACE= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --enable-cplusplus
OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
diff --git a/devel/boehm-gc/files/patch-include-private-gcconfig.h b/devel/boehm-gc/files/patch-include-private-gcconfig.h
index ee148f18d693..8be1a7ca5228 100644
--- a/devel/boehm-gc/files/patch-include-private-gcconfig.h
+++ b/devel/boehm-gc/files/patch-include-private-gcconfig.h
@@ -1,5 +1,5 @@
---- include/private/gcconfig.h.orig Sat May 21 05:48:29 2005
-+++ include/private/gcconfig.h Thu Jun 30 01:10:10 2005
+--- include/private/gcconfig.h.rorig Sat Oct 15 16:40:25 2005
++++ include/private/gcconfig.h Sat Oct 15 16:42:43 2005
@@ -62,7 +62,7 @@
/* Determine the machine type: */
# if defined(__arm__) || defined(__thumb__)
@@ -9,7 +9,7 @@
# define NOSYS
# define mach_type_known
# endif
-@@ -330,10 +330,22 @@
+@@ -334,10 +334,22 @@
# define X86_64
# define mach_type_known
# endif
@@ -33,7 +33,7 @@
# if defined(bsdi) && (defined(i386) || defined(__i386__))
# define I386
# define BSDI
-@@ -822,6 +834,16 @@
+@@ -845,6 +857,16 @@
# define DATASTART GC_data_start
# define DYNAMIC_LOADING
# endif
@@ -50,7 +50,7 @@
# ifdef NOSYS
# define ALIGNMENT 4
# define OS_TYPE "NOSYS"
-@@ -1782,6 +1804,17 @@
+@@ -1807,6 +1829,17 @@
# endif
# define USE_GENERIC_PUSH_REGS
# endif
@@ -67,8 +67,8 @@
+
# ifdef LINUX
# define OS_TYPE "LINUX"
- # define HEURISTIC1
-@@ -1932,6 +1965,15 @@
+ # define LINUX_STACKBOTTOM
+@@ -1957,6 +1990,17 @@
# ifdef __ELF__
# define DYNAMIC_LOADING
# endif
@@ -78,6 +78,8 @@
+# endif
+# ifdef FREEBSD
+# define OS_TYPE "FREEBSD"
++# define SIG_SUSPEND SIGUSR1
++# define SIG_THR_RESTART SIGUSR2
+# ifdef __ELF__
+# define DYNAMIC_LOADING
+# endif