aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bonobo/files
diff options
context:
space:
mode:
authornakai <nakai@FreeBSD.org>1999-10-14 13:03:17 +0800
committernakai <nakai@FreeBSD.org>1999-10-14 13:03:17 +0800
commit3f669cd4ec51cd9938a81ad3714d5300a86a5625 (patch)
treede1f41786051d47282ac2b350fc3f017d438fce0 /devel/bonobo/files
parent870a0125ce91326137c0b961cf0ac21fbf910eea (diff)
downloadfreebsd-ports-gnome-3f669cd4ec51cd9938a81ad3714d5300a86a5625.tar.gz
freebsd-ports-gnome-3f669cd4ec51cd9938a81ad3714d5300a86a5625.tar.zst
freebsd-ports-gnome-3f669cd4ec51cd9938a81ad3714d5300a86a5625.zip
PR: ports/14303
Submitted by:Ade Lovett <ade@lovett.com> Initial import. a library for the GNOME component architecture.
Diffstat (limited to 'devel/bonobo/files')
-rw-r--r--devel/bonobo/files/patch-aa19
-rw-r--r--devel/bonobo/files/patch-ab173
2 files changed, 192 insertions, 0 deletions
diff --git a/devel/bonobo/files/patch-aa b/devel/bonobo/files/patch-aa
new file mode 100644
index 000000000000..797c1448682d
--- /dev/null
+++ b/devel/bonobo/files/patch-aa
@@ -0,0 +1,19 @@
+--- configure.orig Fri Oct 8 12:58:58 1999
++++ configure Fri Oct 8 13:06:30 1999
+@@ -4454,6 +4454,8 @@
+ if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
++ ac_save_LIBS="$LIBS"
++LIBS="-lintl $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 4459 "configure"
+ #include "confdefs.h"
+@@ -4488,6 +4490,7 @@
+ eval "ac_cv_func_$ac_func=no"
+ fi
+ rm -f conftest*
++LIBS="$ac_save_LIBS"
+ fi
+
+ if eval "test \"`echo '$ac_cv_func_'$ac_func`\" = yes"; then
diff --git a/devel/bonobo/files/patch-ab b/devel/bonobo/files/patch-ab
new file mode 100644
index 000000000000..b7a388930663
--- /dev/null
+++ b/devel/bonobo/files/patch-ab
@@ -0,0 +1,173 @@
+--- Makefile.in.orig Mon Sep 27 16:21:48 1999
++++ Makefile.in Fri Oct 8 13:45:53 1999
+@@ -126,7 +126,7 @@
+
+ SUBDIRS = po intl idl libefs bonobo storage-modules components samples
+
+-confexecdir = $(libdir)
++confexecdir = $(sysconfdir)
+ confexec_DATA = bonoboConf.sh
+
+ EXTRA_DIST = bonoboConf.sh.in bonobo.spec.in
+--- bonobo/Makefile.in.orig Mon Sep 27 16:22:01 1999
++++ bonobo/Makefile.in Fri Oct 8 13:46:36 1999
+@@ -128,7 +128,7 @@
+
+ corba_DATA = sample.gnorba item.gnorba
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DSTORAGE_LIB=\""$(libdir)"\" -DG_LOG_DOMAIN=\"Bonobo\" -I$(srcdir) -I$(top_srcdir) -I. -I$(top_builddir) -I$(includedir) $(GNOME_INCLUDEDIR)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DSTORAGE_LIB=\""$(libdir)"\" -DG_LOG_DOMAIN=\"Bonobo\" -I$(srcdir) -I$(top_srcdir) -I. -I$(top_builddir) -I$(includedir) $(GNOME_INCLUDEDIR)
+
+
+ gnome_libs = $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
+--- components/application-x-gnomine/Makefile.in.orig Mon Sep 27 16:22:05 1999
++++ components/application-x-gnomine/Makefile.in Fri Oct 8 13:47:29 1999
+@@ -125,9 +125,9 @@
+ l = @l@
+
+ scoredir = $(localstatedir)/games
+-Gamesdir = $(datadir)/gnome/apps/Games
++Gamesdir = $(datadir)/apps/Games
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(includedir) $(GNOME_INCLUDEDIR)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(includedir) $(GNOME_INCLUDEDIR)
+
+
+ #bin_PROGRAMS = gnomine bonobo-application-x-mines
+@@ -146,7 +146,7 @@
+ bonobo_application_x_mines_SOURCES = minefield.h minefield.c bonobo-application-x-mines.c
+
+
+-bonobo_application_x_mines_LDADD = $(GNOME_LIBDIR) -lbonobo $(GNOMEGNORBA_LIBS)
++bonobo_application_x_mines_LDADD = $(GNOME_LIBDIR) $(top_builddir)/bonobo/libbonobo.la $(GNOMEGNORBA_LIBS)
+
+
+ gnorbadir = $(sysconfdir)/CORBA/servers
+--- components/audio-ulaw/Makefile.in.orig Mon Sep 27 16:22:12 1999
++++ components/audio-ulaw/Makefile.in Fri Oct 8 13:48:17 1999
+@@ -124,14 +124,14 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-SUBDIRS = doc
++SUBDIRS = # doc
+
+ bin_PROGRAMS = bonobo-audio-ulaw
+
+ bonobo_audio_ulaw_SOURCES = bonobo-audio-ulaw.c bonobo-audio-ulaw.h item-audio.c item-audio.h color.c color.h
+
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+
+
+ bonobo_audio_ulaw_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
+--- components/audio-ulaw/doc/C/Makefile.in.orig Mon Sep 27 16:22:14 1999
++++ components/audio-ulaw/doc/C/Makefile.in Fri Oct 8 13:49:03 1999
+@@ -128,7 +128,7 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-audio_ulaw_helpdir = $(datadir)/gnome/bonobo/docs/audio_ulaw/C
++audio_ulaw_helpdir = $(datadir)/bonobo/docs/audio_ulaw/C
+
+ #
+ # Module configuration information
+--- components/image-generic/Makefile.in.orig Mon Sep 27 16:22:06 1999
++++ components/image-generic/Makefile.in Fri Oct 8 13:49:51 1999
+@@ -129,7 +129,7 @@
+ bonobo_image_generic_SOURCES = bonobo-image-generic.c
+
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+
+
+ bonobo_image_generic_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS) -lgdk_pixbuf
+--- components/image-x-png/Makefile.in.orig Mon Sep 27 16:22:07 1999
++++ components/image-x-png/Makefile.in Fri Oct 8 13:50:29 1999
+@@ -124,14 +124,14 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-SUBDIRS = doc
++SUBDIRS = # doc
+
+ bin_PROGRAMS = bonobo-image-x-png
+
+ bonobo_image_x_png_SOURCES = bonobo-image-x-png.c
+
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+
+
+ bonobo_image_x_png_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS) -lpng
+--- components/image-x-png/doc/C/Makefile.in.orig Mon Sep 27 16:22:09 1999
++++ components/image-x-png/doc/C/Makefile.in Fri Oct 8 13:51:01 1999
+@@ -128,7 +128,7 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-image_x_png_helpdir = $(datadir)/gnome/bonobo/docs/image_x_png/C
++image_x_png_helpdir = $(datadir)/bonobo/docs/image_x_png/C
+
+ #
+ # Module configuration information
+--- components/text-plain/Makefile.in.orig Mon Sep 27 16:22:11 1999
++++ components/text-plain/Makefile.in Fri Oct 8 13:51:48 1999
+@@ -129,7 +129,7 @@
+ bonobo_text_plain_SOURCES = bonobo-text-plain.c
+
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+
+
+ bonobo_text_plain_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
+--- samples/Makefile.in.orig Mon Sep 27 16:22:16 1999
++++ samples/Makefile.in Fri Oct 8 13:53:54 1999
+@@ -126,7 +126,7 @@
+
+ bin_PROGRAMS = paint-component-simple sample-container
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+
+
+ paint_component_simple_SOURCES = paint-component-simple.c
+--- storage-modules/Makefile.in.orig Mon Sep 27 16:22:03 1999
++++ storage-modules/Makefile.in Fri Oct 8 13:54:29 1999
+@@ -124,7 +124,7 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/libefs/src -I$(includedir) $(GNOME_INCLUDEDIR)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/libefs/src -I$(includedir) $(GNOME_INCLUDEDIR)
+
+
+ common_ldflags = -avoid-version
+--- po/Makefile.in.in.orig Mon Sep 27 15:26:21 1999
++++ po/Makefile.in.in Fri Oct 8 14:08:03 1999
+@@ -18,8 +18,8 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+-datadir = $(prefix)/@DATADIRNAME@
+-localedir = $(datadir)/locale
++datadir = $(prefix)/share/locale
++localedir = $(prefix)/share/locale
+ gnulocaledir = $(prefix)/share/locale
+ gettextsrcdir = $(prefix)/share/gettext/po
+ subdir = po
+--- libefs/Makefile.in.orig Mon Sep 27 16:21:53 1999
++++ libefs/Makefile.in Fri Oct 8 14:18:17 1999
+@@ -78,7 +78,7 @@
+ USE_SYMBOL_UNDERSCORE = @USE_SYMBOL_UNDERSCORE@
+ VERSION = @VERSION@
+
+-SUBDIRS = src doc
++SUBDIRS = src # doc
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/../mkinstalldirs
+ CONFIG_HEADER = config.h