aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boost-libs
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-03-02 18:57:46 +0800
committerbapt <bapt@FreeBSD.org>2012-03-02 18:57:46 +0800
commitda5476e585557d77a8e8c21177983c025c358dd2 (patch)
tree840a2b740892861338c8a557bd25c0709f0d44da /devel/boost-libs
parentcbb451546084d14eb95f0a3d147218c1a2cb33cd (diff)
downloadfreebsd-ports-gnome-da5476e585557d77a8e8c21177983c025c358dd2.tar.gz
freebsd-ports-gnome-da5476e585557d77a8e8c21177983c025c358dd2.tar.zst
freebsd-ports-gnome-da5476e585557d77a8e8c21177983c025c358dd2.zip
add BOOST_HAS_LONG_LONG to clang.hpp this fix code using boost and being built with clang
Also reported and comitted upstream (https://svn.boost.org/trac/boost/ticket/6636 thanks dim@) PR: ports/165567 Submitted by: bapt@ (myself) Approved by: Alexander Churanov <alexanderchuranov@gmail.com> (maintainer) miwi@ (responsible of the PR)
Diffstat (limited to 'devel/boost-libs')
-rw-r--r--devel/boost-libs/Makefile2
-rw-r--r--devel/boost-libs/files/patch-boost__config__compiler__clang.hpp8
2 files changed, 9 insertions, 1 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 144f464ff428..692515c37a4b 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= boost-libs
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= Free portable C++ libraries (without Boost.Python)
USE_BZIP2= yes
diff --git a/devel/boost-libs/files/patch-boost__config__compiler__clang.hpp b/devel/boost-libs/files/patch-boost__config__compiler__clang.hpp
new file mode 100644
index 000000000000..df38c68d61f5
--- /dev/null
+++ b/devel/boost-libs/files/patch-boost__config__compiler__clang.hpp
@@ -0,0 +1,8 @@
+--- ./boost/config/compiler/clang.hpp.orig 2010-10-01 11:19:44.000000000 +0200
++++ ./boost/config/compiler/clang.hpp 2012-02-29 15:20:25.157457434 +0100
+@@ -60,4 +60,4 @@
+
+ // Macro used to identify the Clang compiler.
+ #define BOOST_CLANG 1
+-
++#define BOOST_HAS_LONG_LONG 1