aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boost-pyste
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-29 21:50:29 +0800
committerpav <pav@FreeBSD.org>2009-12-29 21:50:29 +0800
commitfb5d22a2c05cfc46d0069fbeb6eb7f56e1ff3031 (patch)
tree92da167b040d95514eacd2bdc2f348327af2c2b9 /devel/boost-pyste
parentc1ba1ae4dc5e7a965752bb78db8a295d6decab4b (diff)
downloadfreebsd-ports-gnome-fb5d22a2c05cfc46d0069fbeb6eb7f56e1ff3031.tar.gz
freebsd-ports-gnome-fb5d22a2c05cfc46d0069fbeb6eb7f56e1ff3031.tar.zst
freebsd-ports-gnome-fb5d22a2c05cfc46d0069fbeb6eb7f56e1ff3031.zip
- Update boost to 1.41
PR: ports/141749 Submitted by: Alexander Churanov <churanov.port.maintainer@gmail.com> (maintainer)
Diffstat (limited to 'devel/boost-pyste')
-rw-r--r--devel/boost-pyste/Makefile60
-rw-r--r--devel/boost-pyste/distinfo3
-rw-r--r--devel/boost-pyste/files/patch-Jamroot11
-rw-r--r--devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam17
-rw-r--r--devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam29
-rw-r--r--devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam11
-rw-r--r--devel/boost-pyste/files/patch-tools_jam_src_build.jam11
-rw-r--r--devel/boost-pyste/pkg-descr7
-rw-r--r--devel/boost-pyste/pkg-plist66
9 files changed, 215 insertions, 0 deletions
diff --git a/devel/boost-pyste/Makefile b/devel/boost-pyste/Makefile
new file mode 100644
index 000000000000..e8c0f8626218
--- /dev/null
+++ b/devel/boost-pyste/Makefile
@@ -0,0 +1,60 @@
+# Ports collection makefile for: boost-pyste
+# Date Created: 16 Novemeber 2009
+# Whom: Alexander Churanov <churanov.port.maintainer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= boost-pyste
+COMMENT= Boost.Python code generator
+
+CONFLICTS+= boost-python-libs-1.3* boost-python-libs-1.40
+USE_BZIP2= yes
+USE_PYTHON= 2.4+
+
+OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
+ DEBUG "Build debugging symbols" off \
+ OPTIMIZED_CFLAGS "Enable -O3 optimization" off
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/boost-all/common.mk"
+.include "${PORTSDIR}/devel/boost-all/compiled.mk"
+
+MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
+ PYTHON_VERSION="${PYTHON_VERSION}"\
+ PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"\
+ PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
+
+RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so.${BOOST_SHARED_LIB_VER}:${PORTSDIR}/devel/boost-python-libs
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
+
+RUN_DEPENDS+= gccxml:${PORTSDIR}/devel/gccxml
+BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
+BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
+
+ESCAPED_PREFIX != echo ${PREFIX} | sed 's/\//\\\//g'
+RELATIVE_PYTHON_SITELIBDIR != echo ${PYTHON_SITELIBDIR} | sed "s/${ESCAPED_PREFIX}\///"
+PLIST_SUB+= PYTHON_SITELIBDIR=${RELATIVE_PYTHON_SITELIBDIR}
+PLIST_SUB+= PYTHON_VERSION=${PYTHON_VERSION:C/python//1}
+
+post-patch: customize-boost-build
+
+post-configure:
+# Configure pyste, the Boost.Python code generator
+ @cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
+ config ${PYDISTUTILS_CONFIGUREARGS}
+
+do-build:
+# Build pyste, the Boost.Python code generator
+ cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
+ build ${PYDISTUTILS_BUILDARGS}
+
+do-install:
+# Install pyste, the Boost.Python code generator
+ cd ${WRKSRC}/libs/python/pyste/install && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
+ install ${PYDISTUTILS_INSTALLARGS}
+
+.include <bsd.port.post.mk>
diff --git a/devel/boost-pyste/distinfo b/devel/boost-pyste/distinfo
new file mode 100644
index 000000000000..4741c16b2910
--- /dev/null
+++ b/devel/boost-pyste/distinfo
@@ -0,0 +1,3 @@
+MD5 (boost_1_41_0.tar.bz2) = 8bb65e133907db727a2a825c5400d0a6
+SHA256 (boost_1_41_0.tar.bz2) = 1ef94e6749eaf13318284b4f629be063544c7015b45e38113b975ac1945cc726
+SIZE (boost_1_41_0.tar.bz2) = 33348161
diff --git a/devel/boost-pyste/files/patch-Jamroot b/devel/boost-pyste/files/patch-Jamroot
new file mode 100644
index 000000000000..7903f6daf682
--- /dev/null
+++ b/devel/boost-pyste/files/patch-Jamroot
@@ -0,0 +1,11 @@
+--- Jamroot.orig 2009-09-23 16:35:49.000000000 +0400
++++ Jamroot 2009-09-23 16:36:49.000000000 +0400
+@@ -384,7 +384,7 @@
+ # suffixes either. Pgi compilers can not accept library with version
+ # suffix.
+ if $(type) = SHARED_LIB &&
+- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
++ ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix freebsd ) &&
+ ! ( [ $(property-set).get <toolset> ] in pgi ) )
+ {
+ result = $(result).$(BOOST_VERSION) ;
diff --git a/devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam b/devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam
new file mode 100644
index 000000000000..cc306b204292
--- /dev/null
+++ b/devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam
@@ -0,0 +1,17 @@
+--- tools/build/v2/tools/common.jam.orig 2009-09-23 16:39:31.000000000 +0400
++++ tools/build/v2/tools/common.jam 2009-09-23 16:39:33.000000000 +0400
+@@ -765,14 +765,6 @@
+ result += [ join-tag $(f:G=) : [ toolset-tag $(name) : $(type) :
+ $(property-set) ] ] ;
+
+- case <threading> :
+- result += [ join-tag $(f:G=) : [ threading-tag $(name) : $(type)
+- : $(property-set) ] ] ;
+-
+- case <runtime> :
+- result += [ join-tag $(f:G=) : [ runtime-tag $(name) : $(type) :
+- $(property-set) ] ] ;
+-
+ case <qt> :
+ result += [ join-tag $(f:G=) : [ qt-tag $(name) : $(type) :
+ $(property-set) ] ] ;
diff --git a/devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam b/devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam
new file mode 100644
index 000000000000..9daa31f24d9c
--- /dev/null
+++ b/devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam
@@ -0,0 +1,29 @@
+--- tools/build/v2/tools/gcc.jam.orig Thu Oct 16 12:42:03 2008
++++ tools/build/v2/tools/gcc.jam Tue Nov 11 23:48:37 2008
+@@ -88,7 +88,7 @@
+ {
+ # Information about the gcc command...
+ # The command.
+- local command = [ common.get-invocation-command gcc : g++ : $(command) ] ;
++ local command = [ common.get-invocation-command gcc : %%CXX%% : $(command) ] ;
+ # The root directory of the tool install.
+ local root = [ feature.get-values <root> : $(options) ] ;
+ # The bin directory where to find the command to execute.
+@@ -292,7 +292,7 @@
+
+ # Declare flags and action for compilation.
+ toolset.flags gcc.compile OPTIONS <optimization>off : -O0 ;
+-toolset.flags gcc.compile OPTIONS <optimization>speed : -O3 ;
++toolset.flags gcc.compile OPTIONS <optimization>speed : %%CXXFLAGS%% ;
+ toolset.flags gcc.compile OPTIONS <optimization>space : -Os ;
+
+ toolset.flags gcc.compile OPTIONS <inlining>off : -fno-inline ;
+@@ -811,7 +811,7 @@
+ }
+ case *bsd :
+ {
+- option = -pthread ;
++ option = %%PTHREAD_LIBS%% %%PTHREAD_CFLAGS%% ;
+ # There is no -lrt on BSD.
+ }
+ case sgi :
diff --git a/devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam b/devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam
new file mode 100644
index 000000000000..bf2212b3d520
--- /dev/null
+++ b/devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam
@@ -0,0 +1,11 @@
+--- tools/build/v2/tools/python.jam.orig Thu Oct 16 12:42:03 2008
++++ tools/build/v2/tools/python.jam Tue Nov 11 23:50:21 2008
+@@ -650,7 +650,7 @@
+ case windows : return ;
+
+ case hpux : return <library>rt ;
+- case *bsd : return <library>pthread <toolset>gcc:<library>util ;
++ case *bsd : return <library>%%PTHREAD_LIBS%% <toolset>gcc:<library>util ;
+
+ case aix : return <library>pthread <library>dl ;
+
diff --git a/devel/boost-pyste/files/patch-tools_jam_src_build.jam b/devel/boost-pyste/files/patch-tools_jam_src_build.jam
new file mode 100644
index 000000000000..413fef332db7
--- /dev/null
+++ b/devel/boost-pyste/files/patch-tools_jam_src_build.jam
@@ -0,0 +1,11 @@
+--- tools/jam/src/build.jam.orig Tue Jul 29 15:43:31 2008
++++ tools/jam/src/build.jam Tue Nov 11 23:52:09 2008
+@@ -176,7 +176,7 @@
+ ## GCC 2.x, 3.x, 4.x
+ toolset gcc gcc : "-o " : -D
+ : -pedantic -fno-strict-aliasing
+- [ opt --release : [ opt --symbols : -g : -s ] -O3 ]
++ [ opt --release : [ opt --symbols : -g : -s ] -O3 -fno-strict-aliasing ]
+ [ opt --debug : -g -O0 -fno-inline ]
+ -I$(--python-include) -I$(--extra-include) -Wno-long-long
+ : -L$(--python-lib[1]) -l$(--python-lib[2]) ;
diff --git a/devel/boost-pyste/pkg-descr b/devel/boost-pyste/pkg-descr
new file mode 100644
index 000000000000..cb51cc0a993a
--- /dev/null
+++ b/devel/boost-pyste/pkg-descr
@@ -0,0 +1,7 @@
+Pyste is a Boost.Python code generator. The user specifies the classes
+and functions to be exported using a simple interface file, which
+following the Boost.Python's philosophy, is simple Python code. Pyste
+then uses GCCXML to parse all the headers and extract the necessary
+information to automatically generate C++ code.
+
+WWW: http://www.boost.org/
diff --git a/devel/boost-pyste/pkg-plist b/devel/boost-pyste/pkg-plist
new file mode 100644
index 000000000000..499d422b1a33
--- /dev/null
+++ b/devel/boost-pyste/pkg-plist
@@ -0,0 +1,66 @@
+bin/pyste.py
+%%PYTHON_SITELIBDIR%%/Pyste-0.9.10-py%%PYTHON_VERSION%%.egg-info
+%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/CppParser.py
+%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/Exporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.py
+%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.py
+%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.py
+%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.py
+%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.py
+%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/__init__.py
+%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/declarations.py
+%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/exporters.py
+%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.py
+%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/infos.py
+%%PYTHON_SITELIBDIR%%/Pyste/infos.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/infos.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/policies.py
+%%PYTHON_SITELIBDIR%%/Pyste/policies.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/policies.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/pyste.py
+%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/settings.py
+%%PYTHON_SITELIBDIR%%/Pyste/settings.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/settings.pyo
+%%PYTHON_SITELIBDIR%%/Pyste/utils.py
+%%PYTHON_SITELIBDIR%%/Pyste/utils.pyc
+%%PYTHON_SITELIBDIR%%/Pyste/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/Pyste