aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boost/Makefile
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-03-22 02:04:49 +0800
committerbarner <barner@FreeBSD.org>2005-03-22 02:04:49 +0800
commit1261f27616873a3635ed3ec34fe54163087f09d6 (patch)
tree39d1f6f02d7d68f204bf27a322bbf73fa0df2f5d /devel/boost/Makefile
parent7d0b5065b12be26431c4fd928307f9bb5dab5fe3 (diff)
downloadfreebsd-ports-gnome-1261f27616873a3635ed3ec34fe54163087f09d6.tar.gz
freebsd-ports-gnome-1261f27616873a3635ed3ec34fe54163087f09d6.tar.zst
freebsd-ports-gnome-1261f27616873a3635ed3ec34fe54163087f09d6.zip
- Don't install symlinks to shared libraries that are not installed.
Specifically, this is about the !WITH_PYTHON and !WITH_THREADS cases. - This fixes the plist again. Reported by: kris via pointyhat Approved by: arved (mentor)
Diffstat (limited to 'devel/boost/Makefile')
-rw-r--r--devel/boost/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index d428adb4a1a2..e57da1f2f1b8 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -32,8 +32,7 @@ OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
UNIQ= /usr/bin/uniq
BOOST_LIBS= date_time filesystem prg_exec_monitor program_options \
- python regex signals test_exec_monitor thread \
- unit_test_framework
+ regex signals test_exec_monitor unit_test_framework
BOOST_SHARED_LIB_VER= 2
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -61,6 +60,7 @@ MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
PYTHON_VERSION="${PYTHON_VERSION}"\
PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"\
PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
+BOOST_LIBS+= python
.if defined(WITH_PYSTE)
RUN_DEPENDS+= gccxml:${PORTSDIR}/devel/gccxml \
${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
@@ -129,6 +129,7 @@ PLIST_SUB+= BOOST_THREADS="@comment "
.else
BJAM_BUILD+= <threading>multi
PLIST_SUB+= BOOST_THREADS=""
+BOOST_LIBS+= thread
.endif
.if defined (WITHOUT_OPTIMIZED_CFLAGS)