aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bugzilla50
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2016-02-17 03:35:36 +0800
committerohauer <ohauer@FreeBSD.org>2016-02-17 03:35:36 +0800
commit2cf678ddc7c4824e19aeb5e2b6562227fb78cef2 (patch)
tree27b2ff63878efe250e368b38785eb2f9b55023a0 /devel/bugzilla50
parent24558b9142b3342bf941c468ff75d52ae97c3fdf (diff)
downloadfreebsd-ports-gnome-2cf678ddc7c4824e19aeb5e2b6562227fb78cef2.tar.gz
freebsd-ports-gnome-2cf678ddc7c4824e19aeb5e2b6562227fb78cef2.tar.zst
freebsd-ports-gnome-2cf678ddc7c4824e19aeb5e2b6562227fb78cef2.zip
- add new OPTIONS_GROUP_EXTENSIONS (MoreBugUrl and Voting)
- add patch so MoreBugUrl has support for Phabricator URL's [1] - PORTREVISION bump not requied, new OPTIONS are OFF by default [1] Upstream PR: https://bugzilla.mozilla.org/show_bug.cgi?id=1128119 Special Thanks goes to Mahdi Mokhtari for the patches and improving the FreeBSD Bugzilla integration! PR: 207216 Submitted by: Mahdi Mokhtari
Diffstat (limited to 'devel/bugzilla50')
-rw-r--r--devel/bugzilla50/Makefile8
-rw-r--r--devel/bugzilla50/Makefile.options11
-rw-r--r--devel/bugzilla50/files/patch-PR20721363
-rw-r--r--devel/bugzilla50/pkg-plist39
4 files changed, 120 insertions, 1 deletions
diff --git a/devel/bugzilla50/Makefile b/devel/bugzilla50/Makefile
index d64ed48979c2..afa28faa0b80 100644
--- a/devel/bugzilla50/Makefile
+++ b/devel/bugzilla50/Makefile
@@ -207,4 +207,12 @@ do-install-CONTRIB-on:
@${MKDIR} ${STAGEDIR}${WWWDIR}/contrib
(cd ${WRKSRC}/contrib && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/contrib)
+do-install-MOREBUGURL-on:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/extensions/MoreBugUrl
+ (cd ${WRKSRC}/extensions/MoreBugUrl && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/extensions/MoreBugUrl)
+
+do-install-VOTING-on:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/extensions/Voting
+ (cd ${WRKSRC}/extensions/Voting && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/extensions/Voting)
+
.include <bsd.port.post.mk>
diff --git a/devel/bugzilla50/Makefile.options b/devel/bugzilla50/Makefile.options
index b52674aa10f9..83a9458ae405 100644
--- a/devel/bugzilla50/Makefile.options
+++ b/devel/bugzilla50/Makefile.options
@@ -4,7 +4,7 @@ OPTIONS_SUB= yes
OPTIONS_DEFINE= \
MODPERL
-OPTIONS_GROUP= UI DBBACKEND REPORTING ATTACHMENT EMAIL WEBSERVICE AUTH ADMIN
+OPTIONS_GROUP= UI DBBACKEND REPORTING ATTACHMENT EMAIL WEBSERVICE AUTH ADMIN EXTENSIONS
OPTIONS_GROUP_ADMIN= \
MOVE_BUGZ \
@@ -45,6 +45,10 @@ OPTIONS_GROUP_UI= \
PATCH_VIEWER \
MORE_HTML
+OPTIONS_GROUP_EXTENSIONS=\
+ MOREBUGURL \
+ VOTING
+
OPTIONS_DEFAULT= \
CHARTING_MODULES\
CONTRIB \
@@ -80,4 +84,9 @@ DBBACKEND_DESC= Database Engine
EMAIL_DESC= Email handling
REPORTING_DESC= Reports and Charts
WEBSERVICE_DESC= Web Services
+EXTENSIONS_DESC= Extensions
+
+# Extensions
+MOREBUGURL_DESC= See Also Extensions
+VOTING_DESC= Bug Voting Extension
diff --git a/devel/bugzilla50/files/patch-PR207213 b/devel/bugzilla50/files/patch-PR207213
new file mode 100644
index 000000000000..107b815f224f
--- /dev/null
+++ b/devel/bugzilla50/files/patch-PR207213
@@ -0,0 +1,63 @@
+# Upstream PR: https://bugzilla.mozilla.org/show_bug.cgi?id=1128119
+===================================================================
+--- extensions/MoreBugUrl/Extension.pm.orig 2016-02-15 15:30:02 UTC
++++ extensions/MoreBugUrl/Extension.pm
+@@ -22,6 +22,7 @@ use constant MORE_SUB_CLASSES => qw(
+ Bugzilla::Extension::MoreBugUrl::PHP
+ Bugzilla::Extension::MoreBugUrl::Redmine
+ Bugzilla::Extension::MoreBugUrl::Savane
++ Bugzilla::Extension::MoreBugUrl::Phabricator
+ );
+
+ # We need to update bug_see_also table because both
+--- extensions/MoreBugUrl/lib/Phabricator.pm.orig 2016-02-15 15:40:28 UTC
++++ extensions/MoreBugUrl/lib/Phabricator.pm
+@@ -0,0 +1,41 @@
++# This Source Code Form is subject to the terms of the Mozilla Public
++# License, v. 2.0. If a copy of the MPL was not distributed with this
++# file, You can obtain one at http://mozilla.org/MPL/2.0/.
++#
++# This Source Code Form is "Incompatible With Secondary Licenses", as
++# defined by the Mozilla Public License, v. 2.0.
++
++package Bugzilla::Extension::MoreBugUrl::Phabricator;
++
++use 5.10.1;
++use strict;
++use warnings;
++
++use parent qw(Bugzilla::BugUrl);
++
++###############################
++#### Methods ####
++###############################
++
++sub should_handle {
++ my ($class, $uri) = @_;
++ return ($uri->path =~ m|^/T\d+$|) ? 1 : 0;
++}
++
++sub _check_value {
++ my $class = shift;
++
++ my $uri = $class->SUPER::_check_value(@_);
++
++ # Phabricator URLs have only one form:
++ # http://example.com/T111
++
++ # Make sure there are no query parameters.
++ $uri->query(undef);
++ # And remove any # part if there is one.
++ $uri->fragment(undef);
++
++ return $uri;
++}
++
++1;
+--- extensions/MoreBugUrl/template/en/default/hook/global/user-error-bug_url_invalid_tracker.html.tmpl.orig 2015-12-22 21:22:11 UTC
++++ extensions/MoreBugUrl/template/en/default/hook/global/user-error-bug_url_invalid_tracker.html.tmpl
+@@ -14,3 +14,4 @@
+ <li>A b[% %]ug on b[% %]ugs.php.net.</li>
+ <li>An issue in a Redmine installation.</li>
+ <li>A b[% %]ug in a Savane installation.</li>
++<li>A task in a Phabricator installation.</li>
diff --git a/devel/bugzilla50/pkg-plist b/devel/bugzilla50/pkg-plist
index 585cd0a07319..5017c6da95c7 100644
--- a/devel/bugzilla50/pkg-plist
+++ b/devel/bugzilla50/pkg-plist
@@ -211,6 +211,45 @@
%%WWWDIR%%/editworkflow.cgi
%%WWWDIR%%/email_in.pl
%%WWWDIR%%/enter_bug.cgi
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/Config.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/Extension.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/disabled
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/BitBucket.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/GetSatisfaction.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/PHP.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/Phabricator.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/RT.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/Redmine.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/ReviewBoard.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/Rietveld.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/lib/Savane.pm
+%%MOREBUGURL%%%%WWWDIR%%/extensions/MoreBugUrl/template/en/default/hook/global/user-error-bug_url_invalid_tracker.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/Config.pm
+%%VOTING%%%%WWWDIR%%/extensions/Voting/Extension.pm
+%%VOTING%%%%WWWDIR%%/extensions/Voting/disabled
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/account/prefs/email-relationships.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/admin/products/edit-common-rows.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/admin/products/updated-changes.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/admin/sanitycheck/messages-statuses.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/admin/users/confirm-delete-warn_safe.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/bug/edit-after_importance.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/bug/format_comment-type.txt.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/bug/process/header-title.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/bug/process/results-title.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/bug/show-header-end.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/global/code-error-errors.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/global/field-descs-end.none.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/global/messages-messages.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/global/reason-descs-end.none.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/global/user-error-errors.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/search/form-after_freetext_fields.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/hook/search/search-report-select-rep_fields.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/pages/voting.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/pages/voting/bug.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/pages/voting/user.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/voting/delete-all.html.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/template/en/default/voting/votes-removed.txt.tmpl
+%%VOTING%%%%WWWDIR%%/extensions/Voting/web/style.css
%%WWWDIR%%/images/csv.png
%%WWWDIR%%/images/favicon.ico
%%WWWDIR%%/images/ical.png