aboutsummaryrefslogtreecommitdiffstats
path: root/devel/callgrind
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-09-02 00:27:21 +0800
committersem <sem@FreeBSD.org>2004-09-02 00:27:21 +0800
commit6ecef773189fb907dd6e1ec07319587f94b095f5 (patch)
treec4a1e55fdb064646b4544a2ac9ee8231f00acaa3 /devel/callgrind
parentae09c2be3d473a59cc244f91e9a29420a80406da (diff)
downloadfreebsd-ports-gnome-6ecef773189fb907dd6e1ec07319587f94b095f5.tar.gz
freebsd-ports-gnome-6ecef773189fb907dd6e1ec07319587f94b095f5.tar.zst
freebsd-ports-gnome-6ecef773189fb907dd6e1ec07319587f94b095f5.zip
Rename devel/calltree to callgrind.
Update it to 0.9.8. Update related ports. PR: ports/70936 Submitted by: maintainer
Diffstat (limited to 'devel/callgrind')
-rw-r--r--devel/callgrind/Makefile20
-rw-r--r--devel/callgrind/distinfo4
-rw-r--r--devel/callgrind/files/patch-src::Makefile.in16
-rw-r--r--devel/callgrind/files/patch-src::ct_main.c19
-rw-r--r--devel/callgrind/files/patch-src::ct_sim.c11
-rw-r--r--devel/callgrind/pkg-descr8
-rw-r--r--devel/callgrind/pkg-plist10
7 files changed, 55 insertions, 33 deletions
diff --git a/devel/callgrind/Makefile b/devel/callgrind/Makefile
index ef60c703e37e..c6c10deffe39 100644
--- a/devel/callgrind/Makefile
+++ b/devel/callgrind/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
#
-PORTNAME= calltree
-PORTVERSION= 0.9.7
+PORTNAME= callgrind
+PORTVERSION= 0.9.8
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= kcachegrind
+MASTER_SITES= http://kcachegrind.sourceforge.net/
MAINTAINER= barner@gmx.de
COMMENT= Valgrind skin for cache simulation and call tracing
@@ -21,4 +20,15 @@ ONLY_FOR_ARCHS= i386
GNU_CONFIGURE= yes
USE_GMAKE= yes
-.include <bsd.port.mk>
+OPTIONS= VALGRIND_SNAPSHOT "Depend on snapshot version of valgrind" off
+.include <bsd.port.pre.mk>
+
+.if defined (WITH_VALGRIND_SNAPSHOT)
+RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind-snapshot
+BUILD_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind-snapshot
+.else
+RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
+BUILD_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/callgrind/distinfo b/devel/callgrind/distinfo
index fe9057e37270..cd04657aacc7 100644
--- a/devel/callgrind/distinfo
+++ b/devel/callgrind/distinfo
@@ -1,2 +1,2 @@
-MD5 (calltree-0.9.7.tar.gz) = f1bb4e6446f26219cf5772849630b380
-SIZE (calltree-0.9.7.tar.gz) = 156812
+MD5 (callgrind-0.9.8.tar.gz) = 5d98a82128b66a8ad4a931b728db420b
+SIZE (callgrind-0.9.8.tar.gz) = 178524
diff --git a/devel/callgrind/files/patch-src::Makefile.in b/devel/callgrind/files/patch-src::Makefile.in
index 1b8f2bc36edb..58ba0341597a 100644
--- a/devel/callgrind/files/patch-src::Makefile.in
+++ b/devel/callgrind/files/patch-src::Makefile.in
@@ -1,11 +1,13 @@
---- src/Makefile.in.orig Thu Jun 3 05:08:28 2004
-+++ src/Makefile.in Thu Jun 3 05:08:54 2004
-@@ -116,7 +116,7 @@
+--- src/Makefile.in.orig Thu Aug 19 22:46:55 2004
++++ src/Makefile.in Wed Aug 25 10:07:20 2004
+@@ -167,8 +167,8 @@
+ target_alias = @target_alias@
SUBDIRS = .
-
AM_CFLAGS = $(WERROR) -DVG_LIBDIR="\"$(libdir)"\" \
-- -Winline -Wall -Wshadow -O -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@ -g
-+ -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@
-
+- -Winline -Wall -Wshadow -O2 -fomit-frame-pointer \
+- @PREFERRED_STACK_BOUNDARY@ -g
++ -fomit-frame-pointer \
++ @PREFERRED_STACK_BOUNDARY@
valdir = $(libdir)/valgrind
+ incincdir = $(includedir)/valgrind
diff --git a/devel/callgrind/files/patch-src::ct_main.c b/devel/callgrind/files/patch-src::ct_main.c
index ea2d55da10fb..02d6611562ed 100644
--- a/devel/callgrind/files/patch-src::ct_main.c
+++ b/devel/callgrind/files/patch-src::ct_main.c
@@ -1,11 +1,10 @@
---- src/ct_main.c.orig Thu Jun 3 05:04:08 2004
-+++ src/ct_main.c Thu Jun 3 05:05:51 2004
-@@ -5758,7 +5758,7 @@
- /* Install own SIGILL handler */
- sigill_new.ksa_handler = cpuid_SIGILL_handler;
- sigill_new.ksa_flags = 0;
-- sigill_new.ksa_restorer = NULL;
-+ // sigill_new.ksa_restorer = NULL;
- res = VG_(ksigemptyset)( &sigill_new.ksa_mask );
- CT_ASSERT(res == 0);
+--- src/ct_main.c.orig Wed Aug 25 10:10:18 2004
++++ src/ct_main.c Wed Aug 25 10:13:36 2004
+@@ -32,6 +32,7 @@
+ */
+ #include "vg_skin.h"
++#include "vg_unistd.h"
+ #include "callgrind.h"
+ #include "ct_include.h"
+ #include "ct_events.h"
diff --git a/devel/callgrind/files/patch-src::ct_sim.c b/devel/callgrind/files/patch-src::ct_sim.c
new file mode 100644
index 000000000000..b02a5489c2e5
--- /dev/null
+++ b/devel/callgrind/files/patch-src::ct_sim.c
@@ -0,0 +1,11 @@
+--- src/ct_sim.c.orig Tue Aug 31 13:05:51 2004
++++ src/ct_sim.c Tue Aug 31 13:06:00 2004
+@@ -537,7 +537,7 @@
+ /* Install own SIGILL handler */
+ sigill_new.ksa_handler = cpuid_SIGILL_handler;
+ sigill_new.ksa_flags = 0;
+- sigill_new.ksa_restorer = NULL;
++ //sigill_new.ksa_restorer = NULL;
+ res = VG_(ksigemptyset)( &sigill_new.ksa_mask );
+ CT_ASSERT(res == 0);
+
diff --git a/devel/callgrind/pkg-descr b/devel/callgrind/pkg-descr
index 39591126455a..02eb05bcbc5b 100644
--- a/devel/callgrind/pkg-descr
+++ b/devel/callgrind/pkg-descr
@@ -1,9 +1,9 @@
-Calltree uses runtime instrumentation via the Valgrind framework for its
+Callgrind uses runtime instrumentation via the Valgrind framework for its
cache simulation and call tracing. This way, even shared libraries and
dynamically opened plugins can be profiled. The data files generated by
-Calltree can be loaded into KCachegrind for browsing the performance results.
+Callgrind can be loaded into KCachegrind for browsing the performance results.
-But there is also a command line tool in the Calltree package to get ASCII
-reports from Calltree data files without the need to use KCachegrind.
+But there is also a command line tool in the Callgrind package to get ASCII
+reports from Callgrind data files without the need to use KCachegrind.
WWW: http://kcachegrind.sourceforge.net
diff --git a/devel/callgrind/pkg-plist b/devel/callgrind/pkg-plist
index 8c807ea4e1f0..77f7224a7c98 100644
--- a/devel/callgrind/pkg-plist
+++ b/devel/callgrind/pkg-plist
@@ -1,7 +1,7 @@
-bin/calltree
-bin/ct_annotate
-bin/ct_control
-include/valgrind/calltree.h
-lib/valgrind/vgskin_calltree.so
+bin/callgrind
+bin/callgrind_annotate
+bin/callgrind_control
+include/valgrind/callgrind.h
+lib/valgrind/vgskin_callgrind.so
share/doc/valgrind/ct_main.html
share/doc/valgrind/ct_techdocs.html