aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ccache
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-10-16 06:09:56 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-10-16 06:09:56 +0800
commitf28d8daa2cf7a0a322c8b6efaaa160a2317ae6f3 (patch)
treef4d0df2fdda3696a6ccc03ab3393f83999304823 /devel/ccache
parent8749421d2161e931fbc2fdc6d4577e076fca1b3d (diff)
downloadfreebsd-ports-gnome-f28d8daa2cf7a0a322c8b6efaaa160a2317ae6f3.tar.gz
freebsd-ports-gnome-f28d8daa2cf7a0a322c8b6efaaa160a2317ae6f3.tar.zst
freebsd-ports-gnome-f28d8daa2cf7a0a322c8b6efaaa160a2317ae6f3.zip
Update to 3.2.4.
Changes: https://ccache.samba.org/releasenotes.html#_ccache_3_2_4
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile2
-rw-r--r--devel/ccache/distinfo4
-rw-r--r--devel/ccache/files/patch-ccache.c14
-rw-r--r--devel/ccache/files/patch-configure11
-rw-r--r--devel/ccache/files/patch-configure.ac11
5 files changed, 10 insertions, 32 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index d13465802fb6..9b7ca52430a6 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ccache
-PORTVERSION= 3.2.3
+PORTVERSION= 3.2.4
PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= http://www.samba.org/ftp/ccache/ \
diff --git a/devel/ccache/distinfo b/devel/ccache/distinfo
index ba031e176528..93e527946f5d 100644
--- a/devel/ccache/distinfo
+++ b/devel/ccache/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ccache-3.2.3.tar.gz) = 43b2c0a0f7c8c89cecdc841b4ef55c626c9ca2bc80d5d746c91efcf81d224f6b
-SIZE (ccache-3.2.3.tar.gz) = 438086
+SHA256 (ccache-3.2.4.tar.gz) = bf07d13e3c806971ea01af1d5a8db50319af434c920b4e4b742229aaa04d270c
+SIZE (ccache-3.2.4.tar.gz) = 439320
diff --git a/devel/ccache/files/patch-ccache.c b/devel/ccache/files/patch-ccache.c
index b319899163a9..629b3406a9af 100644
--- a/devel/ccache/files/patch-ccache.c
+++ b/devel/ccache/files/patch-ccache.c
@@ -1,11 +1,11 @@
Determine whether cc(1) is clang or gcc at compile-time.
---- ccache.c.orig 2015-01-06 18:24:47.738295980 -0600
-+++ ccache.c 2015-01-06 18:25:58.685291460 -0600
-@@ -1116,6 +1116,11 @@ compiler_is_clang(struct args *args)
+--- ccache.c.orig 2015-10-15 15:01:14.756621000 -0700
++++ ccache.c 2015-10-15 15:01:47.738326000 -0700
+@@ -1350,6 +1350,11 @@ compiler_is_clang(struct args *args)
{
- char* name = basename(args->argv[0]);
- bool is = strstr(name, "clang");
+ char *name = basename(args->argv[0]);
+ bool is = strstr(name, "clang") != NULL;
+#ifdef CC_IS_CLANG
+ if (strcmp(name, "cc") == 0 || strcmp(name, "CC") == 0 ||
+ strcmp(name, "c++") == 0)
@@ -14,9 +14,9 @@ Determine whether cc(1) is clang or gcc at compile-time.
free(name);
return is;
}
-@@ -1125,6 +1130,11 @@ compiler_is_gcc(struct args *args)
+@@ -1359,6 +1364,11 @@ compiler_is_gcc(struct args *args)
{
- char* name = basename(args->argv[0]);
+ char *name = basename(args->argv[0]);
bool is = strstr(name, "gcc") || strstr(name, "g++");
+#ifdef CC_IS_GCC
+ if (strcmp(name, "cc") == 0 || strcmp(name, "CC") == 0 ||
diff --git a/devel/ccache/files/patch-configure b/devel/ccache/files/patch-configure
deleted file mode 100644
index 8d72ddf4ff2a..000000000000
--- a/devel/ccache/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2015-09-04 21:15:56 UTC
-+++ configure
-@@ -5682,7 +5682,7 @@ if test x${use_bundled_zlib} = xyes; the
- extra_libs="zlib/libz.a"
- mkdir -p zlib
- else
-- extra_libs="-lz"
-+ LIBS="$LIBS -lz"
- fi
-
- if test x${windows_os} = xyes; then
diff --git a/devel/ccache/files/patch-configure.ac b/devel/ccache/files/patch-configure.ac
deleted file mode 100644
index bc8288bb7313..000000000000
--- a/devel/ccache/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2015-08-16 12:12:05 UTC
-+++ configure.ac
-@@ -120,7 +120,7 @@ if test x${use_bundled_zlib} = xyes; the
- extra_libs="zlib/libz.a"
- mkdir -p zlib
- else
-- extra_libs="-lz"
-+ LIBS="$LIBS -lz"
- fi
-
- dnl Linking on Windows needs ws2_32