aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ccache
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2012-01-30 16:38:40 +0800
committerehaupt <ehaupt@FreeBSD.org>2012-01-30 16:38:40 +0800
commitd6c120e7873670cd2252d1330a52aece786a9b98 (patch)
tree21fad7c034d0e46d3987399662a3cbdff86d0f54 /devel/ccache
parentc06f9cd0066cee125d1589e04456e76c0129d8a9 (diff)
downloadfreebsd-ports-gnome-d6c120e7873670cd2252d1330a52aece786a9b98.tar.gz
freebsd-ports-gnome-d6c120e7873670cd2252d1330a52aece786a9b98.tar.zst
freebsd-ports-gnome-d6c120e7873670cd2252d1330a52aece786a9b98.zip
Add an option to statically build ccache.
PR: 164606 Submitted by: zi
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index dc7d727014dd..f2eaf6a1d385 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -26,7 +26,8 @@ MAN1= ccache.1
PORTDOCS= ccache-howto-freebsd.txt MANUAL.html
OPTIONS= CLANGLINK "Create clang compiler links if clang is installed" off \
- LLVMLINK "Create llvm compiler links if llvm is installed" off
+ LLVMLINK "Create llvm compiler links if llvm is installed" off \
+ STATIC "Statically build ccache" off
.include <bsd.port.pre.mk>
@@ -47,6 +48,10 @@ CCACHE_COMPILERS+= clang clang++
CCACHE_COMPILERS+= llvm-gcc llvm-c++ llvm-g++
.endif
+.if defined(WITH_STATIC)
+LDFLAGS+= "--static"
+.endif
+
CCACHE_COMPILERS+= ${EXTRA_COMPILERS}
SUB_LIST+= CCACHE_COMPILERS="${CCACHE_COMPILERS}" \
CCLINKDIR="${CCLINKDIR}" \