aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ccache
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-04 02:17:53 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-04 02:17:53 +0800
commitecdf4a0300202fbef2cfa1ff8fe845411f3fac5b (patch)
tree3780cb42c631dd7ffe1f1628e2d69b44b80598f8 /devel/ccache
parent6abdff0d044fb9bcc7fa42326dcf3124a5d875c2 (diff)
downloadfreebsd-ports-gnome-ecdf4a0300202fbef2cfa1ff8fe845411f3fac5b.tar.gz
freebsd-ports-gnome-ecdf4a0300202fbef2cfa1ff8fe845411f3fac5b.tar.zst
freebsd-ports-gnome-ecdf4a0300202fbef2cfa1ff8fe845411f3fac5b.zip
Restore the possibility to define EXTRA_COMPILERS which must reside in $PATH.
PR: 158888 Submitted by: Pan Tsu <inyaoo@gmail.com>
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile2
-rw-r--r--devel/ccache/files/ccache-update-links.sh.in2
2 files changed, 3 insertions, 1 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index c0af09ea0d89..f489e7aaf2cf 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ccache
PORTVERSION= 3.1.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://samba.org/ftp/ccache/ CRITICAL
@@ -35,6 +36,7 @@ CCACHE_COMPILERS+= icc icpc
GNU_COMPILERS+= 34 42 43 44 45 46
CCACHE_COMPILERS+= cc c++ gcc g++ ${GNU_COMPILERS:S|^|gcc|} ${GNU_COMPILERS:S|^|g++|}
CCACHE_COMPILERS+= clang clang++ llvm-gcc llvm-c++ llvm-g++
+CCACHE_COMPILERS+= ${EXTRA_COMPILERS}
SUB_LIST+= CCACHE_COMPILERS="${CCACHE_COMPILERS}" \
CCLINKDIR="${CCLINKDIR}" \
ICCPREFIX="${LOCALBASE}/intel_cc_80/bin" \
diff --git a/devel/ccache/files/ccache-update-links.sh.in b/devel/ccache/files/ccache-update-links.sh.in
index 66ebd2d092ff..ce49ce718907 100644
--- a/devel/ccache/files/ccache-update-links.sh.in
+++ b/devel/ccache/files/ccache-update-links.sh.in
@@ -32,7 +32,7 @@ esac
# create compiler links
for comp in ${CCACHE_COMPILERS}
do
- if [ -f "${PREFIX}/bin/${comp}" ] || [ -f "/usr/bin/${comp}" ]; then
+ if command -v "${comp}" >/dev/null; then
if [ ! -L "${PREFIX}/${CCLINKDIR}/${comp}" ]; then
[ "$1" = "-v" ] && echo "create symlink for ${comp}"
ln -sf ${PREFIX}/bin/ccache ${PREFIX}/${CCLINKDIR}/${comp}