aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cccc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-11-16 06:03:05 +0800
committerbapt <bapt@FreeBSD.org>2013-11-16 06:03:05 +0800
commit3c176e0bd6e80a0e5d120ce88aa0e378a5719e16 (patch)
treeaa3ca24f11a27ebe149edc61e61437daa6832ae7 /devel/cccc
parentd77d797ada243e008530374794a51089d92dd6f7 (diff)
downloadfreebsd-ports-gnome-3c176e0bd6e80a0e5d120ce88aa0e378a5719e16.tar.gz
freebsd-ports-gnome-3c176e0bd6e80a0e5d120ce88aa0e378a5719e16.tar.zst
freebsd-ports-gnome-3c176e0bd6e80a0e5d120ce88aa0e378a5719e16.zip
Support stage
Properly respect CXX without the need of patching USE_GMAKE->USES=gmake
Diffstat (limited to 'devel/cccc')
-rw-r--r--devel/cccc/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/devel/cccc/Makefile b/devel/cccc/Makefile
index 4185a2039615..1e5b1f001ffc 100644
--- a/devel/cccc/Makefile
+++ b/devel/cccc/Makefile
@@ -12,24 +12,19 @@ COMMENT= C and C++ Code Counter
BUILD_DEPENDS= antlr:${PORTSDIR}/devel/pccts \
dlg:${PORTSDIR}/devel/pccts
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= makefile
MAKE_JOBS_UNSAFE= yes
+MAKE_ARGS= CCC="${CXX}"
PORTDOCS= readme.txt changes.txt
PLIST_FILES= bin/cccc
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|=g++|=${CXX}|' ${WRKSRC}/*/posix*.mak
-
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/cccc/cccc ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/cccc/cccc ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>