aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cccc
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
committerasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
commit559e1bc28bd975c38b561de15be3918ba1f71b5e (patch)
treecda169bf1e41b7166c2d2febd3d858c1411d0e64 /devel/cccc
parent7aed28166a84f266be861367fc9a1add43f9219a (diff)
downloadfreebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.gz
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.zst
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Diffstat (limited to 'devel/cccc')
-rw-r--r--devel/cccc/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/cccc/Makefile b/devel/cccc/Makefile
index cefcff4a4fda..2a9b6b236139 100644
--- a/devel/cccc/Makefile
+++ b/devel/cccc/Makefile
@@ -3,7 +3,7 @@
# Date created: 12 September 1997
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.3 1998/08/13 03:32:52 asami Exp $
+# $Id: Makefile,v 1.4 1998/10/12 15:54:23 jseger Exp $
#
DISTNAME= cccc-2.1.1.src
@@ -17,7 +17,8 @@ MAINTAINER= andy@icc.surw.chel.su
BUILD_DEPENDS= antlr:${PORTSDIR}/devel/pccts \
dlg:${PORTSDIR}/devel/pccts
-OSVERSION!= sysctl -n kern.osreldate
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} >= 300000
BROKEN= signal.h:163: syntax error
.endif
@@ -36,4 +37,4 @@ do-install:
@ ${MKDIR} ${PREFIX}/share/doc/cccc
@ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/cccc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>