aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ccls/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /devel/ccls/Makefile
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'devel/ccls/Makefile')
-rw-r--r--devel/ccls/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/ccls/Makefile b/devel/ccls/Makefile
index b30556c9b8f8..e5488b102599 100644
--- a/devel/ccls/Makefile
+++ b/devel/ccls/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT} \
rapidjson>=1.1.0_4:devel/rapidjson
LIB_DEPENDS= libLLVM-${LLVM_DEFAULT:C/[0-9]$//}.so:devel/llvm${LLVM_DEFAULT}
-USES= cmake:outsource compiler:c++17-lang localbase
+USES= cmake compiler:c++17-lang localbase
USE_GITHUB= yes
GH_ACCOUNT= MaskRay