aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ccls
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-12-26 01:14:37 +0800
committertobik <tobik@FreeBSD.org>2018-12-26 01:14:37 +0800
commitf698e31fec9faf84d34f41f56353e77b19e71c2a (patch)
treef8266eaffe17a7d2d28fa47e3b96027f7d6cc622 /devel/ccls
parent2daa6f976c46f78d0c6ec57ba4cc6e0bc871a285 (diff)
downloadfreebsd-ports-gnome-f698e31fec9faf84d34f41f56353e77b19e71c2a.tar.gz
freebsd-ports-gnome-f698e31fec9faf84d34f41f56353e77b19e71c2a.tar.zst
freebsd-ports-gnome-f698e31fec9faf84d34f41f56353e77b19e71c2a.zip
devel/ccls: Update to 0.20181225
Changes: https://github.com/MaskRay/ccls/releases/tag/0.20181225
Diffstat (limited to 'devel/ccls')
-rw-r--r--devel/ccls/Makefile2
-rw-r--r--devel/ccls/distinfo6
-rw-r--r--devel/ccls/files/patch-src_working__files.hh16
3 files changed, 20 insertions, 4 deletions
diff --git a/devel/ccls/Makefile b/devel/ccls/Makefile
index d95497a6a5db..b30556c9b8f8 100644
--- a/devel/ccls/Makefile
+++ b/devel/ccls/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ccls
-DISTVERSION= 0.20181111.1
+DISTVERSION= 0.20181225
CATEGORIES= devel
MAINTAINER= tobik@FreeBSD.org
diff --git a/devel/ccls/distinfo b/devel/ccls/distinfo
index ca1be96d8bbc..b0cd60b9a15e 100644
--- a/devel/ccls/distinfo
+++ b/devel/ccls/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1544615253
+TIMESTAMP = 1545751536
SHA256 (MaskRay-ccls.wiki-20181210.tar.gz) = fedd812479e504ae7b6df9f5e6fe4d3f89dabacec05184ce6dc4f991c230d971
SIZE (MaskRay-ccls.wiki-20181210.tar.gz) = 25372
-SHA256 (MaskRay-ccls-0.20181111.1_GH0.tar.gz) = 8625704d245b39676d6dc983def0d2adf6347ae0b6686991dc87c74877d784d8
-SIZE (MaskRay-ccls-0.20181111.1_GH0.tar.gz) = 159641
+SHA256 (MaskRay-ccls-0.20181225_GH0.tar.gz) = c544dcad27d82982105429ab4c7371dd12cd9e5f092bc8789f35c64efb6e7fea
+SIZE (MaskRay-ccls-0.20181225_GH0.tar.gz) = 157952
diff --git a/devel/ccls/files/patch-src_working__files.hh b/devel/ccls/files/patch-src_working__files.hh
new file mode 100644
index 000000000000..66917403e67e
--- /dev/null
+++ b/devel/ccls/files/patch-src_working__files.hh
@@ -0,0 +1,16 @@
+src/working_files.hh:89:8: error: no template named 'unordered_map' in namespace 'std'
+ std::unordered_map<std::string, std::unique_ptr<WorkingFile>> files;
+ ~~~~~^
+
+https://github.com/MaskRay/ccls/pull/177
+
+--- src/working_files.hh.orig 2018-12-25 15:28:45 UTC
++++ src/working_files.hh
+@@ -21,6 +21,7 @@ limitations under the License.
+ #include <mutex>
+ #include <optional>
+ #include <string>
++#include <unordered_map>
+
+ namespace ccls {
+ struct WorkingFile {