aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ccons
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2012-10-23 06:12:28 +0800
committerlippe <lippe@FreeBSD.org>2012-10-23 06:12:28 +0800
commitf13ffc815cc755366eef4377387223f32810405f (patch)
tree71b5ea64888b6712258301cc0be1351e258a0ea5 /devel/ccons
parent614ab42bb56be283e21207da02ba307653836b81 (diff)
downloadfreebsd-ports-gnome-f13ffc815cc755366eef4377387223f32810405f.tar.gz
freebsd-ports-gnome-f13ffc815cc755366eef4377387223f32810405f.tar.zst
freebsd-ports-gnome-f13ffc815cc755366eef4377387223f32810405f.zip
The goal of the ccons project is to create an interactive console
for the C programming language, similar to "python" and "irb" for Python and Ruby respectively. PR: ports/172551 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com> Feature safe: yes
Diffstat (limited to 'devel/ccons')
-rw-r--r--devel/ccons/Makefile48
-rw-r--r--devel/ccons/distinfo2
-rw-r--r--devel/ccons/pkg-descr5
3 files changed, 55 insertions, 0 deletions
diff --git a/devel/ccons/Makefile b/devel/ccons/Makefile
new file mode 100644
index 000000000000..4c1686d27178
--- /dev/null
+++ b/devel/ccons/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= ccons
+PORTVERSION= r235
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= danilogondolfo@gmail.com
+COMMENT= Interactive Console for the C Programming Language
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/llvm-config:${PORTSDIR}/devel/llvm \
+ ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang \
+ ${LOCALBASE}/bin/ld:${PORTSDIR}/devel/binutils
+LIB_DEPENDS= ncurses:${PORTSDIR}/devel/ncurses
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_CMAKE= yes
+CMAKE_ARGS+= -DLLVM_CONFIG_EXECUTABLE:FILEPATH=${LOCALBASE}/bin/llvm-config
+
+CXX= ${LOCALBASE}/bin/clang++
+CXXFLAGS+= -fno-rtti
+LDFLAGS+= -lclangFrontendTool -lclangFrontend -lclangDriver -lclangSerialization \
+ -lclangCodeGen -lclangParse -lclangSema -lclangStaticAnalyzerCheckers \
+ -lclangStaticAnalyzerCore -lclangAnalysis -lclang -lclangAST -lclangLex \
+ -lclangBasic -ledit -lm ${PTHREAD_LIBS}
+
+PLIST_FILES= bin/ccons
+
+WRKSRC= ${WRKDIR}/ccons
+
+MAKE_JOBS_SAFE= yes
+
+MAN1= ccons.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900044
+BROKEN= ccons don\'t work on FreeBSD < 9.0-RELEASE
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/ccons ${PREFIX}/bin/ccons
+ @${INSTALL_MAN} ${WRKSRC}/man/ccons.1 ${MAN1PREFIX}/man/man1/ccons.1
+
+.include <bsd.port.post.mk>
diff --git a/devel/ccons/distinfo b/devel/ccons/distinfo
new file mode 100644
index 000000000000..d5f51b90f613
--- /dev/null
+++ b/devel/ccons/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ccons-r235.tar.gz) = 9ca451626e4a54c1504cd86e646041a70a9aff8724a727488671abb3bea1440c
+SIZE (ccons-r235.tar.gz) = 26187
diff --git a/devel/ccons/pkg-descr b/devel/ccons/pkg-descr
new file mode 100644
index 000000000000..9f59bb4c0b6a
--- /dev/null
+++ b/devel/ccons/pkg-descr
@@ -0,0 +1,5 @@
+The goal of the ccons project is to create an interactive console
+for the C programming language, similar to "python" and "irb" for
+Python and Ruby respectively.
+
+WWW: http://code.google.com/p/ccons/