aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cdash
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-08-12 21:23:14 +0800
committergahr <gahr@FreeBSD.org>2011-08-12 21:23:14 +0800
commit3bc589d5fc03614b38cdc7b122b8491d6c7a2f6b (patch)
treed1fa51b842effdef8480019240c25c5c4d21e9d3 /devel/cdash
parent07cc564f63d0015e6d63adf4663c02d281026c26 (diff)
downloadfreebsd-ports-gnome-3bc589d5fc03614b38cdc7b122b8491d6c7a2f6b.tar.gz
freebsd-ports-gnome-3bc589d5fc03614b38cdc7b122b8491d6c7a2f6b.tar.zst
freebsd-ports-gnome-3bc589d5fc03614b38cdc7b122b8491d6c7a2f6b.zip
- New port: devel/cdash
CDash is an open source, web-based software testing server. CDash aggregates, analyzes and displays the results of software testing processes submitted from clients located around the world. Developers depend on CDash to convey the state of a software system, and to continually improve its quality. CDash is a part of a larger software process that integrates Kitware's CMake, CTest, and CPack tools, as well as other external packages used to design, manage and maintain large-scale software systems. Good examples of a CDash are the CMake quality dashboard and the VTK quality dashboard. WWW: http://www.cdash.org/
Diffstat (limited to 'devel/cdash')
-rw-r--r--devel/cdash/Makefile63
-rw-r--r--devel/cdash/distinfo2
-rw-r--r--devel/cdash/files/patch-cdash_config.local.php111
-rw-r--r--devel/cdash/files/pkg-message.in8
-rw-r--r--devel/cdash/pkg-descr9
-rw-r--r--devel/cdash/pkg-plist675
6 files changed, 868 insertions, 0 deletions
diff --git a/devel/cdash/Makefile b/devel/cdash/Makefile
new file mode 100644
index 000000000000..e347e9bc363f
--- /dev/null
+++ b/devel/cdash/Makefile
@@ -0,0 +1,63 @@
+# New ports collection Makefile for: cdash
+# Date created: 12 August 2011
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= cdash
+PORTVERSION= 1.8.2
+CATEGORIES= devel
+MASTER_SITES= http://www.cdash.org/download/
+DISTNAME= CDash-${PORTVERSION}
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A web-based software testing server
+
+LICENSE= BSD
+
+OPTIONS= MYSQL "Use MySQL" on \
+ PGSQL "Use PostgreSQL" off
+
+USE_ZIP= yes
+USE_PHP= curl gd xsl
+USE_APACHE_RUN= 2.0+
+
+NO_BUILD= yes
+SUB_FILES= pkg-message
+SUB_LIST+= DB_TYPE=${DB_TYPE}
+
+.include <bsd.port.options.mk>
+
+.if (!defined(WITH_MYSQL) && !defined(WITH_PGSQL)) || (defined(WITH_MYSQL) && defined(WITH_PGSQL))
+IGNORE= please run 'make config' and select either MYSQL or PGSQL, but not both
+.endif
+
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+USE_PHP+= mysql
+DB_TYPE= mysql
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+USE_PHP+= pgsql
+DB_TYPE= pgsql
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%DB_TYPE%%|${DB_TYPE}|' ${WRKSRC}/cdash/config.local.php
+
+do-install:
+ ${MKDIR} ${PREFIX}/www/CDash
+ ${RM} -f ${WRKSRC}/cdash/config.local.php.bak
+ ${RM} -f ${WRKSRC}/cdash/config.local.php.orig
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${PREFIX}/www/CDash
+ ${CHOWN} www ${PREFIX}/www/CDash/backup ${PREFIX}/www/CDash/rss
+
+post-install:
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/devel/cdash/distinfo b/devel/cdash/distinfo
new file mode 100644
index 000000000000..639c3b02683d
--- /dev/null
+++ b/devel/cdash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CDash-1.8.2.zip) = a2b153311616d07234f9e6aa71162dbd1e8e17de38ea4c6c514bc6a346fb27c0
+SIZE (CDash-1.8.2.zip) = 1271110
diff --git a/devel/cdash/files/patch-cdash_config.local.php b/devel/cdash/files/patch-cdash_config.local.php
new file mode 100644
index 000000000000..afc1fe29ea0e
--- /dev/null
+++ b/devel/cdash/files/patch-cdash_config.local.php
@@ -0,0 +1,111 @@
+--- /dev/null 2011-08-12 12:09:43.000000000 +0200
++++ cdash/config.local.php 2011-08-12 11:57:38.000000000 +0200
+@@ -0,0 +1,108 @@
++<?php
++/*=========================================================================
++
++ Program: CDash - Cross-Platform Dashboard System
++ Module: $Id: config.php 2618 2010-08-04 19:28:36Z david.cole $
++ Language: PHP
++ Date: $Date: 2010-08-04 21:28:36 +0200 (mer., 04 août 2010) $
++ Version: $Revision: 2618 $
++
++ Copyright (c) 2002 Kitware, Inc. All rights reserved.
++ See Copyright.txt or http://www.cmake.org/HTML/Copyright.html for details.
++
++ This software is distributed WITHOUT ANY WARRANTY; without even
++ the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
++ PURPOSE. See the above copyright notices for more information.
++
++=========================================================================*/
++/** WARNING: It's recommended to create a config.local.php file and leave
++ * this file as is.
++ * If creating the config.local.php from config.php make sure you DELETE
++ * any text after the 'DO NOT EDIT AFTER THIS LINE' otherwise your
++ * configuration file will be referencing each other. */
++
++// Hostname of the database server
++$CDASH_DB_HOST = 'localhost';
++// Login for database access
++$CDASH_DB_LOGIN = 'root';
++// Password for database access
++$CDASH_DB_PASS = '';
++// Name of the database
++$CDASH_DB_NAME = 'cdash';
++// Database type (empty means mysql)
++$CDASH_DB_TYPE = '%%DB_TYPE%%';
++// Turn this variable ON when CDash has been installed
++// Prevents from running the install.php again
++$CDASH_PRODUCTION_MODE = false;
++$CDASH_TESTING_MODE = false;
++// Should we use asynchronous submission
++$CDASH_ASYNCHRONOUS_SUBMISSION = false;
++// Default from email
++$CDASH_EMAILADMIN = 'admin@cdash.org';
++$CDASH_EMAIL_FROM = 'admin@cdash.org';
++$CDASH_EMAIL_REPLY = 'noreply@cdash.org';
++// Duration of the cookie session (in seconds)
++$CDASH_COOKIE_EXPIRATION_TIME='3600';
++// Using HTTPS protocol to access CDash
++$CDASH_USE_HTTPS ='0';
++// Name of the server running CDash.
++// Leave empty to use current name.
++$CDASH_SERVER_NAME = '';
++// If the remote request should use localhost or the full name
++// This variable should be set to 1 in most of the server configurations
++$CDASH_CURL_REQUEST_LOCALHOST='1';
++$CDASH_CURL_LOCALHOST_PREFIX='';
++// Define the location of the local directory
++$CDASH_USE_LOCAL_DIRECTORY = '0';
++// CSS file
++$CDASH_CSS_FILE = 'cdash.css';
++// Backup directory
++$CDASH_BACKUP_DIRECTORY = 'backup';
++// Log file location
++$CDASH_LOG_FILE = $CDASH_BACKUP_DIRECTORY."/cdash.log";
++// Using external authentication
++$CDASH_EXTERNAL_AUTH = '0';
++// Backup timeframe
++$CDASH_BACKUP_TIMEFRAME = '48'; // 48 hours
++// Request full email address to add new users
++// instead of displaying a list
++$CDASH_FULL_EMAIL_WHEN_ADDING_USER = '0';
++// Use getIPfromApache script to get IP addresses
++// when using forwarding script
++$CDASH_FORWARDING_IP='192.%'; // should be an SQL format
++$CDASH_DEFAULT_IP_LOCATIONS = array();
++// Use compression (default on)
++$CDASH_USE_COMPRESSION='1';
++// Use LDAP
++$CDASH_USE_LDAP='0';
++$CDASH_LDAP_HOSTNAME='localhost';
++$CDASH_LDAP_BASEDN='ou=people,dc=organization,dc=com';
++$CDASH_LDAP_PROTOCOL_VERSION='3';
++// For authentication against Active Directory, set CDASH_LDAP_AUTHENTICATED to '1'
++// CDASH_LDAP_OPT_REFERRALS to '0', and specify a bind DN and password
++$CDASH_LDAP_OPT_REFERRALS='1';
++$CDASH_LDAP_AUTHENTICATED='0';
++$CDASH_LDAP_BIND_DN='cn=user,ou=people,dc=orgranization,dc=com';
++$CDASH_LDAP_BIND_PASSWORD='password';
++// Allow rememberme
++$CDASH_ALLOW_LOGIN_COOKIE='1';
++// Set to start the autoremoval on the first build of the day
++$CDASH_AUTOREMOVE_BUILDS='0';
++// Google Map API
++$CDASH_GOOGLE_MAP_API_KEY = array();
++$CDASH_GOOGLE_MAP_API_KEY['localhost'] = 'ABQIAAAAT7I3XxP5nXC2xZUbg5AhLhQlpUmSySBnNeRIYFXQdqJETZJpYBStoWsCJtLvtHDiIJzsxJ953H3rgg';
++// Enable Google Analytics
++$CDASH_DEFAULT_GOOGLE_ANALYTICS='';
++// How long since the last submission before considering a project
++// non active
++$CDASH_ACTIVE_PROJECT_DAYS = '7'; // a week
++// Use CDash to manage build submissions
++// This feature is currently experimental
++$CDASH_MANAGE_CLIENTS = '0';
++// Define the git command
++$CDASH_GIT_COMMAND = 'git';
++// The default git directory where the bare repositories should be created
++$CDASH_DEFAULT_GIT_DIRECTORY = 'git';
++// Number of seconds to allow processing a single submission before resetting
++$CDASH_SUBMISSION_PROCESSING_TIME_LIMIT = '450';
++?>
diff --git a/devel/cdash/files/pkg-message.in b/devel/cdash/files/pkg-message.in
new file mode 100644
index 000000000000..95175b4e120a
--- /dev/null
+++ b/devel/cdash/files/pkg-message.in
@@ -0,0 +1,8 @@
+Your CDash configuration file is located at
+%%PREFIX%%/www/cdash/cdash/config.local.php.
+
+Please create the %%DB_TYPE%% username 'cdash' and
+grant him privileges over a database named 'cdash'.
+
+A sample CDash project is available for download at
+http://www.cdash.org/download/CDashTest.zip.
diff --git a/devel/cdash/pkg-descr b/devel/cdash/pkg-descr
new file mode 100644
index 000000000000..56e7baded2c9
--- /dev/null
+++ b/devel/cdash/pkg-descr
@@ -0,0 +1,9 @@
+CDash is an open source, web-based software testing server. CDash aggregates,
+analyzes and displays the results of software testing processes submitted from
+clients located around the world. Developers depend on CDash to convey the state
+of a software system, and to continually improve its quality. CDash is a part of
+a larger software process that integrates Kitware's CMake, CTest, and CPack
+tools, as well as other external packages used to design, manage and maintain
+large-scale software systems.
+
+WWW: http://www.cdash.org/
diff --git a/devel/cdash/pkg-plist b/devel/cdash/pkg-plist
new file mode 100644
index 000000000000..7ac22311ff69
--- /dev/null
+++ b/devel/cdash/pkg-plist
@@ -0,0 +1,675 @@
+www/CDash/CMakeLists.txt
+www/CDash/CTestConfig.cmake
+www/CDash/CTestCustom.cmake.in
+www/CDash/Copyright.txt
+www/CDash/License.txt
+www/CDash/ajax/addbuildgroup.php
+www/CDash/ajax/addnote.php
+www/CDash/ajax/buildinfogroup.php
+www/CDash/ajax/buildnote.php
+www/CDash/ajax/clientchecksystem.php
+www/CDash/ajax/expectedbuildgroup.php
+www/CDash/ajax/expectedinfo.php
+www/CDash/ajax/finduserproject.php
+www/CDash/ajax/findusers.php
+www/CDash/ajax/showbuildhistory.php
+www/CDash/ajax/showbuildtimegraph.php
+www/CDash/ajax/showbuildupdategraph.php
+www/CDash/ajax/showcoveragegraph.php
+www/CDash/ajax/showprojectupdategraph.php
+www/CDash/ajax/showtestfailuregraph.php
+www/CDash/ajax/showtestpassinggraph.php
+www/CDash/ajax/showtesttimegraph.php
+www/CDash/api/api.php
+www/CDash/api/api_build.php
+www/CDash/api/api_coverage.php
+www/CDash/api/api_project.php
+www/CDash/api/api_user.php
+www/CDash/api/getbuildid.php
+www/CDash/api/getuserid.php
+www/CDash/api/getversion.php
+www/CDash/api/hasfile.php
+www/CDash/api/index.php
+www/CDash/autoRemoveBuilds.php
+www/CDash/backup.xsl
+www/CDash/backup/.htaccess
+www/CDash/backup/README.txt
+www/CDash/buildOverview.php
+www/CDash/buildOverview.xsl
+www/CDash/buildSummary.php
+www/CDash/buildSummary.xsl
+www/CDash/cdash.css
+www/CDash/cdash/ChangeLog.txt
+www/CDash/cdash/Copyright.txt
+www/CDash/cdash/autoremove.php
+www/CDash/cdash/bugurl.php
+www/CDash/cdash/clientsubmit.php
+www/CDash/cdash/common.php
+www/CDash/cdash/config.local.php
+www/CDash/cdash/config.php
+www/CDash/cdash/createRSS.php
+www/CDash/cdash/ctestparser.php
+www/CDash/cdash/ctestparserutils.php
+www/CDash/cdash/dailyupdates.php
+www/CDash/cdash/dailyupdatescurl.php
+www/CDash/cdash/defines.php
+www/CDash/cdash/do_submit.php
+www/CDash/cdash/log.php
+www/CDash/cdash/pdo.php
+www/CDash/cdash/pdocore.php
+www/CDash/cdash/processsubmissions.php
+www/CDash/cdash/sendemail.php
+www/CDash/cdash/version.php
+www/CDash/createProject.php
+www/CDash/createProject.xsl
+www/CDash/displayImage.php
+www/CDash/editSite.php
+www/CDash/editSite.xsl
+www/CDash/editUser.php
+www/CDash/editUser.xsl
+www/CDash/favicon.ico
+www/CDash/filterdataFunctions.php
+www/CDash/filterdataTemplate.xsl
+www/CDash/footer.xsl
+www/CDash/generateCTestConfig.php
+www/CDash/groupsDescription.php
+www/CDash/header.xsl
+www/CDash/headeradminproject.xsl
+www/CDash/headerback.xsl
+www/CDash/headscripts.xsl
+www/CDash/images/Alert.gif
+www/CDash/images/Calendar.gif
+www/CDash/images/Closed.gif
+www/CDash/images/Document.gif
+www/CDash/images/DownBlack.gif
+www/CDash/images/Generator.png
+www/CDash/images/Info.png
+www/CDash/images/LeftBlack.gif
+www/CDash/images/Minus.gif
+www/CDash/images/New.gif
+www/CDash/images/Open.gif
+www/CDash/images/Plus.gif
+www/CDash/images/RightBlack.gif
+www/CDash/images/advanced.png
+www/CDash/images/asc.gif
+www/CDash/images/bg.gif
+www/CDash/images/bg1.gif
+www/CDash/images/bgfo.gif
+www/CDash/images/bgtm.gif
+www/CDash/images/blank.gif
+www/CDash/images/blogo.gif
+www/CDash/images/cancel.png
+www/CDash/images/cdash-60.gif
+www/CDash/images/cdash.gif
+www/CDash/images/check.gif
+www/CDash/images/delete.png
+www/CDash/images/desc.gif
+www/CDash/images/edit.png
+www/CDash/images/edit2.png
+www/CDash/images/edit_group.png
+www/CDash/images/error.png
+www/CDash/images/feed-icon16x16.png
+www/CDash/images/filecoverage.png
+www/CDash/images/filter.gif
+www/CDash/images/flag.png
+www/CDash/images/flaggreen.gif
+www/CDash/images/folder.png
+www/CDash/images/graph.png
+www/CDash/images/help.gif
+www/CDash/images/hide.png
+www/CDash/images/invite.png
+www/CDash/images/loading.gif
+www/CDash/images/logo2.gif
+www/CDash/images/mail.png
+www/CDash/images/manageclient.png
+www/CDash/images/menu2_07.jpg
+www/CDash/images/menub1.gif
+www/CDash/images/menub2.gif
+www/CDash/images/new_project.png
+www/CDash/images/next.png
+www/CDash/images/note.png
+www/CDash/images/previous.png
+www/CDash/images/progressbar.gif
+www/CDash/images/progressbg_green.gif
+www/CDash/images/progressbg_orange.gif
+www/CDash/images/progressbg_red.gif
+www/CDash/images/refresh.png
+www/CDash/images/show.png
+www/CDash/images/star.png
+www/CDash/images/subproject.png
+www/CDash/images/systemtray.png
+www/CDash/images/tab.png
+www/CDash/images/tab2.png
+www/CDash/images/top_01.jpg
+www/CDash/images/top_02.jpg
+www/CDash/images/top_03.jpg
+www/CDash/images/top_04.jpg
+www/CDash/images/topbg1.gif
+www/CDash/images/topbg2.gif
+www/CDash/images/upgrade.png
+www/CDash/images/users.png
+www/CDash/images/warning.png
+www/CDash/images/warningsmall.png
+www/CDash/images/yellowled.png
+www/CDash/import.php
+www/CDash/import.xsl
+www/CDash/importBackup.php
+www/CDash/importBackup.xsl
+www/CDash/importBuilds.php
+www/CDash/index.php
+www/CDash/index.xsl
+www/CDash/indexsubproject.xsl
+www/CDash/indextable.xsl
+www/CDash/install.php
+www/CDash/install.xsl
+www/CDash/iphone/buildsummary.php
+www/CDash/iphone/buildsummary.xsl
+www/CDash/iphone/iPhoneArrow.png
+www/CDash/iphone/iPhoneArrow2.gif
+www/CDash/iphone/index.php
+www/CDash/iphone/index.xsl
+www/CDash/iphone/iphone.css
+www/CDash/iphone/iphone.js
+www/CDash/iphone/jquery-1.1.4.js
+www/CDash/iphone/jquery-iphone.js
+www/CDash/iphone/login.xsl
+www/CDash/iphone/logo.gif
+www/CDash/iphone/project.php
+www/CDash/iphone/project.xsl
+www/CDash/iphone/section.gif
+www/CDash/iphone/user.php
+www/CDash/iphone/user.xsl
+www/CDash/javascript/DashboardMap.js
+www/CDash/javascript/OptionTransfer.js
+www/CDash/javascript/cdashAddNote.js
+www/CDash/javascript/cdashBuildError.js
+www/CDash/javascript/cdashBuildGraph.js
+www/CDash/javascript/cdashBuildGroup.js
+www/CDash/javascript/cdashClient.js
+www/CDash/javascript/cdashCoverageGraph.js
+www/CDash/javascript/cdashCreateProject.js
+www/CDash/javascript/cdashFilters.js
+www/CDash/javascript/cdashIndexTable.js
+www/CDash/javascript/cdashManageCoverageSorter.js
+www/CDash/javascript/cdashManageUsers.js
+www/CDash/javascript/cdashProjectRole.js
+www/CDash/javascript/cdashSiteSorter.js
+www/CDash/javascript/cdashTableSorter.js
+www/CDash/javascript/cdashTestGraph.js
+www/CDash/javascript/cdashUpdateGraph.js
+www/CDash/javascript/cdashUpgrade.js
+www/CDash/javascript/cdashUser.js
+www/CDash/javascript/cdashUserLabels.js
+www/CDash/javascript/cdashmenu.css
+www/CDash/javascript/cdashmenu.js
+www/CDash/javascript/excanvas.js
+www/CDash/javascript/jqModal.css
+www/CDash/javascript/jqModal.js
+www/CDash/javascript/jquery.cookie.js
+www/CDash/javascript/jquery.flot.min.js
+www/CDash/javascript/jquery.flot.pie.js
+www/CDash/javascript/jquery.flot.selection.min.js
+www/CDash/javascript/jquery.js
+www/CDash/javascript/jquery.metadata.js
+www/CDash/javascript/jquery.tablesorter.js
+www/CDash/javascript/jtip.js
+www/CDash/javascript/menu.js
+www/CDash/javascript/rounded.js
+www/CDash/javascript/tableheader.js
+www/CDash/javascript/tooltip.js
+www/CDash/javascript/tree.js
+www/CDash/javascript/tree_init.js
+www/CDash/javascript/ui.datepicker.css
+www/CDash/javascript/ui.datepicker.js
+www/CDash/javascript/ui.tabs.js
+www/CDash/key.html
+www/CDash/local/README.txt
+www/CDash/local/footer.xsl
+www/CDash/local/header.xsl
+www/CDash/local/headeradminproject.xsl
+www/CDash/local/headerback.xsl
+www/CDash/local/headscripts.xsl
+www/CDash/loggingAdministration.php
+www/CDash/loggingAdministration.xsl
+www/CDash/login.php
+www/CDash/login.xsl
+www/CDash/manageBackup.php
+www/CDash/manageBackup.xsl
+www/CDash/manageBanner.php
+www/CDash/manageBanner.xsl
+www/CDash/manageBuildGroup.php
+www/CDash/manageBuildGroup.xsl
+www/CDash/manageClient.php
+www/CDash/manageClient.xsl
+www/CDash/manageCoverage.php
+www/CDash/manageCoverage.xsl
+www/CDash/manageProjectRoles.php
+www/CDash/manageProjectRoles.xsl
+www/CDash/manageSubproject.php
+www/CDash/manageSubproject.xsl
+www/CDash/manageUsers.php
+www/CDash/manageUsers.xsl
+www/CDash/models/banner.php
+www/CDash/models/build.php
+www/CDash/models/buildconfigure.php
+www/CDash/models/buildconfigureerror.php
+www/CDash/models/buildconfigureerrordiff.php
+www/CDash/models/builderror.php
+www/CDash/models/builderrordiff.php
+www/CDash/models/buildfailure.php
+www/CDash/models/buildgroup.php
+www/CDash/models/buildgroupposition.php
+www/CDash/models/buildgrouprule.php
+www/CDash/models/buildinformation.php
+www/CDash/models/buildnote.php
+www/CDash/models/buildtest.php
+www/CDash/models/buildtestdiff.php
+www/CDash/models/buildupdate.php
+www/CDash/models/buildupdatefile.php
+www/CDash/models/buildusernote.php
+www/CDash/models/clientcmake.php
+www/CDash/models/clientcompiler.php
+www/CDash/models/clientjob.php
+www/CDash/models/clientjobschedule.php
+www/CDash/models/clientlibrary.php
+www/CDash/models/clientos.php
+www/CDash/models/clientsite.php
+www/CDash/models/constants.php
+www/CDash/models/coverage.php
+www/CDash/models/coveragefile.php
+www/CDash/models/coveragefile2user.php
+www/CDash/models/coveragefilelog.php
+www/CDash/models/coveragesummary.php
+www/CDash/models/coveragesummarydiff.php
+www/CDash/models/dailyupdate.php
+www/CDash/models/dailyupdatefile.php
+www/CDash/models/dynamicanalysis.php
+www/CDash/models/dynamicanalysisdefect.php
+www/CDash/models/errorlog.php
+www/CDash/models/image.php
+www/CDash/models/label.php
+www/CDash/models/labelemail.php
+www/CDash/models/project.php
+www/CDash/models/site.php
+www/CDash/models/siteinformation.php
+www/CDash/models/subproject.php
+www/CDash/models/test.php
+www/CDash/models/testimage.php
+www/CDash/models/testmeasurement.php
+www/CDash/models/user.php
+www/CDash/models/userproject.php
+www/CDash/prepend_coverage.php
+www/CDash/queryTests.php
+www/CDash/queryTests.xsl
+www/CDash/recoverPassword.php
+www/CDash/recoverPassword.xsl
+www/CDash/register.php
+www/CDash/register.xsl
+www/CDash/removeBuilds.php
+www/CDash/removeBuilds.xsl
+www/CDash/router.php
+www/CDash/scheduleSummary.php
+www/CDash/scheduleSummary.xsl
+www/CDash/scripts/cdash_client_common.ctest
+www/CDash/siteStatistics.php
+www/CDash/siteStatistics.xsl
+www/CDash/sql/convert.sh
+www/CDash/sql/convert_alter_table.pl
+www/CDash/sql/mysql/cdash-upgrade-0-0.8.sql
+www/CDash/sql/mysql/cdash-upgrade-0.8-1.0.sql
+www/CDash/sql/mysql/cdash-upgrade-1.0-1.2.sql
+www/CDash/sql/mysql/cdash-upgrade-1.2-1.4.sql
+www/CDash/sql/mysql/cdash-upgrade-1.4-1.6.sql
+www/CDash/sql/mysql/cdash-upgrade-1.6-1.8.sql
+www/CDash/sql/mysql/cdash.sql
+www/CDash/sql/mysqlcompat.patch
+www/CDash/sql/pgsql/cdash-upgrade-0-0.8.sql
+www/CDash/sql/pgsql/cdash-upgrade-0.8-1.0.sql
+www/CDash/sql/pgsql/cdash-upgrade-1.0-1.2.sql
+www/CDash/sql/pgsql/cdash-upgrade-1.2-1.4.sql
+www/CDash/sql/pgsql/cdash-upgrade-1.4-1.6.sql
+www/CDash/sql/pgsql/cdash-upgrade-1.6-1.8.sql
+www/CDash/sql/pgsql/cdash.ext.sql
+www/CDash/sql/pgsql/cdash.sql
+www/CDash/submit.php
+www/CDash/subscribeProject.php
+www/CDash/subscribeProject.xsl
+www/CDash/svninfo.php
+www/CDash/tabs_ie.css
+www/CDash/testDetails.php
+www/CDash/testDetails.xsl
+www/CDash/testOverview.php
+www/CDash/testOverview.xsl
+www/CDash/testSummary.php
+www/CDash/testSummary.xsl
+www/CDash/tests/CMakeLists.txt
+www/CDash/tests/append_coverage.php.in
+www/CDash/tests/autoremovebuilds/CMakeLists.txt
+www/CDash/tests/cdash_test_case.php
+www/CDash/tests/config.test.php
+www/CDash/tests/ctest/CMakeLists.txt
+www/CDash/tests/ctest/CTestSubmitLargeOutput/CMakeLists.txt
+www/CDash/tests/ctest/CTestSubmitLargeOutput/CTestConfig.cmake
+www/CDash/tests/ctest/CTestSubmitLargeOutput/GenerateRandomOutput.cmake
+www/CDash/tests/ctest/CTestSubmitLargeOutput/test.cmake.in
+www/CDash/tests/ctest/coveragedriver.ctest.in
+www/CDash/tests/ctest/ctestdriver.ctest.in
+www/CDash/tests/ctest/sameImage/CMakeLists.txt
+www/CDash/tests/ctest/sameImage/frown.gif
+www/CDash/tests/ctest/sameImage/sameImage.cxx
+www/CDash/tests/ctest/sameImage/smile.gif
+www/CDash/tests/ctest/sameImage/test.cmake.in
+www/CDash/tests/ctest/simple/CMakeLists.txt
+www/CDash/tests/ctest/simple/crash.cxx
+www/CDash/tests/ctest/simple/simple.cxx
+www/CDash/tests/ctest/simple/test.cmake.in
+www/CDash/tests/ctest/simple2/CMakeLists.txt
+www/CDash/tests/ctest/simple2/crash.cxx
+www/CDash/tests/ctest/simple2/simple.ctest.in
+www/CDash/tests/ctest/simple2/simple.cxx
+www/CDash/tests/ctest/simple2/test.cmake.in
+www/CDash/tests/ctest/unittest.cmake.in
+www/CDash/tests/data/BatchmakeNightlyExample/BatchMake_Nightly_Build.xml
+www/CDash/tests/data/BatchmakeNightlyExample/BatchMake_Nightly_Configure.xml
+www/CDash/tests/data/BatchmakeNightlyExample/BatchMake_Nightly_Notes.xml
+www/CDash/tests/data/BatchmakeNightlyExample/BatchMake_Nightly_Test.xml
+www/CDash/tests/data/BatchmakeNightlyExample/BatchMake_Nightly_Update.xml
+www/CDash/tests/data/CompressedTest.xml
+www/CDash/tests/data/EmailProjectExample/1_build.xml
+www/CDash/tests/data/EmailProjectExample/1_configure.xml
+www/CDash/tests/data/EmailProjectExample/1_test.xml
+www/CDash/tests/data/EmailProjectExample/2_build.xml
+www/CDash/tests/data/EmailProjectExample/2_dynamicanalysis.xml
+www/CDash/tests/data/EmailProjectExample/2_test.xml
+www/CDash/tests/data/EmailProjectExample/2_update.xml
+www/CDash/tests/data/EmailProjectExample/cdash_1.log
+www/CDash/tests/data/EmailProjectExample/cdash_2.log
+www/CDash/tests/data/EmailProjectExample/cdash_3.log
+www/CDash/tests/data/EmailProjectExample/cdash_autoremove.log
+www/CDash/tests/data/InsightExperimentalExample/Insight_Experimental_Build.xml
+www/CDash/tests/data/InsightExperimentalExample/Insight_Experimental_Configure.xml
+www/CDash/tests/data/InsightExperimentalExample/Insight_Experimental_Coverage.xml
+www/CDash/tests/data/InsightExperimentalExample/Insight_Experimental_CoverageLog.xml
+www/CDash/tests/data/InsightExperimentalExample/Insight_Experimental_DynamicAnalysis.xml
+www/CDash/tests/data/InsightExperimentalExample/Insight_Experimental_Notes.xml
+www/CDash/tests/data/InsightExperimentalExample/Insight_Experimental_Test.xml
+www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71/2005-07-19-0514-Experimental/XML/Build.xml
+www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71/2005-07-19-0514-Experimental/XML/Configure.xml
+www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71/2005-07-19-0514-Experimental/XML/NoteCollection.xml
+www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71/2005-07-19-0514-Experimental/XML/Notes.xml
+www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71/2005-07-19-0514-Experimental/XML/Test.xml
+www/CDash/tests/data/SortingExample/long_Build.xml
+www/CDash/tests/data/SortingExample/long_Configure.xml
+www/CDash/tests/data/SortingExample/long_Notes.xml
+www/CDash/tests/data/SortingExample/long_Test.xml
+www/CDash/tests/data/SortingExample/long_Update.xml
+www/CDash/tests/data/SortingExample/medium_Build.xml
+www/CDash/tests/data/SortingExample/medium_Configure.xml
+www/CDash/tests/data/SortingExample/medium_Notes.xml
+www/CDash/tests/data/SortingExample/medium_Test.xml
+www/CDash/tests/data/SortingExample/medium_Update.xml
+www/CDash/tests/data/SortingExample/short_Build.xml
+www/CDash/tests/data/SortingExample/short_Configure.xml
+www/CDash/tests/data/SortingExample/short_Notes.xml
+www/CDash/tests/data/SortingExample/short_Test.xml
+www/CDash/tests/data/SortingExample/short_Update.xml
+www/CDash/tests/data/SubProjectExample/Build_1.xml
+www/CDash/tests/data/SubProjectExample/Project_1.xml
+www/CDash/tests/data/SubProjectExample/Test_1.xml
+www/CDash/tests/data/SubProjectExample/cdash_1.log
+www/CDash/tests/data/SubProjectExample/cdash_2.log
+www/CDash/tests/data/authors.txt
+www/CDash/tests/data/camelot.cdash.xml
+www/CDash/tests/data/git-Update.xml
+www/CDash/tests/data/smile.gif
+www/CDash/tests/data/smile2.gif
+www/CDash/tests/kwtest/kw_db.php
+www/CDash/tests/kwtest/kw_test_manager.php
+www/CDash/tests/kwtest/kw_web_tester.php
+www/CDash/tests/kwtest/simpletest/authentication.php
+www/CDash/tests/kwtest/simpletest/autorun.php
+www/CDash/tests/kwtest/simpletest/browser.php
+www/CDash/tests/kwtest/simpletest/collector.php
+www/CDash/tests/kwtest/simpletest/compatibility.php
+www/CDash/tests/kwtest/simpletest/cookies.php
+www/CDash/tests/kwtest/simpletest/default_reporter.php
+www/CDash/tests/kwtest/simpletest/detached.php
+www/CDash/tests/kwtest/simpletest/dumper.php
+www/CDash/tests/kwtest/simpletest/eclipse.php
+www/CDash/tests/kwtest/simpletest/encoding.php
+www/CDash/tests/kwtest/simpletest/errors.php
+www/CDash/tests/kwtest/simpletest/exceptions.php
+www/CDash/tests/kwtest/simpletest/expectation.php
+www/CDash/tests/kwtest/simpletest/form.php
+www/CDash/tests/kwtest/simpletest/frames.php
+www/CDash/tests/kwtest/simpletest/http.php
+www/CDash/tests/kwtest/simpletest/invoker.php
+www/CDash/tests/kwtest/simpletest/mock_objects.php
+www/CDash/tests/kwtest/simpletest/page.php
+www/CDash/tests/kwtest/simpletest/parser.php
+www/CDash/tests/kwtest/simpletest/reflection_php4.php
+www/CDash/tests/kwtest/simpletest/reflection_php5.php
+www/CDash/tests/kwtest/simpletest/remote.php
+www/CDash/tests/kwtest/simpletest/reporter.php
+www/CDash/tests/kwtest/simpletest/scorer.php
+www/CDash/tests/kwtest/simpletest/selector.php
+www/CDash/tests/kwtest/simpletest/shell_tester.php
+www/CDash/tests/kwtest/simpletest/simpletest.php
+www/CDash/tests/kwtest/simpletest/socket.php
+www/CDash/tests/kwtest/simpletest/tag.php
+www/CDash/tests/kwtest/simpletest/test_case.php
+www/CDash/tests/kwtest/simpletest/unit_tester.php
+www/CDash/tests/kwtest/simpletest/url.php
+www/CDash/tests/kwtest/simpletest/user_agent.php
+www/CDash/tests/kwtest/simpletest/web_tester.php
+www/CDash/tests/kwtest/simpletest/xml.php
+www/CDash/tests/loginCoverage.php
+www/CDash/tests/manageCoverageTest.php
+www/CDash/tests/sameImage.php
+www/CDash/tests/selenium/CMakeLists.txt
+www/CDash/tests/selenium/cdash_selenium_test_case.php
+www/CDash/tests/selenium/test_addbuildgroup.php
+www/CDash/tests/selenium/test_buildinfogroup.html
+www/CDash/tests/selenium/test_buildinfogroup.php
+www/CDash/tests/selenium/test_buildnote.html
+www/CDash/tests/selenium/test_buildnote.php
+www/CDash/tests/selenium/test_buildsummary.html
+www/CDash/tests/selenium/test_buildsummary.php
+www/CDash/tests/selenium/test_editsite.html
+www/CDash/tests/selenium/test_editsite.php
+www/CDash/tests/selenium/test_emailsubscription.html
+www/CDash/tests/selenium/test_emailsubscription.php
+www/CDash/tests/selenium/test_expectedbuildgroup.html
+www/CDash/tests/selenium/test_expectedbuildgroup.php
+www/CDash/tests/selenium/test_finduserproject.html
+www/CDash/tests/selenium/test_finduserproject.php
+www/CDash/tests/selenium/test_findusers.html
+www/CDash/tests/selenium/test_findusers.php
+www/CDash/tests/selenium/test_querytestsfilters.html
+www/CDash/tests/selenium/test_querytestsfilters.php
+www/CDash/tests/selenium/test_removescheduledbuild.html
+www/CDash/tests/selenium/test_removescheduledbuild.php
+www/CDash/tests/selenium/test_requestwork.html
+www/CDash/tests/selenium/test_requestwork.php
+www/CDash/tests/selenium/test_setup_repositories.html
+www/CDash/tests/selenium/test_setup_repositories.php
+www/CDash/tests/selenium/test_showcoveragegraph.html
+www/CDash/tests/selenium/test_showcoveragegraph.php
+www/CDash/tests/selenium/test_showtestgraphs.html
+www/CDash/tests/selenium/test_showtestgraphs.php
+www/CDash/tests/selenium/test_showupdategraph.html
+www/CDash/tests/selenium/test_showupdategraph.php
+www/CDash/tests/selenium/test_sortbuilderror.php
+www/CDash/tests/selenium/test_sortbuildname.php
+www/CDash/tests/selenium/test_sortbuildtime.php
+www/CDash/tests/selenium/test_sortbuildtiming.php
+www/CDash/tests/selenium/test_sortbuildwarning.php
+www/CDash/tests/selenium/test_sortconfigureerror.php
+www/CDash/tests/selenium/test_sortconfiguretiming.php
+www/CDash/tests/selenium/test_sortconfigurewarning.php
+www/CDash/tests/selenium/test_sortsite.php
+www/CDash/tests/selenium/test_sorttestfail.php
+www/CDash/tests/selenium/test_sorttestnotrun.php
+www/CDash/tests/selenium/test_sorttestpass.php
+www/CDash/tests/selenium/test_sorttesttiming.html
+www/CDash/tests/selenium/test_sorttesttiming.php
+www/CDash/tests/selenium/test_sortupdatefiles.php
+www/CDash/tests/selenium/test_sortupdatetiming.php
+www/CDash/tests/selenium/test_subproject2.html
+www/CDash/tests/selenium/test_subproject2.php
+www/CDash/tests/simple.php
+www/CDash/tests/simple2.php
+www/CDash/tests/singletest.php
+www/CDash/tests/test_api.php
+www/CDash/tests/test_autoremovebuilds.php
+www/CDash/tests/test_autoremovebuilds_on_submit.php
+www/CDash/tests/test_banner.php
+www/CDash/tests/test_buildconfigure.php
+www/CDash/tests/test_builderrordiff.php
+www/CDash/tests/test_buildgroupposition.php
+www/CDash/tests/test_buildgrouprule.php
+www/CDash/tests/test_buildmodel.php
+www/CDash/tests/test_buildoverview.php
+www/CDash/tests/test_buildtestdiff.php
+www/CDash/tests/test_buildusernote.php
+www/CDash/tests/test_compressedtest.php
+www/CDash/tests/test_createpublicdashboard.php
+www/CDash/tests/test_customclientscript.php
+www/CDash/tests/test_dailyupdatefile.php
+www/CDash/tests/test_deletedailyupdate.php
+www/CDash/tests/test_displayimage.php
+www/CDash/tests/test_editautoremovesettings.php
+www/CDash/tests/test_edituser.php
+www/CDash/tests/test_email.php
+www/CDash/tests/test_enable_async.php
+www/CDash/tests/test_errorlog.php
+www/CDash/tests/test_groupsdescription.php
+www/CDash/tests/test_image.php
+www/CDash/tests/test_import.php
+www/CDash/tests/test_importbackup.php
+www/CDash/tests/test_importbuilds.php
+www/CDash/tests/test_install.php
+www/CDash/tests/test_iphone.php
+www/CDash/tests/test_loggingadministration.php
+www/CDash/tests/test_login.php
+www/CDash/tests/test_managebackup.php
+www/CDash/tests/test_managebanner.php
+www/CDash/tests/test_managebuildgroup.php
+www/CDash/tests/test_manageclient.php
+www/CDash/tests/test_manageprojectroles.php
+www/CDash/tests/test_managesubproject.php
+www/CDash/tests/test_manageusers.php
+www/CDash/tests/test_processsubmissions.php
+www/CDash/tests/test_projectindb.php
+www/CDash/tests/test_projectmodel.php
+www/CDash/tests/test_projectwebpage.php
+www/CDash/tests/test_pubproject.php
+www/CDash/tests/test_querytests.php
+www/CDash/tests/test_recoverpassword.php
+www/CDash/tests/test_removebuilds.php
+www/CDash/tests/test_router.php
+www/CDash/tests/test_sitestatistics.php
+www/CDash/tests/test_submitsortingdata.php
+www/CDash/tests/test_subproject.php
+www/CDash/tests/test_svninfo.php
+www/CDash/tests/test_testenv.php
+www/CDash/tests/test_testmodel.php
+www/CDash/tests/test_testoverview.php
+www/CDash/tests/test_upgrade.php
+www/CDash/tests/test_user.php
+www/CDash/tests/test_userstatistics.php
+www/CDash/tests/test_viewbuilderror.php
+www/CDash/tests/test_viewchanges.php
+www/CDash/tests/test_viewconfigure.php
+www/CDash/tests/test_viewdynamicanalysis.php
+www/CDash/tests/test_viewdynamicanalysisfile.php
+www/CDash/tests/test_viewerrorlog.php
+www/CDash/tests/test_viewissues.php
+www/CDash/tests/test_viewmap.php
+www/CDash/tests/test_viewsubprojectdependencies.php
+www/CDash/upgrade.php
+www/CDash/upgrade.xsl
+www/CDash/user.php
+www/CDash/user.xsl
+www/CDash/userStatistics.php
+www/CDash/userStatistics.xsl
+www/CDash/viewBuildError.php
+www/CDash/viewBuildError.xsl
+www/CDash/viewChanges.php
+www/CDash/viewChanges.xsl
+www/CDash/viewConfigure.php
+www/CDash/viewConfigure.xsl
+www/CDash/viewCoverage.php
+www/CDash/viewCoverage.xsl
+www/CDash/viewCoverageFile.php
+www/CDash/viewCoverageFile.xsl
+www/CDash/viewDynamicAnalysis.php
+www/CDash/viewDynamicAnalysis.xsl
+www/CDash/viewDynamicAnalysisFile.php
+www/CDash/viewDynamicAnalysisFile.xsl
+www/CDash/viewErrorLog.php
+www/CDash/viewErrorLog.xsl
+www/CDash/viewIssues.php
+www/CDash/viewIssues.xsl
+www/CDash/viewMap.php
+www/CDash/viewMap.xsl
+www/CDash/viewNotes.php
+www/CDash/viewNotes.xsl
+www/CDash/viewSite.php
+www/CDash/viewSite.xsl
+www/CDash/viewSubprojectDependencies.php
+www/CDash/viewSubprojectDependencies.xsl
+www/CDash/viewTest.php
+www/CDash/viewTest.xsl
+www/CDash/viewUpdate.php
+www/CDash/viewUpdate.xsl
+www/CDash/whileUpgrading.php
+www/CDash/xml_handlers/abstract_handler.php
+www/CDash/xml_handlers/build_handler.php
+www/CDash/xml_handlers/configure_handler.php
+www/CDash/xml_handlers/coverage_handler.php
+www/CDash/xml_handlers/coverage_log_handler.php
+www/CDash/xml_handlers/dynamic_analysis_handler.php
+www/CDash/xml_handlers/note_handler.php
+www/CDash/xml_handlers/project_handler.php
+www/CDash/xml_handlers/sax_handler.php
+www/CDash/xml_handlers/stack.php
+www/CDash/xml_handlers/testing_handler.php
+www/CDash/xml_handlers/update_handler.php
+@dirrm www/CDash/xml_handlers
+@dirrm www/CDash/tests/selenium
+@dirrm www/CDash/tests/kwtest/simpletest
+@dirrm www/CDash/tests/kwtest
+@dirrm www/CDash/tests/data/SubProjectExample
+@dirrm www/CDash/tests/data/SortingExample
+@dirrm www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71/2005-07-19-0514-Experimental/XML
+@dirrm www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71/2005-07-19-0514-Experimental
+@dirrm www/CDash/tests/data/Sites/VOGON.kitware/Win32-nmake71
+@dirrm www/CDash/tests/data/Sites/VOGON.kitware
+@dirrm www/CDash/tests/data/Sites
+@dirrm www/CDash/tests/data/InsightExperimentalExample
+@dirrm www/CDash/tests/data/EmailProjectExample
+@dirrm www/CDash/tests/data/BatchmakeNightlyExample
+@dirrm www/CDash/tests/data
+@dirrm www/CDash/tests/ctest/simple2
+@dirrm www/CDash/tests/ctest/simple
+@dirrm www/CDash/tests/ctest/sameImage
+@dirrm www/CDash/tests/ctest/CTestSubmitLargeOutput
+@dirrm www/CDash/tests/ctest
+@dirrm www/CDash/tests/autoremovebuilds
+@dirrm www/CDash/tests
+@dirrm www/CDash/sql/pgsql
+@dirrm www/CDash/sql/mysql
+@dirrm www/CDash/sql
+@dirrm www/CDash/scripts
+@dirrm www/CDash/rss
+@dirrm www/CDash/models
+@dirrm www/CDash/local
+@dirrm www/CDash/javascript
+@dirrm www/CDash/iphone
+@dirrm www/CDash/images
+@dirrm www/CDash/cdash
+@dirrm www/CDash/backup
+@dirrm www/CDash/api
+@dirrm www/CDash/ajax
+@dirrm www/CDash