aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cdk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-06-23 07:25:50 +0800
committerbapt <bapt@FreeBSD.org>2015-06-23 07:25:50 +0800
commit2abe5ee9f8ae24b5cbf6dec155e98b68d6ac8959 (patch)
treea5c3f1ad8fa1847bbee9a661ca92e5ac70c280f0 /devel/cdk
parentc511b6185d7ecaea3628d058647d7b105c371089 (diff)
downloadfreebsd-ports-gnome-2abe5ee9f8ae24b5cbf6dec155e98b68d6ac8959.tar.gz
freebsd-ports-gnome-2abe5ee9f8ae24b5cbf6dec155e98b68d6ac8959.tar.zst
freebsd-ports-gnome-2abe5ee9f8ae24b5cbf6dec155e98b68d6ac8959.zip
Simplify example installation
Use pax(1) which is less noisy then cpio(1)
Diffstat (limited to 'devel/cdk')
-rw-r--r--devel/cdk/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index 9afb2ad8036d..a03c99e98ba4 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -35,15 +35,9 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/cli
- cd ${WRKSRC}/cli; \
- ${FIND} . | ${CPIO} -pdm -R ${LIBOWN}:${LIBGRP} ${STAGEDIR}${EXAMPLESDIR}/cli
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/demos
- cd ${WRKSRC}/demos; \
- ${FIND} . | ${CPIO} -pdm -R ${LIBOWN}:${LIBGRP} ${STAGEDIR}${EXAMPLESDIR}/demos
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/examples
- cd ${WRKSRC}/examples; \
- ${FIND} . | ${CPIO} -pdm -R ${LIBOWN}:${LIBGRP} ${STAGEDIR}${EXAMPLESDIR}/examples
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}; \
+ ${FIND} cli demos examples | ${PAX} -rw ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>