aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-asdf-clisp
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
commitdb6c634e448bc8765cbc58ca91b1a4e4aa41610a (patch)
tree9c5ff04da0b9c023f86f7db9b932c7c9a9da8101 /devel/cl-asdf-clisp
parente434a643efdf84c3dfcdc64e58706cc363f818d1 (diff)
downloadfreebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.gz
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.zst
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Diffstat (limited to 'devel/cl-asdf-clisp')
-rw-r--r--devel/cl-asdf-clisp/Makefile28
-rw-r--r--devel/cl-asdf-clisp/pkg-plist1
2 files changed, 9 insertions, 20 deletions
diff --git a/devel/cl-asdf-clisp/Makefile b/devel/cl-asdf-clisp/Makefile
index c25f5f2037d8..579495702792 100644
--- a/devel/cl-asdf-clisp/Makefile
+++ b/devel/cl-asdf-clisp/Makefile
@@ -1,4 +1,4 @@
-# New ports collection Makefile for: cl-asdf-sbcl
+# New ports collection Makefile for: cl-asdf-clisp
# Date created: 10 May 2003
# Whom: Henrik Motakef <henrik.motakef@web.de>
#
@@ -6,34 +6,24 @@
PORTNAME= asdf
PORTVERSION= 1.374
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -clisp
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A system definition facility for Common Lisp
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
- clisp:${PORTSDIR}/lang/clisp
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
- clisp:${PORTSDIR}/lang/clisp
+# Even if this port builds FASL files, it is slightly different from
+# other FASL ports because it uses USE_ASDF rather than USE_ASDF_FASL.
-ASDF_MODULES= asdf.lisp wild-modules.lisp
+USE_ASDF= yes
+FASL_TARGET= clisp
+FASL_BUILD= yes
post-extract:
@${MKDIR} ${WRKSRC}
-do-build:
- @clisp -q -ansi -norc \
- -x "(compile-file \"${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp\" :output-file \"${WRKSRC}/asdf.fasl\")" \
- -x "(compile-file \"${LOCALBASE}/lib/common-lisp/asdf/wild-modules.lisp\" :output-file \"${WRKSRC}/wild-modules.fasl\")" \
- -x "(quit)";
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/common-lisp/asdf/clispfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/asdf/clispfasl
-
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>
diff --git a/devel/cl-asdf-clisp/pkg-plist b/devel/cl-asdf-clisp/pkg-plist
index 9c82491b042c..9ab70a3fc4e5 100644
--- a/devel/cl-asdf-clisp/pkg-plist
+++ b/devel/cl-asdf-clisp/pkg-plist
@@ -1,3 +1,2 @@
lib/common-lisp/asdf/clispfasl/asdf.fasl
-lib/common-lisp/asdf/clispfasl/wild-modules.fasl
@dirrm lib/common-lisp/asdf/clispfasl