aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-asdf-cmucl
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-28 17:13:43 +0800
committeredwin <edwin@FreeBSD.org>2003-09-28 17:13:43 +0800
commit52d809ae3638eecad5882e471656b1867a37d9bf (patch)
treea0374785bc21c32c7b4017a4440a2589e06b2f1e /devel/cl-asdf-cmucl
parent987d89d64a21c0bbf8734b7b997d86b6a7ca8926 (diff)
downloadfreebsd-ports-gnome-52d809ae3638eecad5882e471656b1867a37d9bf.tar.gz
freebsd-ports-gnome-52d809ae3638eecad5882e471656b1867a37d9bf.tar.zst
freebsd-ports-gnome-52d809ae3638eecad5882e471656b1867a37d9bf.zip
New Port: ASDF, a Common Lisp library manager (CMUCL Binaries)
ASDF binaries for lang/cmucl PR: ports/52359 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Diffstat (limited to 'devel/cl-asdf-cmucl')
-rw-r--r--devel/cl-asdf-cmucl/Makefile39
-rw-r--r--devel/cl-asdf-cmucl/pkg-descr11
-rw-r--r--devel/cl-asdf-cmucl/pkg-plist3
3 files changed, 53 insertions, 0 deletions
diff --git a/devel/cl-asdf-cmucl/Makefile b/devel/cl-asdf-cmucl/Makefile
new file mode 100644
index 000000000000..2bdb91db9af8
--- /dev/null
+++ b/devel/cl-asdf-cmucl/Makefile
@@ -0,0 +1,39 @@
+# New ports collection Makefile for: cl-asdf-cmucl
+# Date created: 10 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= asdf
+PORTVERSION= 2003.05.16
+CATEGORIES= devel
+MASTER_SITES= http://www.henrik-motakef.de/freebsd-distfiles/asdf/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -cmucl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= A system definition facility for Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
+ lisp:${PORTSDIR}/lang/cmucl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
+ lisp:${PORTSDIR}/lang/cmucl
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+do-build:
+ lisp -noinit -nositeinit \
+ -eval '(compile-file "${PREFIX}/lib/common-lisp/asdf/asdf.lisp" \
+ :output-file "${WRKSRC}/asdf.fasl")' \
+ -eval '(compile-file "${PREFIX}/lib/common-lisp/asdf/wild-modules.lisp" \
+ :output-file "${WRKSRC}/wild-modules.fasl")' \
+ -eval '(quit)'
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/asdf/cmuclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/asdf/cmuclfasl
+
+.include <bsd.port.mk>
diff --git a/devel/cl-asdf-cmucl/pkg-descr b/devel/cl-asdf-cmucl/pkg-descr
new file mode 100644
index 000000000000..22d206f09da8
--- /dev/null
+++ b/devel/cl-asdf-cmucl/pkg-descr
@@ -0,0 +1,11 @@
+asdf is Another System Definition Facility for Common Lisp. It intends
+to solve the same class of problems as mk-defsystem - compiling and
+installing Lisp libraries -, but internally it takes advantage of
+modern CL features like pathname support etc., and uses CLOS for
+extensibility.
+
+This package installs binaries compiled for CMU Common Lisp.
+
+WWW: http://www.cliki.net/asdf
+
+- Henrik Motakef
diff --git a/devel/cl-asdf-cmucl/pkg-plist b/devel/cl-asdf-cmucl/pkg-plist
new file mode 100644
index 000000000000..ee41ad1da9d1
--- /dev/null
+++ b/devel/cl-asdf-cmucl/pkg-plist
@@ -0,0 +1,3 @@
+lib/common-lisp/asdf/cmuclfasl/asdf.fasl
+lib/common-lisp/asdf/cmuclfasl/wild-modules.fasl
+@dirrm lib/common-lisp/asdf/cmuclfasl