aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-cffi-sbcl
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-21 05:48:31 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-21 05:48:31 +0800
commit1ac22d5c1198cc797b6390359f5c63bb697fef4e (patch)
treec5b8abb5db64a0290fdc9be471d00a0c81a0f47e /devel/cl-cffi-sbcl
parente0acfa95bf3f26d54eaaa84d9b91677923dc404d (diff)
downloadfreebsd-ports-gnome-1ac22d5c1198cc797b6390359f5c63bb697fef4e.tar.gz
freebsd-ports-gnome-1ac22d5c1198cc797b6390359f5c63bb697fef4e.tar.zst
freebsd-ports-gnome-1ac22d5c1198cc797b6390359f5c63bb697fef4e.zip
Add cl-cffi, a portable foreign function interface for Common Lisp
with a cl-uffi compatibility layer.
Diffstat (limited to 'devel/cl-cffi-sbcl')
-rw-r--r--devel/cl-cffi-sbcl/Makefile29
-rw-r--r--devel/cl-cffi-sbcl/pkg-descr16
2 files changed, 45 insertions, 0 deletions
diff --git a/devel/cl-cffi-sbcl/Makefile b/devel/cl-cffi-sbcl/Makefile
new file mode 100644
index 000000000000..90be0a20c2ce
--- /dev/null
+++ b/devel/cl-cffi-sbcl/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: cl-cffi-sbcl
+# Date created: 20 January 2010
+# Whom: Jimmy Olgeni <olgeni@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= cffi
+PORTVERSION= 0.10.5
+CATEGORIES= devel lisp
+PKGNAMEPREFIX= cl-
+DISTFILES= # none
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A portable foreign function interface for Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/sbclfasl/arrays.fasl:${PORTSDIR}/devel/cl-alexandria-sbcl \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/sbclfasl/src/tf-sbcl.fasl:${PORTSDIR}/devel/cl-trivial-features-sbcl \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/babel/sbclfasl/src/enc-ascii.fasl:${PORTSDIR}/converters/cl-babel-sbcl
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/alexandria/sbclfasl/arrays.fasl:${PORTSDIR}/devel/cl-alexandria-sbcl \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/trivial-features/sbclfasl/src/tf-sbcl.fasl:${PORTSDIR}/devel/cl-trivial-features-sbcl \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/babel/sbclfasl/src/enc-ascii.fasl:${PORTSDIR}/converters/cl-babel-sbcl
+
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
+ASDF_MODULES= cffi cffi-grovel cffi-uffi-compat
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+.include <bsd.port.mk>
diff --git a/devel/cl-cffi-sbcl/pkg-descr b/devel/cl-cffi-sbcl/pkg-descr
new file mode 100644
index 000000000000..523ae4a8b94d
--- /dev/null
+++ b/devel/cl-cffi-sbcl/pkg-descr
@@ -0,0 +1,16 @@
+CFFI, the Common Foreign Function Interface, purports to be a
+portable foreign function interface for Common Lisp. The CFFI library
+is composed of a Lisp-implementation-specific backend in the CFFI-SYS
+package, and a portable frontend in the CFFI package.
+
+The CFFI-SYS backend package defines a low-level interface to the
+native FFI support in the Lisp implementation. It offers operators
+for allocating and dereferencing foreign memory, calling foreign
+functions, and loading shared libraries. The CFFI frontend provides
+a declarative interface for defining foreign functions, structures,
+typedefs, enumerated types, etc. It is implemented in portable ANSI
+CL making use of the low-level operators exported by CFFI-SYS.
+
+This package is compiled with SBCL.
+
+WWW: http://common-lisp.net/project/cffi/