aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-infix
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
commitdb6c634e448bc8765cbc58ca91b1a4e4aa41610a (patch)
tree9c5ff04da0b9c023f86f7db9b932c7c9a9da8101 /devel/cl-infix
parente434a643efdf84c3dfcdc64e58706cc363f818d1 (diff)
downloadfreebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.gz
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.zst
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Diffstat (limited to 'devel/cl-infix')
-rw-r--r--devel/cl-infix/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/devel/cl-infix/Makefile b/devel/cl-infix/Makefile
index 1fd87d4487b7..ba7856331853 100644
--- a/devel/cl-infix/Makefile
+++ b/devel/cl-infix/Makefile
@@ -5,7 +5,8 @@
# $FreeBSD$
PORTNAME= infix
-DISTVERSION= 19960628
+PORTVERSION= 19960628
+PORTREVISION= 1
CATEGORIES= devel lisp
MASTER_SITES= http://ftp.linux.org.uk/pub/lisp/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
@@ -17,29 +18,24 @@ DISTNAME= ${PORTNAME}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A lisp macro for reading math expressions in infix form
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-CL_LIBDIR= ${PREFIX}/lib/common-lisp
-
NO_BUILD= yes
NO_CDROM= No fees or compensation can be charged
-LPORTDOCS= COPYING infix.3lisp
+USE_ASDF= yes
do-install:
- @${MKDIR} ${CL_LIBDIR}/infix
- @${INSTALL_DATA} ${WRKSRC}/infix.asd ${CL_LIBDIR}/infix/
- @${INSTALL_DATA} ${WRKSRC}/*.cl ${CL_LIBDIR}/infix/
- @${INSTALL_DATA} ${WRKSRC}/infix.system ${CL_LIBDIR}/infix/
- @${LN} -sf ${CL_LIBDIR}/infix/infix.asd ${CL_LIBDIR}/system-registry/infix.asd
+ @${MKDIR} ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/*.cl ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/infix.asd ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/infix.system ${ASDF_PATHNAME}
+ @${LN} -sf ${ASDF_PATHNAME}/*.asd ${ASDF_REGISTRY}
.if !defined(NOPORTDOCS)
-.for FILE in ${LPORTDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/
+.for FILE in COPYING infix.3lisp
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
.endif
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>