aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-port-sbcl/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
commitdb6c634e448bc8765cbc58ca91b1a4e4aa41610a (patch)
tree9c5ff04da0b9c023f86f7db9b932c7c9a9da8101 /devel/cl-port-sbcl/Makefile
parente434a643efdf84c3dfcdc64e58706cc363f818d1 (diff)
downloadfreebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.gz
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.zst
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Diffstat (limited to 'devel/cl-port-sbcl/Makefile')
-rw-r--r--devel/cl-port-sbcl/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/devel/cl-port-sbcl/Makefile b/devel/cl-port-sbcl/Makefile
index 4d0d00184a6f..9ad8bd1e8238 100644
--- a/devel/cl-port-sbcl/Makefile
+++ b/devel/cl-port-sbcl/Makefile
@@ -6,32 +6,23 @@
PORTNAME= port
PORTVERSION= 2002.10.02.1
+PORTREVISION= 1
CATEGORIES= devel lisp
MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -sbcl
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Cross-Lisp portability package
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
- sbcl:${PORTSDIR}/lang/sbcl
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
- sbcl:${PORTSDIR}/lang/sbcl
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
-do-build:
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
- sbcl --noinform --userinit /dev/null \
- --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
- --eval "(asdf:oos 'asdf:compile-op :port)" \
- --eval "(quit)"
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/common-lisp/port/sbclfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/port/sbclfasl/
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>