aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-port
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
commitdb6c634e448bc8765cbc58ca91b1a4e4aa41610a (patch)
tree9c5ff04da0b9c023f86f7db9b932c7c9a9da8101 /devel/cl-port
parente434a643efdf84c3dfcdc64e58706cc363f818d1 (diff)
downloadfreebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.gz
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.zst
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Diffstat (limited to 'devel/cl-port')
-rw-r--r--devel/cl-port/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/devel/cl-port/Makefile b/devel/cl-port/Makefile
index 32a1849a8d26..4764df62e17f 100644
--- a/devel/cl-port/Makefile
+++ b/devel/cl-port/Makefile
@@ -6,7 +6,7 @@
PORTNAME= port
PORTVERSION= 2002.10.02.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lisp
MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
@@ -17,23 +17,21 @@ DISTNAME= clocc-${PORTNAME}_2002-10-02-1
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Cross-Lisp portability package
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-
WRKSRC= ${WRKDIR}/clocc-${PORTNAME}
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
NO_BUILD= yes
-CL_LIBDIR= ${PREFIX}/lib/common-lisp
+
+USE_ASDF= yes
do-install:
- @${MKDIR} ${CL_LIBDIR}/port
- @${INSTALL_DATA} ${WRKSRC}/clocc-port.asd ${CL_LIBDIR}/port/port.asd
- @${INSTALL_DATA} ${WRKSRC}/port.system ${CL_LIBDIR}/port/port.system
- @${INSTALL_DATA} ${WRKSRC}/*.lisp ${CL_LIBDIR}/port/
- @${LN} -sf ${CL_LIBDIR}/port/port.asd ${CL_LIBDIR}/system-registry/port.asd
+ @${MKDIR} ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/clocc-port.asd ${ASDF_PATHNAME}/port.asd
+ @${INSTALL_DATA} ${WRKSRC}/port.system ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/*.lisp ${ASDF_PATHNAME}
+ @${LN} -sf ${ASDF_PATHNAME}/*.asd ${ASDF_REGISTRY}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/port.html ${DOCSDIR}
.endif
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>