aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-uffi-cmucl/Makefile
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-04-14 18:41:10 +0800
committerflz <flz@FreeBSD.org>2005-04-14 18:41:10 +0800
commit47fedc331eab203d2d5895b62ce22efe75f05f94 (patch)
tree0a94200318f4233d572743a95387da1d08a7a826 /devel/cl-uffi-cmucl/Makefile
parent2c11c66b5fd60f9730d25cd339dc0ed91b0d13ed (diff)
downloadfreebsd-ports-gnome-47fedc331eab203d2d5895b62ce22efe75f05f94.tar.gz
freebsd-ports-gnome-47fedc331eab203d2d5895b62ce22efe75f05f94.tar.zst
freebsd-ports-gnome-47fedc331eab203d2d5895b62ce22efe75f05f94.zip
- Add cl-uffi-cmucl 1.4.37, Universal Foreign Function Interface for Common
Lisp (CMUCL-specific). PR: ports/72701 Submitted by: Matthew X. Economou <xenophon+fbsdports@irtnog.org>
Diffstat (limited to 'devel/cl-uffi-cmucl/Makefile')
-rw-r--r--devel/cl-uffi-cmucl/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/cl-uffi-cmucl/Makefile b/devel/cl-uffi-cmucl/Makefile
new file mode 100644
index 000000000000..675549c57361
--- /dev/null
+++ b/devel/cl-uffi-cmucl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection Makefile for: cl-uffi-cmucl
+# Date created: 19 August 2004
+# Whom: Matthew X. Economou <xenophon+fbsdports@irtnog.org>
+#
+# $FreeBSD$
+
+PORTNAME= uffi
+PORTVERSION= 1.4.37
+CATEGORIES= devel
+MASTER_SITES= http://files.b9.com/uffi/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -cmucl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= xenophon+fbsdports@irtnog.org
+COMMENT= Universal Foreign Function Interface for Common Lisp (CMU CL binaries)
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/uffi/uffi.asd:${PORTSDIR}/devel/cl-uffi \
+ ${LOCALBASE}/lib/common-lisp/asdf/cmuclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-cmucl \
+ lisp:${PORTSDIR}/lang/cmucl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/cmuclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-cmucl \
+ lisp:${PORTSDIR}/lang/cmucl
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ lisp -nositeinit -noinit \
+ -load ${LOCALBASE}/etc/asdf-init.lisp \
+ -eval "(asdf:oos 'asdf:compile-op :uffi)" \
+ -eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/uffi/src/cmuclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/uffi/src/cmuclfasl/
+
+.include <bsd.port.mk>