aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-uffi-sbcl
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 20:14:39 +0800
commitdb6c634e448bc8765cbc58ca91b1a4e4aa41610a (patch)
tree9c5ff04da0b9c023f86f7db9b932c7c9a9da8101 /devel/cl-uffi-sbcl
parente434a643efdf84c3dfcdc64e58706cc363f818d1 (diff)
downloadfreebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.gz
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.tar.zst
freebsd-ports-gnome-db6c634e448bc8765cbc58ca91b1a4e4aa41610a.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Diffstat (limited to 'devel/cl-uffi-sbcl')
-rw-r--r--devel/cl-uffi-sbcl/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/devel/cl-uffi-sbcl/Makefile b/devel/cl-uffi-sbcl/Makefile
index a087af427ed0..88746c9ae262 100644
--- a/devel/cl-uffi-sbcl/Makefile
+++ b/devel/cl-uffi-sbcl/Makefile
@@ -6,32 +6,24 @@
PORTNAME= uffi
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= devel lisp
-MASTER_SITES= # use installed sources from CL_LIBDIR
PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -sbcl
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Universal Foreign Function Interface for Common Lisp (SBCL binaries)
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/uffi/uffi.asd:${PORTSDIR}/devel/cl-uffi \
- sbcl:${PORTSDIR}/lang/sbcl
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
- sbcl:${PORTSDIR}/lang/sbcl
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/uffi/uffi.asd:${PORTSDIR}/devel/cl-uffi
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
-CL_LIBDIR?= ${LOCALBASE}/lib/common-lisp
-
-do-build:
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
- sbcl --noinform --userinit /dev/null --disable-debugger \
- --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
- --eval "(asdf:oos 'asdf:compile-op :uffi)" \
- --eval "(quit)"
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
do-install:
- @${MKDIR} ${CL_LIBDIR}/uffi/src/sbclfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${CL_LIBDIR}/uffi/src/sbclfasl/
+ @${MKDIR} ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
+ @${INSTALL_DATA} ${WRKSRC}/*.fasl ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>