aboutsummaryrefslogtreecommitdiffstats
path: root/devel/clanlib/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-09-24 21:01:39 +0800
committerkrion <krion@FreeBSD.org>2003-09-24 21:01:39 +0800
commitd189f8d1fc66bad92b6e1f8a3c9fe4175b29366f (patch)
treed66d3747ca4d7184188bf6ed4ea290269a893053 /devel/clanlib/Makefile
parent82298165d9c8b41854ab3f9713b69636780c0179 (diff)
downloadfreebsd-ports-gnome-d189f8d1fc66bad92b6e1f8a3c9fe4175b29366f.tar.gz
freebsd-ports-gnome-d189f8d1fc66bad92b6e1f8a3c9fe4175b29366f.tar.zst
freebsd-ports-gnome-d189f8d1fc66bad92b6e1f8a3c9fe4175b29366f.zip
- Update to version 0.7.4-1
PR: 57092 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'devel/clanlib/Makefile')
-rw-r--r--devel/clanlib/Makefile95
1 files changed, 73 insertions, 22 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 13af8cc2d8c1..a91fc25626e1 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -6,38 +6,89 @@
#
PORTNAME= clanlib
-PORTVERSION= 0.4.4
-PORTREVISION= 1
+PORTVERSION= 0.7.4.1
CATEGORIES= devel
-MASTER_SITES= http://dark.x.dtu.dk/~mbn/clanlib/download/
-DISTNAME= ClanLib-${PORTVERSION}
+MASTER_SITES= http://clanlib.org/~sphair/download/
+DISTNAME= ClanLib-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-platform game SDK
LIB_DEPENDS= Hermes.1:${PORTSDIR}/graphics/Hermes \
- png.5:${PORTSDIR}/graphics/png \
- vga.1:${PORTSDIR}/graphics/svgalib
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
-.if defined(WITHOUT_GL)
-CONFIGURE_ARGS+= --disable-opengl
+WRKSRC= ${WRKDIR}/ClanLib-${PORTVERSION:R}
+
+USE_BZIP2= yes
+USE_PERL5_BUILD= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-clanJavaScript --disable-docs
+INSTALLS_SHLIB= yes
+
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500032
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CPPFLAGS+= -I${LOCALBASE}/include/stlport
+LDFLAGS+= -lstlport_gcc
+CFLAGS+= -O0
+.endif
+
+.if defined(WITHOUT_SDL)
+CONFIGURE_ARGS+= --disable-clanSDL
+PLIST_SUB+= SDL="@comment "
+.else
+USE_SDL= yes
+CONFIGURE_ARGS+= --disable-sdltest
+PLIST_SUB+= SDL=""
+.endif
+
+.if defined(WITHOUT_OPENGL)
+CONFIGURE_ARGS+= --disable-clanGL
+PLIST_SUB+= OPENGL="@comment "
.else
USE_MESA= yes
-CONFIGURE_ARGS+= --enable-opengl
-PLIST= ${WRKDIR}/PLIST
+PLIST_SUB+= OPENGL=""
.endif
-USE_GMAKE= yes
-USE_XLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include"
-CFLAGS+= -fpermissive
-ALL_TARGET+= clanPNG clanGL
-
-.if !defined(WITHOUT_GL)
-pre-install:
- @cat ${PKGDIR}/pkg-plist.glx ${PKGDIR}/pkg-plist > ${PLIST}
+.if defined(WITHOUT_LIBMIKMOD)
+CONFIGURE_ARGS+= --disable-clanMikMod
+PLIST_SUB+= LIBMIKMOD="@comment "
+.else
+LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+PLIST_SUB+= LIBMIKMOD=""
.endif
-.include <bsd.port.mk>
+.if defined(WITHOUT_LIBVORBIS)
+CONFIGURE_ARGS+= --disable-clanVorbis
+PLIST_SUB+= LIBVORBIS="@comment "
+.else
+LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+PLIST_SUB+= LIBVORBIS=""
+.endif
+
+pre-everything:
+ @${ECHO_MSG} "ClanLib has the following tunables option(s):"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_SDL=yes Turns off SDL support"
+ @${ECHO_MSG} " WITHOUT_OPENGL=yes Turns off OpenGL support"
+ @${ECHO_MSG} " WITHOUT_LIBMIKMOD=yes Turns off libmikmod support"
+ @${ECHO_MSG} " WITHOUT_LIBVORBIS=yes Turns off libvorbis support"
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-lpthread||g'
+ @${REINPLACE_CMD} -e 's|@perl_exec@|${PERL}|g' \
+ ${WRKSRC}/Documentation/Utilities/webbuilder.pl.in
+
+.include <bsd.port.post.mk>