aboutsummaryrefslogtreecommitdiffstats
path: root/devel/clanlib22
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-13 11:50:33 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-13 11:50:33 +0800
commit47867b09b856196e56bb38abc6770419c738b529 (patch)
tree7479cd51feb4150541ff5402e2a0a9d9e93e1bf9 /devel/clanlib22
parent150d7f72b2526aa4d113c69a3713a93d6276bbcf (diff)
downloadfreebsd-ports-gnome-47867b09b856196e56bb38abc6770419c738b529.tar.gz
freebsd-ports-gnome-47867b09b856196e56bb38abc6770419c738b529.tar.zst
freebsd-ports-gnome-47867b09b856196e56bb38abc6770419c738b529.zip
- Don't specify protocol in socketpair(AF_UNIX, SOCK_DGRAM, ...), otherwise it fails with EPROTONOSUPPORT
MFH: 2015Q4
Diffstat (limited to 'devel/clanlib22')
-rw-r--r--devel/clanlib22/Makefile2
-rw-r--r--devel/clanlib22/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/clanlib22/Makefile b/devel/clanlib22/Makefile
index 2cb4882a07a9..728a5d06cc37 100644
--- a/devel/clanlib22/Makefile
+++ b/devel/clanlib22/Makefile
@@ -3,7 +3,7 @@
PORTNAME= clanlib
PORTVERSION= 2.2.12
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
DISTNAME= ClanLib-${PORTVERSION}
diff --git a/devel/clanlib22/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp b/devel/clanlib22/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp
new file mode 100644
index 000000000000..d33ae67cfa9f
--- /dev/null
+++ b/devel/clanlib22/files/patch-Sources_Core_System_Unix_event__provider_socketpair.cpp
@@ -0,0 +1,11 @@
+--- Sources/Core/System/Unix/event_provider_socketpair.cpp.orig 2011-01-13 11:17:34 UTC
++++ Sources/Core/System/Unix/event_provider_socketpair.cpp
+@@ -45,7 +45,7 @@ CL_EventProvider_Socketpair::CL_EventPro
+ // Not sure if its better to use 0 or PF_UNIX for Linux then. The
+ // documentation for socketpair is not that clear about the
+ // difference. -- mbn 15 april 2005
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ int result = socketpair(AF_UNIX, SOCK_DGRAM, 0, wait_sockets);
+ #else
+ int result = socketpair(AF_UNIX, SOCK_DGRAM, PF_UNIX, wait_sockets);