aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cld2
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2015-05-10 15:46:37 +0800
committerdemon <demon@FreeBSD.org>2015-05-10 15:46:37 +0800
commit940bc27caae13f80752180704fbd282432b45233 (patch)
treec70df297467de41272dfa0d3177b8bcb026a0770 /devel/cld2
parent97a2808ddff182aaad566dc142e0b8bad24695f7 (diff)
downloadfreebsd-ports-gnome-940bc27caae13f80752180704fbd282432b45233.tar.gz
freebsd-ports-gnome-940bc27caae13f80752180704fbd282432b45233.tar.zst
freebsd-ports-gnome-940bc27caae13f80752180704fbd282432b45233.zip
Rename cld --> cld2 (since it corresponds to version 2 of CLD).
Diffstat (limited to 'devel/cld2')
-rw-r--r--devel/cld2/Makefile30
-rw-r--r--devel/cld2/distinfo2
-rw-r--r--devel/cld2/pkg-descr6
-rw-r--r--devel/cld2/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/cld2/Makefile b/devel/cld2/Makefile
new file mode 100644
index 000000000000..5a7a536d2d1b
--- /dev/null
+++ b/devel/cld2/Makefile
@@ -0,0 +1,30 @@
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cld
+PORTVERSION= 20150505
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= demon
+PKGNAMESUFFIX= 2
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Compact language detector library
+
+LICENSE= APACHE20
+
+USE_LDCONFIG= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e "s#g++#${CXX}#" ${WRKSRC}/internal/compile_libs.sh
+
+do-build:
+ cd ${WRKSRC}/internal && ${SETENV} ${MAKE_ENV} ./compile_libs.sh
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/cld/public ${STAGEDIR}${PREFIX}/include/cld/internal
+ ${INSTALL_DATA} ${WRKSRC}/public/encodings.h ${WRKSRC}/public/compact_lang_det.h ${STAGEDIR}${PREFIX}/include/cld/public/
+ ${INSTALL_DATA} ${WRKSRC}/internal/lang_script.h ${WRKSRC}/internal/integral_types.h ${WRKSRC}/internal/generated_language.h ${WRKSRC}/internal/generated_ulscript.h ${STAGEDIR}${PREFIX}/include/cld/internal/
+ ${INSTALL_LIB} ${WRKSRC}/internal/libcld2.so ${WRKSRC}/internal/libcld2_full.so ${STAGEDIR}${PREFIX}/lib/
+
+.include <bsd.port.mk>
diff --git a/devel/cld2/distinfo b/devel/cld2/distinfo
new file mode 100644
index 000000000000..870c065f9168
--- /dev/null
+++ b/devel/cld2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cld-20150505.tar.gz) = 1671c31bc9ddb7b5ca6c765d4f8f388c43c4345c46551f12ed22e8cdc966fbf0
+SIZE (cld-20150505.tar.gz) = 71185464
diff --git a/devel/cld2/pkg-descr b/devel/cld2/pkg-descr
new file mode 100644
index 000000000000..4e7250f6d58f
--- /dev/null
+++ b/devel/cld2/pkg-descr
@@ -0,0 +1,6 @@
+A port from the CLD (Compact Language Detector) library embedded in
+Google's Chromium browser. The library detects the language from
+provided UTF8 text (plain text or HTML). It's implemented in C++,
+with very basic Python bindings.
+
+WWW: https://code.google.com/p/cld2/
diff --git a/devel/cld2/pkg-plist b/devel/cld2/pkg-plist
new file mode 100644
index 000000000000..269322566a95
--- /dev/null
+++ b/devel/cld2/pkg-plist
@@ -0,0 +1,8 @@
+include/cld/internal/generated_language.h
+include/cld/internal/generated_ulscript.h
+include/cld/internal/integral_types.h
+include/cld/internal/lang_script.h
+include/cld/public/compact_lang_det.h
+include/cld/public/encodings.h
+lib/libcld2.so
+lib/libcld2_full.so