aboutsummaryrefslogtreecommitdiffstats
path: root/devel/clewn
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2008-10-24 21:40:01 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2008-10-24 21:40:01 +0800
commit53c27988c064fb6a6b07ab212675e5d2a3746b85 (patch)
tree8417d94fbfdbf1844aca8af7555b6a06f64dc5ce /devel/clewn
parentbca677d1fd3f6d2af4df33bd7396a40c2d4ee094 (diff)
downloadfreebsd-ports-gnome-53c27988c064fb6a6b07ab212675e5d2a3746b85.tar.gz
freebsd-ports-gnome-53c27988c064fb6a6b07ab212675e5d2a3746b85.tar.zst
freebsd-ports-gnome-53c27988c064fb6a6b07ab212675e5d2a3746b85.zip
Clewn implements full gdb support in the vim editor: breakpoints,
watch variables, gdb command completion, assembly windows, etc. Clewn is a program controlling vim through the netBeans socket interface, it runs concurrently with vim and talks to vim. Clewn can only be used with gvim, the graphical implementation of vim, as vim on a terminal does not support netBeans. WWW: http://clewn.sourceforge.net/index.html PR: ports/128289 Submitted by: Giacomo Mariani <giacomomariani_at_yahoo_dot_it>
Diffstat (limited to 'devel/clewn')
-rw-r--r--devel/clewn/Makefile21
-rw-r--r--devel/clewn/distinfo3
-rw-r--r--devel/clewn/pkg-descr9
-rw-r--r--devel/clewn/pkg-plist11
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/clewn/Makefile b/devel/clewn/Makefile
new file mode 100644
index 000000000000..21bed3ce4b26
--- /dev/null
+++ b/devel/clewn/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: clewn
+# Date created: 21 Oct 2008
+# Whom: Giacomo Mariani <giacomomariani_at_yahoo_dot_it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clewn
+PORTVERSION= 1.14
+CATEGORIES= devel editors
+MASTER_SITES= SFE
+
+MAINTAINER= giacomomariani@yahoo.it
+COMMENT= Clewn provides Gdb support within Vim
+
+RUN_DEPENDS= vim>=6.3:${PORTSDIR}/editors/vim
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/clewn/distinfo b/devel/clewn/distinfo
new file mode 100644
index 000000000000..6d52ed3813ee
--- /dev/null
+++ b/devel/clewn/distinfo
@@ -0,0 +1,3 @@
+MD5 (clewn-1.14.tar.gz) = aa486604101d60930ea4cb76498be81f
+SHA256 (clewn-1.14.tar.gz) = f797b625371a34c9ed9404da911eb765f62b2513c4802629ab51bd99e84ec56f
+SIZE (clewn-1.14.tar.gz) = 200844
diff --git a/devel/clewn/pkg-descr b/devel/clewn/pkg-descr
new file mode 100644
index 000000000000..ca334484dbe4
--- /dev/null
+++ b/devel/clewn/pkg-descr
@@ -0,0 +1,9 @@
+Clewn implements full gdb support in the vim editor: breakpoints,
+watch variables, gdb command completion, assembly windows, etc.
+
+Clewn is a program controlling vim through the netBeans socket interface,
+it runs concurrently with vim and talks to vim.
+Clewn can only be used with gvim, the graphical implementation of vim,
+as vim on a terminal does not support netBeans.
+
+WWW: http://clewn.sourceforge.net/index.html
diff --git a/devel/clewn/pkg-plist b/devel/clewn/pkg-plist
new file mode 100644
index 000000000000..7da4a9fd1b17
--- /dev/null
+++ b/devel/clewn/pkg-plist
@@ -0,0 +1,11 @@
+bin/clewn
+share/vim/vimfiles/clewn.vim
+share/vim/vimfiles/.clewn_keys
+share/vim/vimfiles/doc/clewn.txt
+share/vim/vimfiles/doc/tags
+share/vim/vimfiles/macros/clewn_mappings.vim
+share/vim/vimfiles/syntax/gdbvar.vim
+@dirrm share/vim/vimfiles/macros
+@dirrm share/vim/vimfiles/doc
+@dirrm share/vim/vimfiles/syntax
+@dirrm share/vim/vimfiles