aboutsummaryrefslogtreecommitdiffstats
path: root/devel/clint/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /devel/clint/Makefile
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'devel/clint/Makefile')
-rw-r--r--devel/clint/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/clint/Makefile b/devel/clint/Makefile
index a7306ff0e1a7..f8ebc9e43514 100644
--- a/devel/clint/Makefile
+++ b/devel/clint/Makefile
@@ -16,18 +16,18 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A static source code checker for C++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_PYTHON= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure