aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cmake
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2011-09-11 10:04:09 +0800
committerrakuco <rakuco@FreeBSD.org>2011-09-11 10:04:09 +0800
commit5e71c8d732595c475439826ea7d1ec1e059434e2 (patch)
treefae647f5b04350263eef446351e2ad2c411a4980 /devel/cmake
parentaa5f8366cd154164cb59706ff4a592727ea5da4b (diff)
downloadfreebsd-ports-gnome-5e71c8d732595c475439826ea7d1ec1e059434e2.tar.gz
freebsd-ports-gnome-5e71c8d732595c475439826ea7d1ec1e059434e2.tar.zst
freebsd-ports-gnome-5e71c8d732595c475439826ea7d1ec1e059434e2.zip
- Remove the patch that was clearing default build flags for build
profiles, so that CMake can be used outside of ports. - Bump CMake PORTREVISION. - Pass default build flags (at least I hope) via bsd.cmake.mk. PR: 159276 Submitted by: Igor Soumenkov <2igosha@gmail.com> Approved by: avilla (mentor)
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile2
-rw-r--r--devel/cmake/files/patch-Modules_Compiler_GNU.cmake14
2 files changed, 1 insertions, 15 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index 49967a7e8a33..1118b8d3792d 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cmake
PORTVERSION= 2.8.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.${PORTNAME}.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/
diff --git a/devel/cmake/files/patch-Modules_Compiler_GNU.cmake b/devel/cmake/files/patch-Modules_Compiler_GNU.cmake
deleted file mode 100644
index 06a5aadf5f67..000000000000
--- a/devel/cmake/files/patch-Modules_Compiler_GNU.cmake
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./Modules/Compiler/GNU.cmake.orig 2011-02-15 20:47:27.000000000 +0300
-+++ ./Modules/Compiler/GNU.cmake 2011-04-09 13:43:24.030760248 +0400
-@@ -26,9 +26,9 @@
-
- # Initial configuration flags.
- set(CMAKE_${lang}_FLAGS_INIT "")
-- set(CMAKE_${lang}_FLAGS_DEBUG_INIT "-g")
-+ set(CMAKE_${lang}_FLAGS_DEBUG_INIT "")
- set(CMAKE_${lang}_FLAGS_MINSIZEREL_INIT "-Os -DNDEBUG")
-- set(CMAKE_${lang}_FLAGS_RELEASE_INIT "-O3 -DNDEBUG")
-+ set(CMAKE_${lang}_FLAGS_RELEASE_INIT "")
- set(CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT "-O2 -g")
- set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
- set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")