aboutsummaryrefslogtreecommitdiffstats
path: root/devel/commoncpp
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2005-11-06 03:02:30 +0800
committerarved <arved@FreeBSD.org>2005-11-06 03:02:30 +0800
commita94cb54d8c3b1f971f94ba1f47cedcb47a2eaf58 (patch)
tree1fa44a8cb23e6fbb0c2d2d9d3f6cf6c0327d2e1f /devel/commoncpp
parent6612f952fcae623aaceb73315485640d17abd859 (diff)
downloadfreebsd-ports-gnome-a94cb54d8c3b1f971f94ba1f47cedcb47a2eaf58.tar.gz
freebsd-ports-gnome-a94cb54d8c3b1f971f94ba1f47cedcb47a2eaf58.tar.zst
freebsd-ports-gnome-a94cb54d8c3b1f971f94ba1f47cedcb47a2eaf58.zip
Unbreak on CURRENT
Diffstat (limited to 'devel/commoncpp')
-rw-r--r--devel/commoncpp/Makefile4
-rw-r--r--devel/commoncpp/files/patch-src_mutex.cpp11
2 files changed, 11 insertions, 4 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 113002ca2ac4..cde9380eae6c 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -38,10 +38,6 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700000
-BROKEN= "Does not compile on FreeBSD >= 7.0"
-.endif
-
pre-configure:
@${CP} ${LTMAIN} ${WRKSRC}/autoconf
diff --git a/devel/commoncpp/files/patch-src_mutex.cpp b/devel/commoncpp/files/patch-src_mutex.cpp
new file mode 100644
index 000000000000..8c8be2a62cb7
--- /dev/null
+++ b/devel/commoncpp/files/patch-src_mutex.cpp
@@ -0,0 +1,11 @@
+--- src/mutex.cpp.orig Sat Nov 5 19:54:24 2005
++++ src/mutex.cpp Sat Nov 5 19:59:01 2005
+@@ -48,6 +48,8 @@
+ using namespace __gnu_cxx;
+ #endif
+
++using namespace std;
++
+ #ifdef CCXX_NAMESPACES
+ namespace ost {
+ #endif