aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cpan-upload
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-12-19 17:11:33 +0800
committererwin <erwin@FreeBSD.org>2003-12-19 17:11:33 +0800
commit22496495a6b0dbbb7802c83fd0de4b7353fe7139 (patch)
treec9cac57a67df2bfde60849e28aa139b2fbdca213 /devel/cpan-upload
parenteb01f03a797c2e081e6f16a4e6adf702376fa0ed (diff)
downloadfreebsd-ports-gnome-22496495a6b0dbbb7802c83fd0de4b7353fe7139.tar.gz
freebsd-ports-gnome-22496495a6b0dbbb7802c83fd0de4b7353fe7139.tar.zst
freebsd-ports-gnome-22496495a6b0dbbb7802c83fd0de4b7353fe7139.zip
Add cpan-upload 2.2, script for uploading distributions to CPAN.
PR: 59850 Submitted by: Lars Thegler <lars@thegler.dk>
Diffstat (limited to 'devel/cpan-upload')
-rw-r--r--devel/cpan-upload/Makefile28
-rw-r--r--devel/cpan-upload/distinfo1
-rw-r--r--devel/cpan-upload/pkg-descr2
-rw-r--r--devel/cpan-upload/pkg-plist3
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/cpan-upload/Makefile b/devel/cpan-upload/Makefile
new file mode 100644
index 000000000000..d2bd442d8c28
--- /dev/null
+++ b/devel/cpan-upload/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: cpan-upload
+# Date created: Nov 30 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpan-upload
+PORTVERSION= 2.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NE/NEILB/scripts/
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Script for uploading distributions to CPAN
+
+BUILD_DEPENDS= ${SITE_PERL}/AppConfig/Std.pm:${PORTSDIR}/devel/p5-AppConfig-Std \
+ ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= cpan-upload.1
+
+.include <bsd.port.mk>
diff --git a/devel/cpan-upload/distinfo b/devel/cpan-upload/distinfo
new file mode 100644
index 000000000000..dbaacf0295cc
--- /dev/null
+++ b/devel/cpan-upload/distinfo
@@ -0,0 +1 @@
+MD5 (cpan-upload-2.2.tar.gz) = e900a0b3e78f9f2a4dabc1d1b5e1cdb6
diff --git a/devel/cpan-upload/pkg-descr b/devel/cpan-upload/pkg-descr
new file mode 100644
index 000000000000..8fe3a5a7eaff
--- /dev/null
+++ b/devel/cpan-upload/pkg-descr
@@ -0,0 +1,2 @@
+This is a script for uploading one or more distributions to CPAN
+using PAUSE, the Perl Authors Upload SErver.
diff --git a/devel/cpan-upload/pkg-plist b/devel/cpan-upload/pkg-plist
new file mode 100644
index 000000000000..3a986458dc8c
--- /dev/null
+++ b/devel/cpan-upload/pkg-plist
@@ -0,0 +1,3 @@
+bin/cpan-upload
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/cpan-upload/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/cpan-upload