aboutsummaryrefslogtreecommitdiffstats
path: root/devel/critcl
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-09-02 02:18:51 +0800
committeradamw <adamw@FreeBSD.org>2014-09-02 02:18:51 +0800
commitd9af679efa65bf1b96a675d35d9be7475c39fa94 (patch)
tree8ea791da50557750c88d36748e710a32025d6ed9 /devel/critcl
parent7f27183f90ab3f17abf71218a402731b879a2ea8 (diff)
downloadfreebsd-ports-gnome-d9af679efa65bf1b96a675d35d9be7475c39fa94.tar.gz
freebsd-ports-gnome-d9af679efa65bf1b96a675d35d9be7475c39fa94.tar.zst
freebsd-ports-gnome-d9af679efa65bf1b96a675d35d9be7475c39fa94.zip
Wrap compound statements and use '.' instead of '\*' in COPYTREE_SHARE.
The underlying problem that caused the build failures (tcl modules) has already been fixed, but the problem exposed another failure when \* was used to match nothing.
Diffstat (limited to 'devel/critcl')
-rw-r--r--devel/critcl/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/critcl/Makefile b/devel/critcl/Makefile
index c2c11678e9c2..403ffbbb8308 100644
--- a/devel/critcl/Makefile
+++ b/devel/critcl/Makefile
@@ -34,12 +34,12 @@ post-patch:
do-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${TCLSH} build.tcl doc
- cd ${WRKSRC}/embedded/www && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${TCLSH} build.tcl doc)
+ (cd ${WRKSRC}/embedded/www && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.endif
- cd ${WRKSRC} && ${TCLSH} build.tcl install ${STAGEDIR}${PREFIX}/lib
+ (cd ${WRKSRC} && ${TCLSH} build.tcl install ${STAGEDIR}${PREFIX}/lib)
regression-test:
- cd ${WRKSRC} && ${TCLSH} test/all.tcl
+ (cd ${WRKSRC} && ${TCLSH} test/all.tcl)
.include <bsd.port.mk>