aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cscout
diff options
context:
space:
mode:
authordds <dds@FreeBSD.org>2006-10-02 17:56:09 +0800
committerdds <dds@FreeBSD.org>2006-10-02 17:56:09 +0800
commit568bb21807a71f297c0975f67bc2f563ea388545 (patch)
treeae758e7b333c77da2e6095b2676e86f978c00871 /devel/cscout
parent01ada3c619b7567cb914ecfef82ce8a2bfcd5905 (diff)
downloadfreebsd-ports-gnome-568bb21807a71f297c0975f67bc2f563ea388545.tar.gz
freebsd-ports-gnome-568bb21807a71f297c0975f67bc2f563ea388545.tar.zst
freebsd-ports-gnome-568bb21807a71f297c0975f67bc2f563ea388545.zip
Update for CScout version 2.2
Version 2.2 includes numerous fixes and the following enahncements. - All query results are presented through a page selection interface. - Identical files in different locations are identified and presented in the file information page and through the file metrics. - Identifiers occuring at the same place in identical files are considered to be the same. - Facility to display the call path from one function to another. - New option to display call graphs as GIF images avoiding the need for an SVG plugin for medium-sized graphs. - The SQL backend supports four additional tables: STRINGS, COMMENTS, FILEPOS, FILECOPIES. - Allow attribute declarations to follow labels (gcc extension). - Support indirect goto labels (gcc extension). - Support (ANSI-style) nested function definitions (gcc extension). - The macro expansion algorithm follows more closely the C standard specification. - Allow braces around scalar initializers (common extension). - Macro calls in function arguments now get recorded as calls from the enclosing function, rather than the function being called. - Significantly faster file post-processing for the web and the SQL interface in large projects. - Array designators can be denoted through a range (gcc extension). - Support for symbolic operands in gcc asm constructs. - Allow __typeof__ declarations to be preceded by type qualifiers. - Correctly handle __typeof__ of objects with a storage class within typedef declarations. - The order of include file searching now matches more closely that of other compilers: absolute file names are never searched in the include file path, and non-system files are first searched relative to the directory of the including file. - Allow empty initializers and compound literals. (gcc extension) - Support for the alignof operator (gcc extension) - The equals sign following an initializer designator is optional (gcc extension). - A declaration expression can be used as the first expression of a for statement. (C99) - __typeof can also have as its argument a type name - Support for designators in compound literals. (C99)
Diffstat (limited to 'devel/cscout')
-rw-r--r--devel/cscout/Makefile9
-rw-r--r--devel/cscout/distinfo30
-rw-r--r--devel/cscout/pkg-descr7
-rw-r--r--devel/cscout/pkg-plist28
4 files changed, 44 insertions, 30 deletions
diff --git a/devel/cscout/Makefile b/devel/cscout/Makefile
index 8841bc1e68ae..05bea961fe26 100644
--- a/devel/cscout/Makefile
+++ b/devel/cscout/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= cscout
-PORTVERSION= 1.16
+PORTVERSION= 2.2
CATEGORIES= devel
MASTER_SITES= http://www.spinellis.gr/cscout/ \
http://www.dmst.aueb.gr/dds/cscout/
DISTFILES= ${PORTNAME}-${PORTVERSION}-neutral${EXTRACT_SUFX} \
- ${PORTNAME}-${PORTVERSION}-freebsd-${ARCH}${EXTRACT_SUFX}
+ ${PORTNAME}-${PORTVERSION}-fbsd-${ARCH}${EXTRACT_SUFX}
MAINTAINER= dds@FreeBSD.org
-COMMENT= Source code analyzer and refactoring browser for collections of C programs
+COMMENT= Source code analyzer and refactoring browser for C program collections
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
MAN1= cscout.1 cswc.1
@@ -37,6 +37,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/cscout ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/bin/cswc ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/csmake ${PREFIX}/bin
cd ${WRKSRC}/etc && ${FIND} . -print | \
${CPIO} -pdu -R ${BINOWN}:${BINGRP} --quiet ${PREFIX}/etc/${PORTNAME}
# don't overwrite an existing config
diff --git a/devel/cscout/distinfo b/devel/cscout/distinfo
index 820d6b609505..37fc6ebd5ca1 100644
--- a/devel/cscout/distinfo
+++ b/devel/cscout/distinfo
@@ -1,18 +1,12 @@
-MD5 (cscout-1.16-freebsd-alpha.tar.gz) = d0bac4df660922abeaa94cc827b2f081
-SHA256 (cscout-1.16-freebsd-alpha.tar.gz) = 3395510dc77a3f5234252f1044ab61fe3681b9f212918777395f94dfc777e8f3
-SIZE (cscout-1.16-freebsd-alpha.tar.gz) = 803384
-MD5 (cscout-1.16-freebsd-amd64.tar.gz) = ea144775aedef78eceab2eba5f753fed
-SHA256 (cscout-1.16-freebsd-amd64.tar.gz) = 03209240ef0bd067816fb112c86df4ec07eca781cf708d2e6f01a708f6cbc313
-SIZE (cscout-1.16-freebsd-amd64.tar.gz) = 678757
-MD5 (cscout-1.16-freebsd-i386.tar.gz) = 84ae5d46d02dafae695f548757216a99
-SHA256 (cscout-1.16-freebsd-i386.tar.gz) = 2a943414894c5c01296856dfa8744b18a24aa2e4d7d727040b94dfecb729b2a8
-SIZE (cscout-1.16-freebsd-i386.tar.gz) = 520730
-MD5 (cscout-1.16-freebsd-ia64.tar.gz) = 62e197b56774d37dc2522d182ecec5bd
-SHA256 (cscout-1.16-freebsd-ia64.tar.gz) = 00e7fe68a4602ccbfbbcf8dba01f277aad5c4a32ce9172ddd4dab69e8c253879
-SIZE (cscout-1.16-freebsd-ia64.tar.gz) = 1039575
-MD5 (cscout-1.16-freebsd-sparc64.tar.gz) = 0571bc2629fd3a041629c43d68d917aa
-SHA256 (cscout-1.16-freebsd-sparc64.tar.gz) = 68f91d956f6e526295f26853d8d4ea61dbc0a5f416b436b8158e13376f9c5d26
-SIZE (cscout-1.16-freebsd-sparc64.tar.gz) = 645968
-MD5 (cscout-1.16-neutral.tar.gz) = a848f77d5ad53647f9ae30f2e07f36fe
-SHA256 (cscout-1.16-neutral.tar.gz) = e677c8e39a229ba37f52c3352f32d78851ba33aea9cc72a0d5c8bf7c0915eaa1
-SIZE (cscout-1.16-neutral.tar.gz) = 215732
+MD5 (cscout-2.2-fbsd-i386.tar.gz) = 8304fae9f07077ef55561d38e5afc04c
+SHA256 (cscout-2.2-fbsd-i386.tar.gz) = e83c8af76144b2fd64d5b6d1d7dd6575ce47a3e588a7972853364655c2f9e30a
+SIZE (cscout-2.2-fbsd-i386.tar.gz) = 502605
+MD5 (cscout-2.2-fbsd-amd64.tar.gz) = 149b8c2463ae5b39418fdf30374ebbd3
+SHA256 (cscout-2.2-fbsd-amd64.tar.gz) = 1edb4cdee24ff4e241930cf3c3c3224926a3969f2891ade221d2d4382053b8b7
+SIZE (cscout-2.2-fbsd-amd64.tar.gz) = 527115
+MD5 (cscout-2.2-fbsd-sparc64.tar.gz) = 8174696d72d043d23828505bd119af36
+SHA256 (cscout-2.2-fbsd-sparc64.tar.gz) = 19a252d947616932af3cac60eee3bbeedb1ad50d4012af70aa163684e1beea2d
+SIZE (cscout-2.2-fbsd-sparc64.tar.gz) = 533827
+MD5 (cscout-2.2-neutral.tar.gz) = c1660fee01756a792ea64b3686f577b6
+SHA256 (cscout-2.2-neutral.tar.gz) = 422e560e363cbcd9ea8aadbf7868cdd6d0c513942cd43ccfd3edb7801bf1aa8c
+SIZE (cscout-2.2-neutral.tar.gz) = 312888
diff --git a/devel/cscout/pkg-descr b/devel/cscout/pkg-descr
index 83fa3b83bbcd..13ba8383efcd 100644
--- a/devel/cscout/pkg-descr
+++ b/devel/cscout/pkg-descr
@@ -9,11 +9,8 @@ of detail and accuracy provided by current compilers and linkers.
The analysis CScout performs takes into account the identifier
scopes introduced by the C preprocessor and the C language proper
scopes and namespaces. CScout has already been applied on projects
-ranging from tens of thousands of lines, like the apache web server
-(using 36MB of memory, taking 6 minutes on a 500MHz Celeron processor),
-to above a million lines of code, like the FreeBSD kernel (using
-813MB of memory, taking 3 hours 42 minutes on a 900MHz Itanium 2
-processor).
+ranging from tens of thousands of lines, like the FreeBSD and
+Linux kernels, and the Apache web server.
This free unsupported version of CScout is distributed under the terms
of the CScout Public License, which is available in the accompanying
diff --git a/devel/cscout/pkg-plist b/devel/cscout/pkg-plist
index feb00a1649ca..6765a69d35d7 100644
--- a/devel/cscout/pkg-plist
+++ b/devel/cscout/pkg-plist
@@ -1,10 +1,13 @@
bin/cscout
+bin/csmake
bin/cswc
@unexec if cmp -s %D/etc/cscout/cscout_defs.h %D/etc/cscout/cscout_defs.FBSD_GCC; then rm -f %D/etc/cscout/cscout_defs.h; fi
@unexec if cmp -s %D/etc/cscout/cscout_incs.h %D/etc/cscout/cscout_incs.FBSD_GCC; then rm -f %D/etc/cscout/cscout_incs.h; fi
+etc/cscout/acl
etc/cscout/cscout_defs.BORLAND
etc/cscout/cscout_defs.FBSD_GCC
etc/cscout/cscout_defs.GENERIC
+etc/cscout/cscout_defs.GENERIC_GCC
etc/cscout/cscout_defs.LINUX_GCC
etc/cscout/cscout_defs.WIN32_MINGW
etc/cscout/cscout_defs.WIN32_MSC
@@ -15,14 +18,25 @@ etc/cscout/cscout_incs.WIN32_MINGW
etc/cscout/cscout_incs.WIN32_MSC
@dirrmtry etc/cscout
%%PORTDOCS%%%%DOCSDIR%%/access.html
+%%PORTDOCS%%%%DOCSDIR%%/bib.html
+%%PORTDOCS%%%%DOCSDIR%%/cg.html
+%%PORTDOCS%%%%DOCSDIR%%/change.html
+%%PORTDOCS%%%%DOCSDIR%%/concept.html
%%PORTDOCS%%%%DOCSDIR%%/contents.html
+%%PORTDOCS%%%%DOCSDIR%%/copy_file.gif
+%%PORTDOCS%%%%DOCSDIR%%/csmake.html
%%PORTDOCS%%%%DOCSDIR%%/cvs.html
+%%PORTDOCS%%%%DOCSDIR%%/dbschema.html
%%PORTDOCS%%%%DOCSDIR%%/egglos.html
%%PORTDOCS%%%%DOCSDIR%%/error.html
%%PORTDOCS%%%%DOCSDIR%%/ext.html
%%PORTDOCS%%%%DOCSDIR%%/faq.html
%%PORTDOCS%%%%DOCSDIR%%/file.html
-%%PORTDOCS%%%%DOCSDIR%%/fq.html
+%%PORTDOCS%%%%DOCSDIR%%/fileq.html
+%%PORTDOCS%%%%DOCSDIR%%/flow.gif
+%%PORTDOCS%%%%DOCSDIR%%/flow.html
+%%PORTDOCS%%%%DOCSDIR%%/fun.html
+%%PORTDOCS%%%%DOCSDIR%%/funq.html
%%PORTDOCS%%%%DOCSDIR%%/geglos.html
%%PORTDOCS%%%%DOCSDIR%%/id.html
%%PORTDOCS%%%%DOCSDIR%%/idq.html
@@ -31,25 +45,34 @@ etc/cscout/cscout_incs.WIN32_MSC
%%PORTDOCS%%%%DOCSDIR%%/indexw.html
%%PORTDOCS%%%%DOCSDIR%%/intro.html
%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/maincall.gif
%%PORTDOCS%%%%DOCSDIR%%/mancscout.html
%%PORTDOCS%%%%DOCSDIR%%/mancswc.html
+%%PORTDOCS%%%%DOCSDIR%%/mismash.gif
%%PORTDOCS%%%%DOCSDIR%%/name.html
+%%PORTDOCS%%%%DOCSDIR%%/obf.html
%%PORTDOCS%%%%DOCSDIR%%/op.html
%%PORTDOCS%%%%DOCSDIR%%/opt.html
+%%PORTDOCS%%%%DOCSDIR%%/optf.html
%%PORTDOCS%%%%DOCSDIR%%/pragma.html
+%%PORTDOCS%%%%DOCSDIR%%/qeg.html
%%PORTDOCS%%%%DOCSDIR%%/re.html
%%PORTDOCS%%%%DOCSDIR%%/run.html
+%%PORTDOCS%%%%DOCSDIR%%/setfile.gif
%%PORTDOCS%%%%DOCSDIR%%/setup.html
%%PORTDOCS%%%%DOCSDIR%%/short.html
%%PORTDOCS%%%%DOCSDIR%%/simul.html
+%%PORTDOCS%%%%DOCSDIR%%/smlogo.png
+%%PORTDOCS%%%%DOCSDIR%%/sql.html
%%PORTDOCS%%%%DOCSDIR%%/walk.html
%%PORTDOCS%%%%DOCSDIR%%/web.html
%%PORTDOCS%%%%DOCSDIR%%/wsp.html
+%%PORTDOCS%%%%DOCSDIR%%/wspd.html
%%PORTDOCS%%%%DOCSDIR%%/yacc.html
-%%PORTDOCS%%%%DOCSDIR%%/change.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%%%EXAMPLESDIR%%/.cscout/cscout_defs.h
%%PORTDOCS%%%%EXAMPLESDIR%%/.cscout/cscout_incs.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/.cscout/options
%%PORTDOCS%%%%EXAMPLESDIR%%/README
%%PORTDOCS%%%%EXAMPLESDIR%%/awk.cs
%%PORTDOCS%%%%EXAMPLESDIR%%/awk.prj
@@ -81,7 +104,6 @@ etc/cscout/cscout_incs.WIN32_MSC
%%PORTDOCS%%%%EXAMPLESDIR%%/bin.prj
%%PORTDOCS%%%%EXAMPLESDIR%%/mkproj
%%PORTDOCS%%%%EXAMPLESDIR%%/sh.prj
-%%PORTDOCS%%%%EXAMPLESDIR%%/FreeBSD-kernel-4.8.cs
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/.cscout
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/awk
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%